busybox: fix installation of cron and ntpd scripts in the default config
authorFelix Fietkau <nbd@nbd.name>
Tue, 4 Apr 2017 13:05:11 +0000 (15:05 +0200)
committerFelix Fietkau <nbd@nbd.name>
Tue, 4 Apr 2017 13:06:14 +0000 (15:06 +0200)
Fixes: 0b24850e9778 ("busybox: don't install NTP scripts if NTP isn't configured")
Signed-off-by: Felix Fietkau <nbd@nbd.name>
package/utils/busybox/Makefile

index 48d945718a09a30bade49f33c159b8405d2f16cc..be4b967a47d4818961ab88172d978e942f9faec7 100644 (file)
@@ -112,10 +112,10 @@ endef
 define Package/busybox/install
        $(INSTALL_DIR) $(1)/etc/init.d
        $(CP) $(PKG_INSTALL_DIR)/* $(1)/
-ifneq ($(CONFIG_BUSYBOX_CONFIG_CROND),)
+ifneq ($(CONFIG_BUSYBOX_$(BUSYBOX_SYM)_CROND),)
        $(INSTALL_BIN) ./files/cron $(1)/etc/init.d/cron
 endif
-ifneq ($(CONFIG_BUSYBOX_CONFIG_NTPD),)
+ifneq ($(CONFIG_BUSYBOX_$(BUSYBOX_SYM)_NTPD),)
        $(INSTALL_BIN) ./files/sysntpd $(1)/etc/init.d/sysntpd
        $(INSTALL_BIN) ./files/ntpd-hotplug $(1)/usr/sbin/ntpd-hotplug
 endif