ath10k: remove support for the obsolete STA firmware
authorFelix Fietkau <nbd@openwrt.org>
Mon, 6 Jul 2015 10:21:26 +0000 (10:21 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 6 Jul 2015 10:21:26 +0000 (10:21 +0000)
Current firmware should work for station mode as well, and the older
firmware will usually behave worse and become unsupported over time.
Also, the MAC address handling on ar71xx is only implemented on one
firmware version.

Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 46197

package/kernel/mac80211/Makefile

index de82118b02de1bfd14653ec1aa664ebb4c69e9d4..f7f740172845fd48322f4ae4ecda57aefd4c7962 100644 (file)
@@ -621,19 +621,6 @@ Atheros IEEE 802.11ac family of chipsets. For now only
 PCI is supported.
 endef
 
-define KernelPackage/ath10k/config
-  if PACKAGE_kmod-ath10k
-
-       config ATH10K_STA_FW
-               bool "Firmware optimized for STA operation"
-               default n
-               help
-                 Use the ath10k firmware optimized for wireless client instead
-                 of access point operation.
-
-  endif
-endef
-
 define KernelPackage/carl9170
   $(call KernelPackage/mac80211/Default)
   TITLE:=Driver for Atheros AR9170 USB sticks
@@ -1858,15 +1845,9 @@ define KernelPackage/ath10k/install
        $(INSTALL_DATA) \
                $(PKG_BUILD_DIR)/$(PKG_ATH10K_LINUX_FIRMWARE_SUBDIR)/ath10k/QCA988X/hw2.0/board.bin \
                $(1)/lib/firmware/ath10k/QCA988X/hw2.0/
-ifeq ($(CONFIG_ATH10K_STA_FW),y)
-       $(INSTALL_DATA) \
-               $(PKG_BUILD_DIR)/$(PKG_ATH10K_LINUX_FIRMWARE_SUBDIR)/main/firmware-2.bin_999.999.0.636 \
-               $(1)/lib/firmware/ath10k/QCA988X/hw2.0/firmware-2.bin
-else
        $(INSTALL_DATA) \
                $(PKG_BUILD_DIR)/$(PKG_ATH10K_LINUX_FIRMWARE_SUBDIR)/10.2.4/untested/firmware-5.bin_10.2.4.70-2 \
                $(1)/lib/firmware/ath10k/QCA988X/hw2.0/firmware-5.bin
-endif
 endef
 
 define KernelPackage/mwl8k/install