Add optionnal support for a BUILD_DIR suffix (#2057)
authorFlorian Fainelli <florian@openwrt.org>
Thu, 19 Jul 2007 12:09:52 +0000 (12:09 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Thu, 19 Jul 2007 12:09:52 +0000 (12:09 +0000)
SVN-Revision: 8050

Config.in
rules.mk

index 705c24ad2fd74e828faacf1a4f68e03f25929696..5518290f4845141a669006bfef00e5e7afc26ab5 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -123,6 +123,13 @@ config SOURCE_FEEDS
        help
                Separate sources with spaces : " "
 
+config BUILD_SUFFIX
+       string
+       prompt "Build suffix to append to the BUILD_DIR variable" if BUILDOPTS
+       default ""
+       help
+               Build suffix to append to the BUILD_DIR variable, i.e: build_dir_suffix
+
 source "toolchain/Config.in"
 source "target/imagebuilder/Config.in"
 source "target/sdk/Config.in"
index 6fbf88f801f21113335ed2e733670d966479d447..4d6c7d0986dccc28f40d5ed2a90377918e7b566d 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -14,6 +14,7 @@ export SHELL=/usr/bin/env bash -c '. $(TOPDIR)/include/shell.sh; eval "$$2"' --
 
 ARCH:=$(strip $(subst ",, $(CONFIG_ARCH)))
 TARGET_OPTIMIZATION:=$(strip $(subst ",, $(CONFIG_TARGET_OPTIMIZATION)))
+BUILD_DIR_SUFFIX:=$(strip $(subst ",, $(CONFIG_BUILD_SUFFIX)))
 WGET:=$(strip $(subst ",, $(CONFIG_WGET)))
 #"))"))")) # fix vim's broken syntax highlighting
 
@@ -30,7 +31,7 @@ STAGING_DIR:=$(TOPDIR)/staging_dir_$(ARCH)
 BIN_DIR:=$(TOPDIR)/bin
 PACKAGE_DIR:=$(BIN_DIR)/packages
 IPKG_TARGET_DIR:=$(PACKAGE_DIR)
-BUILD_DIR:=$(TOPDIR)/build_$(ARCH)
+BUILD_DIR:=$(TOPDIR)/build_$(ARCH)$(BUILD_DIR_SUFFIX)
 TMP_DIR:=$(TOPDIR)/tmp
 STAMP_DIR:=$(BUILD_DIR)/stamp
 TARGET_DIR:=$(BUILD_DIR)/root