resolveip: fix endless getopt() loop when compiled for arm (#12290)
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 8 Nov 2012 10:48:08 +0000 (10:48 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 8 Nov 2012 10:48:08 +0000 (10:48 +0000)
SVN-Revision: 34116

package/network/utils/resolveip/Makefile
package/network/utils/resolveip/src/resolveip.c

index 4b3e3d4da61cdd00da6e2808a64bc0a547603686..d1e675e428d8a17d3dc734568a23d60a8a4557a5 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2011 OpenWrt.org
+# Copyright (C) 2011-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=resolveip
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 include $(INCLUDE_DIR)/package.mk
 
index 310f35ffd5e55741d4f35f3a41c6b89ca8f51890..43c5ae7f1296570ddcd64082bc507012e43dfb05 100644 (file)
@@ -35,7 +35,7 @@ static void show_usage(void)
 int main(int argc, char **argv)
 {
        int timeout = 3;
-       char opt;
+       int opt;
        char ipaddr[INET6_ADDRSTRLEN];
        void *addr;
        struct addrinfo *res, *rp;
@@ -49,7 +49,7 @@ int main(int argc, char **argv)
 
        while ((opt = getopt(argc, argv, "46t:h")) > -1)
        {
-               switch (opt)
+               switch ((char)opt)
                {
                        case '4':
                                hints.ai_family = AF_INET;