package-ipkg.sh: copy the package provides list for all virtual PROVIDES
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 13 Jun 2012 11:42:17 +0000 (11:42 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 13 Jun 2012 11:42:17 +0000 (11:42 +0000)
SVN-Revision: 32332

include/package-ipkg.mk

index e9bac7a23be9a3d3b5d75eeb246ac3daeb64d02c..7ff3f6e23aaf3915c3a36e5603a28fd623fd21cd 100644 (file)
@@ -144,6 +144,7 @@ ifeq ($(DUMP),)
                        fi; \
                done; \
        ) | sort -u > $(PKG_INFO_DIR)/$(1).provides
+       $(if $(PROVIDES),@for pkg in $(PROVIDES); do cp $(PKG_INFO_DIR)/$(1).provides $(PKG_INFO_DIR)/$$pkg.provides; done)
        $(CheckDependencies)
 
        $(RSTRIP) $$(IDIR_$(1))