move rule for $(STAGING_DIR)/etc/ipkg.conf out of BuildIPKG so that it's defined...
authorNicolas Thill <nico@openwrt.org>
Sun, 26 Aug 2007 12:42:48 +0000 (12:42 +0000)
committerNicolas Thill <nico@openwrt.org>
Sun, 26 Aug 2007 12:42:48 +0000 (12:42 +0000)
SVN-Revision: 8491

include/package-ipkg.mk

index c67ee4b8aee21e413348f43d0dc59d248108a196..cc9a780147fe928be85bff8ba94eacaea88213ca 100644 (file)
@@ -71,11 +71,6 @@ ifeq ($(DUMP),)
     $$(INFO_$(1)): $$(IPKG_$(1))
        $(IPKG) install $$(IPKG_$(1))
 
-    $(STAGING_DIR)/etc/ipkg.conf:
-       mkdir -p $(STAGING_DIR)/etc
-       echo "dest root /" > $(STAGING_DIR)/etc/ipkg.conf
-       echo "option offline_root $(TARGET_DIR)" >> $(STAGING_DIR)/etc/ipkg.conf
-
     $(1)-clean:
        rm -f $(PACKAGE_DIR)/$(1)_*
 
@@ -88,4 +83,10 @@ ifeq ($(DUMP),)
     $$(eval $$(call Build/DefaultTargets,$(1)))
 
   endef
+
+  $(STAGING_DIR)/etc/ipkg.conf:
+       mkdir -p $(STAGING_DIR)/etc
+       echo "dest root /" > $(STAGING_DIR)/etc/ipkg.conf
+       echo "option offline_root $(TARGET_DIR)" >> $(STAGING_DIR)/etc/ipkg.conf
+
 endif