kernel: add kirkwood thermal module
authorLuka Perkov <luka@openwrt.org>
Sat, 12 Oct 2013 16:26:55 +0000 (16:26 +0000)
committerLuka Perkov <luka@openwrt.org>
Sat, 12 Oct 2013 16:26:55 +0000 (16:26 +0000)
Signed-off-by: Luka Perkov <luka@openwrt.org>
SVN-Revision: 38371

package/kernel/linux/modules/other.mk

index 65f2975a2bb27954e8c80c6db7abdd1c10e5bf75..453bedfc20264fa2aeb13c6b4a384a0f2d452b67 100644 (file)
@@ -824,3 +824,20 @@ define KernelPackage/thermal-imx/description
 endef
 
 $(eval $(call KernelPackage,thermal-imx))
+
+
+define KernelPackage/thermal-kirkwood
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=Temperature sensor on Marvell Kirkwood SoCs
+  DEPENDS:=@TARGET_kirkwood +kmod-thermal
+  KCONFIG:=CONFIG_KIRKWOOD_THERMAL
+  FILES:=$(LINUX_DIR)/drivers/thermal/kirkwood_thermal.ko
+  AUTOLOAD:=$(call AutoProbe,kirkwood_thermal)
+endef
+
+define KernelPackage/thermal-kirkwood/description
+ Support for the Kirkwood thermal sensor driver into the Linux thermal
+ framework. Only kirkwood 88F6282 and 88F6283 have this sensor.
+endef
+
+$(eval $(call KernelPackage,thermal-kirkwood))