kernel: add random-omap rng for omap
authorAlexander Couzens <lynxis@fe80.eu>
Sat, 28 May 2016 22:41:30 +0000 (00:41 +0200)
committerAlexander Couzens <lynxis@fe80.eu>
Thu, 2 Jun 2016 19:58:10 +0000 (21:58 +0200)
Kernel module for the OMAP Random Number Generator
found on OMAP16xx, OMAP2/3/4/5 and AM33xx/AM43xx
multimedia processors.

Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
package/kernel/linux/modules/other.mk

index 98b7f54dcf8ec8d6371f754a758ede1bb72fc7d2..11d836e5f72007309c92a957788ad8d76f4fdb28 100644 (file)
@@ -874,6 +874,21 @@ endef
 
 $(eval $(call KernelPackage,random-core))
 
+define KernelPackage/random-omap
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=Hardware Random Number Generator OMAP support
+  KCONFIG:=CONFIG_HW_RANDOM_OMAP
+  FILES:=$(LINUX_DIR)/drivers/char/hw_random/omap-rng.ko
+  DEPENDS:=@(TARGET_omap24xx||TARGET_omap) +kmod-random-core
+  AUTOLOAD:=$(call AutoProbe,random-omap)
+endef
+
+define KernelPackage/random-omap/description
+ Kernel module for the OMAP Random Number Generator
+ found on OMAP16xx, OMAP2/3/4/5 and AM33xx/AM43xx multimedia processors.
+endef
+
+$(eval $(call KernelPackage,random-omap))
 
 define KernelPackage/thermal
   SUBMENU:=$(OTHER_MENU)