x86: add kmod-acpi-button and kmod-button-hotplug to default packages
authorJohn Crispin <john@openwrt.org>
Tue, 14 Jul 2015 16:24:02 +0000 (16:24 +0000)
committerJohn Crispin <john@openwrt.org>
Tue, 14 Jul 2015 16:24:02 +0000 (16:24 +0000)
Since r40909 openwrt can automatically shutdown when you press the
power button or try to shutdown a kvm virtual machine.
When booting a recent CC-rc2 or trunk image, it doesn't work,
as two kernel modules are missing.

Add these two kernel modules to the default packages, so users
don't need to install them manually.

Signed-off-by: Stefan Hellermann <stefan@the2masters.de>
SVN-Revision: 46366

target/linux/x86/64/target.mk
target/linux/x86/kvm_guest/target.mk

index 1f22eb3934b7f3faefbbc2f51e70d2359db3c686..9cf1671206f530185e9651ebfbd73b4eaf5dca5a 100644 (file)
@@ -1,6 +1,6 @@
 ARCH:=x86_64
 BOARDNAME:=x86_64
-DEFAULT_PACKAGES += kmod-e1000e kmod-e1000 kmod-r8169
+DEFAULT_PACKAGES += kmod-acpi-button kmod-button-hotplug kmod-e1000e kmod-e1000 kmod-r8169
 ARCH_PACKAGES:=x86_64
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
index 4bdfbc63b2c62b31cf2e0deb4fb0ad0c190a07c8..6194778653fda590ee2454b94b720a3384d3ef76 100644 (file)
@@ -1,4 +1,4 @@
 BOARDNAME:=KVM Guest
 FEATURES:=ext4 pci usb
-DEFAULT_PACKAGES += kmod-virtio-balloon kmod-virtio-net kmod-virtio-random
+DEFAULT_PACKAGES += kmod-acpi-button kmod-button-hotplug kmod-virtio-balloon kmod-virtio-net kmod-virtio-random
 CPU_TYPE := pentium4