drop support for the dns323
authorImre Kaloz <kaloz@openwrt.org>
Tue, 4 Jun 2013 11:13:18 +0000 (11:13 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Tue, 4 Jun 2013 11:13:18 +0000 (11:13 +0000)
SVN-Revision: 36832

target/linux/orion/Makefile
target/linux/orion/config-3.3
target/linux/orion/dns323/base-files/etc/config/network [deleted file]
target/linux/orion/dns323/config-3.3 [deleted file]
target/linux/orion/dns323/target.mk [deleted file]
target/linux/orion/image/dns323.mk [deleted file]
target/linux/orion/patches-3.3/300-dns323_partition_map.patch [deleted file]

index 2a24cdb95afc631f1cc0dc0dcdd31bd73a37a08a..b1d109a1f694bcab2a285badee01a57bb6c5f426 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2011 OpenWrt.org
+# Copyright (C) 2008-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=orion
 BOARDNAME:=Marvell Orion
-SUBTARGETS:=generic harddisk dns323
+SUBTARGETS:=generic harddisk
 CFLAGS=-Os -pipe -march=armv5te -mtune=xscale -fno-caller-saves
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
index 1098c6a5b11dbad68f7f2ce035f8cd8cbfc6affa..c85740a8e213fed766665f67ecac3630ae40e451 100644 (file)
@@ -93,7 +93,7 @@ CONFIG_LEDS_GPIO=y
 # CONFIG_MACH_BIGDISK is not set
 # CONFIG_MACH_D2NET is not set
 # CONFIG_MACH_DB88F5281 is not set
-CONFIG_MACH_DNS323=y
+# CONFIG_MACH_DNS323 is not set
 CONFIG_MACH_DT2=y
 # CONFIG_MACH_EDMINI_V2 is not set
 # CONFIG_MACH_KUROBOX_PRO is not set
diff --git a/target/linux/orion/dns323/base-files/etc/config/network b/target/linux/orion/dns323/base-files/etc/config/network
deleted file mode 100644 (file)
index 8bdd3b0..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-# Copyright (C) 2010 OpenWrt.org
-
-config interface loopback
-       option ifname   lo
-       option proto    static
-       option ipaddr   127.0.0.1
-       option netmask  255.0.0.0
-
-config interface eth0
-       option ifname   eth0
-       option proto    dhcp
-       option hostname dns323
diff --git a/target/linux/orion/dns323/config-3.3 b/target/linux/orion/dns323/config-3.3
deleted file mode 100644 (file)
index cc5b4a6..0000000
+++ /dev/null
@@ -1,46 +0,0 @@
-CONFIG_ATA=y
-CONFIG_ATAGS_PROC=y
-CONFIG_BLK_DEV_DM=y
-CONFIG_BLK_DEV_MD=y
-CONFIG_BLK_DEV_SD=y
-CONFIG_CMDLINE="root=/dev/mtdblock3 rootfstype=squashfs,jffs2 noinitrd console=ttyS0,115200"
-CONFIG_CRC16=y
-CONFIG_CRYPTO_AEAD2=y
-CONFIG_CRYPTO_BLKCIPHER=y
-CONFIG_CRYPTO_CBC=y
-CONFIG_CRYPTO_MANAGER=y
-CONFIG_CRYPTO_MANAGER2=y
-CONFIG_CRYPTO_PCOMP2=y
-CONFIG_DM_CRYPT=y
-CONFIG_DM_MIRROR=y
-CONFIG_DM_SNAPSHOT=y
-CONFIG_EXPORTFS=y
-CONFIG_EXT2_FS=y
-CONFIG_EXT3_FS=y
-CONFIG_EXT4_FS=y
-CONFIG_FS_MBCACHE=y
-CONFIG_INPUT=y
-CONFIG_INPUT_EVDEV=y
-CONFIG_INPUT_KEYBOARD=y
-CONFIG_JBD=y
-CONFIG_JBD2=y
-CONFIG_KEXEC=y
-CONFIG_KEYBOARD_GPIO=y
-CONFIG_MD=y
-CONFIG_MD_AUTODETECT=y
-CONFIG_MD_LINEAR=y
-# CONFIG_MD_MULTIPATH is not set
-CONFIG_MD_RAID0=y
-CONFIG_MD_RAID1=y
-# CONFIG_MD_RAID10 is not set
-# CONFIG_MD_RAID456 is not set
-CONFIG_NLS=y
-CONFIG_RTC_DRV_M41T80=y
-CONFIG_RTC_DRV_M41T80_WDT=y
-CONFIG_SATA_MV=y
-CONFIG_SCSI=y
-CONFIG_SCSI_MOD=y
-CONFIG_SENSORS_G760A=y
-CONFIG_SENSORS_LM75=y
-# CONFIG_USB_SUPPORT is not set
-CONFIG_XFS_FS=y
diff --git a/target/linux/orion/dns323/target.mk b/target/linux/orion/dns323/target.mk
deleted file mode 100644 (file)
index 25523ae..0000000
+++ /dev/null
@@ -1,6 +0,0 @@
-BOARDNAME:=D-Link DNS-323
-DEFAULT_PACKAGES += -kmod-ath9k -wpad-mini -dnsmasq
-
-define Target/Description
-       Build OpenWrt image for D-Link DNS-323
-endef
diff --git a/target/linux/orion/image/dns323.mk b/target/linux/orion/image/dns323.mk
deleted file mode 100644 (file)
index c33e612..0000000
+++ /dev/null
@@ -1,36 +0,0 @@
-#
-# Copyright (C) 2010 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Image/Prepare
-       cp $(LINUX_DIR)/arch/arm/boot/uImage $(KDIR)/uImage
-endef
-
-define Image/BuildKernel
-       # Orion Kernel uImages
- # DNS-323: mach id 1542 (0x606)
-       echo -en "\x06\x1c\xa0\xe3\x06\x10\x81\xe3" > $(KDIR)/dns323-zImage
-       cat $(LINUX_DIR)/arch/arm/boot/zImage >> $(KDIR)/dns323-zImage
-       $(STAGING_DIR_HOST)/bin/mkimage -A arm -O linux -T kernel \
-       -C none -a 0x00008000 -e 0x00008000 -n 'Linux-$(LINUX_VERSION)' \
-       -d $(KDIR)/dns323-zImage $(KDIR)/dns323-uImage
-       cp $(KDIR)/dns323-uImage $(BIN_DIR)/openwrt-dns323-uImage
-endef
-
-define Image/Build/D-Link
-       # Orion DNS-323 Images
- # mtd image
-       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-dns323-rootfs bs=128k
-endef
-
-define Image/Build
-$(call Image/Build/$(1),$(1))
-$(call Image/Build/D-Link,$(1),dns323,DNS-323,$(1))
-endef
-
-define Image/Build/squashfs
-$(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
-endef
diff --git a/target/linux/orion/patches-3.3/300-dns323_partition_map.patch b/target/linux/orion/patches-3.3/300-dns323_partition_map.patch
deleted file mode 100644 (file)
index 6eab81f..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
---- a/arch/arm/mach-orion5x/dns323-setup.c
-+++ b/arch/arm/mach-orion5x/dns323-setup.c
-@@ -113,6 +113,13 @@ subsys_initcall(dns323_pci_init);
-  *  0x00020000-0x001a0000 : "Linux Kernel"
-  *  0x001a0000-0x007d0000 : "File System"
-  *  0x007d0000-0x00800000 : "u-boot"
-+ *
-+ * Layout as used by OpenWrt
-+ *  0x00000000-0x00010000 : "MTD1"
-+ *  0x00010000-0x00020000 : "MTD2"
-+ *  0x00020000-0x001a0000 : "kernel"
-+ *  0x001a0000-0x007d0000 : "rootfs"
-+ *  0x007d0000-0x00800000 : "u-boot"
-  */
- #define DNS323_NOR_BOOT_BASE 0xf4000000
-@@ -128,11 +135,11 @@ static struct mtd_partition dns323_parti
-               .size   = 0x00010000,
-               .offset = 0x00010000,
-       }, {
--              .name   = "Linux Kernel",
-+              .name   = "kernel",
-               .size   = 0x00180000,
-               .offset = 0x00020000,
-       }, {
--              .name   = "File System",
-+              .name   = "rootfs",
-               .size   = 0x00630000,
-               .offset = 0x001A0000,
-       }, {