mac80211: manually apply dependencies to prevent a recoursive one
authorJonas Gorski <jonas.gorski@gmail.com>
Wed, 12 Apr 2017 10:44:12 +0000 (12:44 +0200)
committerJonas Gorski <jonas.gorski@gmail.com>
Wed, 12 Apr 2017 10:48:35 +0000 (12:48 +0200)
Apply the !UML dependency to both the symbol and the DEPENDS so there is
no recursive dependency anymore.

Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
package/kernel/mac80211/Makefile

index 545ecdd6f436aae7fd40f2d15638fc21b2ea3396..60efdaa9fc09a11d6ad185e9f3435865c0e20b31 100644 (file)
@@ -687,7 +687,7 @@ define KernelPackage/brcmfmac
   TITLE:=Broadcom IEEE802.11n USB FullMAC WLAN driver
   URL:=https://wireless.wiki.kernel.org/en/users/drivers/brcm80211
   DEPENDS+= @USB_SUPPORT +kmod-cfg80211 +@DRIVER_11N_SUPPORT +@DRIVER_11AC_SUPPORT +kmod-brcmutil \
-       +BRCMFMAC_SDIO:kmod-mmc \
+       +BRCMFMAC_SDIO&&!TARGET_uml:kmod-mmc \
        +BRCMFMAC_USB:kmod-usb-core +BRCMFMAC_USB:brcmfmac-firmware-usb
   FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/broadcom/brcm80211/brcmfmac/brcmfmac.ko
   AUTOLOAD:=$(call AutoProbe,brcmfmac)
@@ -702,6 +702,7 @@ define KernelPackage/brcmfmac/config
 
        config BRCMFMAC_SDIO
                bool "Enable SDIO bus interface support"
+               depends on !TARGET_uml
                default y if TARGET_brcm2708
                default n
                help