ramips: provide means to specify custom "image name" for uImages, use for DIR-620
authorGabor Juhos <juhosg@openwrt.org>
Sun, 12 Aug 2012 12:48:26 +0000 (12:48 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Sun, 12 Aug 2012 12:48:26 +0000 (12:48 +0000)
D-Link's DIR-620 allows to flash a uImage directly from its web-interface but
for that the image name should be set to DIR_620.

Signed-off-by: Paul Fertser <fercerpav@gmail.com>
SVN-Revision: 33143

target/linux/ramips/image/Makefile

index 5f42fe8a75b5d9d4f7b263e8572782ad89787abd..1e17187c32139ce78cbccbf138aa6ca5dcb5b343 100644 (file)
@@ -49,14 +49,15 @@ define PatchKernelLzma
 endef
 
 define MkImage
+       $(eval imagename=$(if $(4),$(4),MIPS OpenWrt Linux-$(LINUX_VERSION)))
        mkimage -A mips -O linux -T kernel -C $(1) $(call kernel_entry)\
-               -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
+               -n "$(imagename)" \
                -d $(2) $(3)
 endef
 
 define MkImageLzma
        $(call PatchKernelLzma,$(1),$(2))
-       $(call MkImage,lzma,$(KDIR)/vmlinux-$(1).bin.lzma,$(KDIR)/vmlinux-$(1).uImage)
+       $(call MkImage,lzma,$(KDIR)/vmlinux-$(1).bin.lzma,$(KDIR)/vmlinux-$(1).uImage,$(3))
 endef
 
 define CatFiles
@@ -95,7 +96,7 @@ define Image/BuildKernel
 endef
 
 define BuildFirmware/Generic
-       $(call MkImageLzma,$(2),$(3))
+       $(call MkImageLzma,$(2),$(3),$(6))
        $(call Sysupgrade/KRuImage,$(1),$(2),$(4),$(5))
 endef
 
@@ -200,7 +201,7 @@ mtdlayout_dir620a1=192k(u-boot)ro,64k(u-boot-env)ro,64k(factory)ro,896k(kernel),
 kernel_size_dir620a1=917504
 rootfs_size_dir620a1=7143424
 define BuildFirmware/DIR620A1
-       $(call BuildFirmware/Generic,$(1),$(2),$(call mkcmdline,$(3),ttyS1,57600) $(call mkmtd/phys,$(mtdlayout_dir620a1)),$(kernel_size_dir620a1),$(rootfs_size_dir620a1))
+       $(call BuildFirmware/Generic,$(1),$(2),$(call mkcmdline,$(3),ttyS1,57600) $(call mkmtd/phys,$(mtdlayout_dir620a1)),$(kernel_size_dir620a1),$(rootfs_size_dir620a1),DIR_620)
 endef
 
 define BuildFirmware/DIR620A1/initramfs