odhcp6c: improve server selection, introduce "forceprefix" option
authorSteven Barth <cyrus@openwrt.org>
Mon, 7 Oct 2013 08:43:33 +0000 (08:43 +0000)
committerSteven Barth <cyrus@openwrt.org>
Mon, 7 Oct 2013 08:43:33 +0000 (08:43 +0000)
SVN-Revision: 38314

package/network/ipv6/odhcp6c/Makefile
package/network/ipv6/odhcp6c/files/dhcpv6.sh

index d6540d6e301ec30b48f834ea4929c211aaec2320..22e39bde4fd43591240714fc99f1e405dd4100cb 100644 (file)
@@ -8,14 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=odhcp6c
-PKG_VERSION:=2013-10-02
+PKG_VERSION:=2013-10-07
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE_URL:=git://github.com/sbyx/odhcp6c.git
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_VERSION:=357ecc1f5163bc7f74c64f4bca387e8d44a2eac5
+PKG_SOURCE_VERSION:=d2c90000292f62962276579fa6b2eac1ff4b76e6
 PKG_MAINTAINER:=Steven Barth <steven@midlink.org>
 
 include $(INCLUDE_DIR)/package.mk
index bf6cd9aa6281ea44e2869f3263ab88de80bcf60a..ab344e1d30446a585eb063782c65265df437b326 100755 (executable)
@@ -10,6 +10,7 @@ proto_dhcpv6_init_config() {
        proto_config_add_string "clientid"
        proto_config_add_string "reqopts"
        proto_config_add_string "noslaaconly"
+       proto_config_add_string "forceprefix"
        proto_config_add_string "norelease"
        proto_config_add_string "ip6prefix"
        proto_config_add_string "iface_dslite"
@@ -20,8 +21,8 @@ proto_dhcpv6_setup() {
        local config="$1"
        local iface="$2"
 
-       local reqaddress reqprefix clientid reqopts noslaaconly norelease ip6prefix iface_dslite ifaceid
-       json_get_vars reqaddress reqprefix clientid reqopts noslaaconly norelease ip6prefix iface_dslite ifaceid
+       local reqaddress reqprefix clientid reqopts noslaaconly forceprefix norelease ip6prefix iface_dslite ifaceid
+       json_get_vars reqaddress reqprefix clientid reqopts noslaaconly forceprefix norelease ip6prefix iface_dslite ifaceid
 
 
        # Configure
@@ -35,6 +36,8 @@ proto_dhcpv6_setup() {
 
        [ "$noslaaconly" = "1" ] && append opts "-S"
 
+       [ "$forceprefix" = "1" ] && append opts "-F"
+
        [ "$norelease" = "1" ] && append opts "-k"
 
        [ -n "$ifaceid" ] && append opts "-i$ifaceid"