ar7-atm: fix compilation for 4.1
authorJonas Gorski <jogo@openwrt.org>
Sun, 12 Jul 2015 11:57:40 +0000 (11:57 +0000)
committerJonas Gorski <jogo@openwrt.org>
Sun, 12 Jul 2015 11:57:40 +0000 (11:57 +0000)
Add the required changes to make it compile for 4.1 again.

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 46306

package/kernel/ar7-atm/Makefile
package/kernel/ar7-atm/patches-D7.04.03.00/230-compile_fixes.patch
package/kernel/ar7-atm/patches-D7.04.03.00/240-3.18_fixes.patch
package/kernel/ar7-atm/patches-D7.04.03.00/250-4.1_fixes.patch [new file with mode: 0644]
package/kernel/ar7-atm/patches-D7.05.01.00/240-3.18_fixes.patch [new file with mode: 0644]
package/kernel/ar7-atm/patches-D7.05.01.00/250-4.1_fixes.patch [new file with mode: 0644]

index 59454fa3677ee7b0bcdb403fd161b1112156dbfb..2574568acc90190d5539b3704a39ecc536606c0f 100644 (file)
@@ -38,7 +38,7 @@ include $(INCLUDE_DIR)/package.mk
 
 define KernelPackage/sangam-atm/Default
   SUBMENU:=Network Devices
-  DEPENDS:=@TARGET_ar7_generic +kmod-atm @!LINUX_4_1
+  DEPENDS:=@TARGET_ar7_generic +kmod-atm
   TITLE:=AR7 ADSL driver
   FILES:=$(PKG_BUILD_DIR)/tiatm.ko
   AUTOLOAD:=$(call AutoLoad,50,tiatm)
index fbc49a3f865491b6317fd3bbe7fa4eee8d715230..c7d9127012b6df819a925c65db4f930e7f5c6f17 100644 (file)
@@ -1,38 +1,30 @@
-Index: sangam_atm-D7.04.03.00/cp_sar_reg.h
-===================================================================
---- sangam_atm-D7.04.03.00.orig/cp_sar_reg.h   2004-04-20 08:23:30.000000000 +0200
-+++ sangam_atm-D7.04.03.00/cp_sar_reg.h        2014-12-01 14:28:58.586447237 +0100
+--- a/cp_sar_reg.h
++++ b/cp_sar_reg.h
 @@ -214,4 +214,4 @@
  
  /* END OF FILE */
  
 -#endif _INC_SAR_REG
 +#endif
-Index: sangam_atm-D7.04.03.00/tn7api.h
-===================================================================
---- sangam_atm-D7.04.03.00.orig/tn7api.h       2014-12-01 14:28:58.574446794 +0100
-+++ sangam_atm-D7.04.03.00/tn7api.h    2014-12-01 14:28:58.586447237 +0100
-@@ -172,4 +172,4 @@
+--- a/tn7api.h
++++ b/tn7api.h
+@@ -172,4 +172,4 @@ void tn7sar_get_sar_firmware_version(uns
  extern struct file_operations tn7sar_proc_oam_ping_fops;
  extern struct file_operations tn7sar_proc_pvc_table_fops;
  int tn7sar_tx_flush(void *privContext, int chan, int queue, int skip);
 -#endif __SGAPI_H
 +#endif
-Index: sangam_atm-D7.04.03.00/tn7atm.h
-===================================================================
---- sangam_atm-D7.04.03.00.orig/tn7atm.h       2014-12-01 14:28:58.442441921 +0100
-+++ sangam_atm-D7.04.03.00/tn7atm.h    2014-12-01 14:28:58.586447237 +0100
-@@ -276,4 +276,4 @@
+--- a/tn7atm.h
++++ b/tn7atm.h
+@@ -276,4 +276,4 @@ typedef struct
  #define PHYS_TO_K1(X)                             (PHYS_ADDR(X)|K1BASE)
  #endif
  
 -#endif __TN7ATM_H
 +#endif
-Index: sangam_atm-D7.04.03.00/dsl_hal_api.h
-===================================================================
---- sangam_atm-D7.04.03.00.orig/dsl_hal_api.h  2007-03-07 14:40:26.000000000 +0100
-+++ sangam_atm-D7.04.03.00/dsl_hal_api.h       2014-12-01 14:30:10.509102453 +0100
-@@ -2448,7 +2448,7 @@
+--- a/dsl_hal_api.h
++++ b/dsl_hal_api.h
+@@ -2448,7 +2448,7 @@ unsigned int dslhal_api_getHLINpsds(tids
  *
  ********************************************************************************************/
  
@@ -41,7 +33,7 @@ Index: sangam_atm-D7.04.03.00/dsl_hal_api.h
  
  /********************************************************************************************
  * FUNCTION NAME: void dslhal_api_setHighPrecision
-@@ -2459,7 +2459,7 @@
+@@ -2459,7 +2459,7 @@ unsigned int dslhal_api_getHighPrecision
  * Return: None
  ********************************************************************************************/
  
index befd11fde8aaf3d466649c3a714e2faeaccb1780..e8bdab63da50d05e0379d95b7ab53f980b80a27e 100644 (file)
@@ -1,6 +1,6 @@
 --- a/tn7dsl.c
 +++ b/tn7dsl.c
-@@ -346,7 +346,7 @@
+@@ -346,7 +346,7 @@ static void tn7dsl_chng_modulation(void*
  static unsigned int tn7dsl_set_modulation(void* data, int flag);
  static void tn7dsl_ctrl_fineGain(int value);
  static void tn7dsl_set_fineGainValue(int value);
@@ -9,7 +9,7 @@
                            void *buffer, size_t * lenp);
  static void tn7dsl_register_dslss_led(void);
  void tn7dsl_dslmod_sysctl_register(void);
-@@ -3325,7 +3325,7 @@
+@@ -3325,7 +3325,7 @@ unsigned int tn7dsl_get_memory(unsigned
  
  
  
@@ -18,7 +18,7 @@
        void *buffer, size_t *lenp)
  {
    char *ptr;
-@@ -3451,7 +3451,7 @@
+@@ -3451,7 +3451,7 @@ static int dslmod_sysctl(ctl_table *ctl,
  }
  
  
@@ -27,7 +27,7 @@
  #if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,33)
    {DEV_DSLMOD, "dslmod", info, DSL_MOD_SIZE, 0644, NULL, NULL, &dslmod_sysctl, &sysctl_string}
  #else
-@@ -3469,7 +3469,7 @@
+@@ -3469,7 +3469,7 @@ ctl_table dslmod_table[] = {
    };
  
  /* Make sure that /proc/sys/dev is there */
diff --git a/package/kernel/ar7-atm/patches-D7.04.03.00/250-4.1_fixes.patch b/package/kernel/ar7-atm/patches-D7.04.03.00/250-4.1_fixes.patch
new file mode 100644 (file)
index 0000000..97a26cb
--- /dev/null
@@ -0,0 +1,20 @@
+--- a/tn7atm.c
++++ b/tn7atm.c
+@@ -788,7 +788,7 @@ static int __init tn7atm_irq_request (st
+    * Register SAR interrupt
+    */
+   priv->sar_irq = LNXINTNUM (ATM_SAR_INT);      /* Interrupt line # */
+-  if (request_irq (priv->sar_irq, tn7atm_sar_irq, IRQF_DISABLED, "SAR ", dev))
++  if (request_irq (priv->sar_irq, tn7atm_sar_irq, 0, "SAR ", dev))
+     printk ("Could not register tn7atm_sar_irq\n");
+   /*
+@@ -806,7 +806,7 @@ static int __init tn7atm_irq_request (st
+    * Reigster Receive interrupt A
+    */
+   priv->dsl_irq = LNXINTNUM (ATM_DSL_INT);      /* Interrupt line # */
+-  if (request_irq (priv->dsl_irq, tn7atm_dsl_irq, IRQF_DISABLED, "DSL ", dev))
++  if (request_irq (priv->dsl_irq, tn7atm_dsl_irq, 0, "DSL ", dev))
+     printk ("Could not register tn7atm_dsl_irq\n");
+ /***** VRB Tasklet Mode ****/
diff --git a/package/kernel/ar7-atm/patches-D7.05.01.00/240-3.18_fixes.patch b/package/kernel/ar7-atm/patches-D7.05.01.00/240-3.18_fixes.patch
new file mode 100644 (file)
index 0000000..a29bae8
--- /dev/null
@@ -0,0 +1,38 @@
+--- a/tn7dsl.c
++++ b/tn7dsl.c
+@@ -363,7 +363,7 @@ static void tn7dsl_chng_modulation(void*
+ static unsigned int tn7dsl_set_modulation(void* data, int flag);
+ static void tn7dsl_ctrl_fineGain(int value);
+ static void tn7dsl_set_fineGainValue(int value);
+-static int dslmod_sysctl (ctl_table * ctl, int write, struct file *filp,
++static int dslmod_sysctl (struct ctl_table * ctl, int write, struct file *filp,
+                           void *buffer, size_t * lenp);
+ static void tn7dsl_register_dslss_led(void);
+ void tn7dsl_dslmod_sysctl_register(void);
+@@ -3505,7 +3505,7 @@ unsigned int tn7dsl_get_memory(unsigned
+-static int dslmod_sysctl(ctl_table *ctl, int write, struct file * filp,
++static int dslmod_sysctl(struct ctl_table *ctl, int write, struct file * filp,
+       void *buffer, size_t *lenp)
+ {
+   char *ptr;
+@@ -3631,7 +3631,7 @@ static int dslmod_sysctl(ctl_table *ctl,
+ }
+-ctl_table dslmod_table[] = {
++struct ctl_table dslmod_table[] = {
+ #if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,33)
+   {DEV_DSLMOD, "dslmod", info, DSL_MOD_SIZE, 0644, NULL, NULL, &dslmod_sysctl, &sysctl_string}
+ #else
+@@ -3649,7 +3649,7 @@ ctl_table dslmod_table[] = {
+   };
+ /* Make sure that /proc/sys/dev is there */
+-ctl_table dslmod_root_table[] = {
++struct ctl_table dslmod_root_table[] = {
+ #ifdef CONFIG_PROC_FS
+       #if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,33)
+   {CTL_DEV, "dev", NULL, 0, 0555, dslmod_table}
diff --git a/package/kernel/ar7-atm/patches-D7.05.01.00/250-4.1_fixes.patch b/package/kernel/ar7-atm/patches-D7.05.01.00/250-4.1_fixes.patch
new file mode 100644 (file)
index 0000000..bc913a7
--- /dev/null
@@ -0,0 +1,20 @@
+--- a/tn7atm.c
++++ b/tn7atm.c
+@@ -856,7 +856,7 @@ static int __init tn7atm_irq_request (st
+   priv->sar_irq = LNXINTNUM (ATM_SAR_INT);      /* Interrupt line # */
+-  if (request_irq (priv->sar_irq, tn7atm_sar_irq, IRQF_DISABLED, "SAR ", dev))
++  if (request_irq (priv->sar_irq, tn7atm_sar_irq, 0, "SAR ", dev))
+     printk ("Could not register tn7atm_sar_irq\n");
+   /*
+@@ -880,7 +880,7 @@ static int __init tn7atm_irq_request (st
+    * Reigster Receive interrupt A
+    */
+   priv->dsl_irq = LNXINTNUM (ATM_DSL_INT);      /* Interrupt line # */
+-  if (request_irq (priv->dsl_irq, tn7atm_dsl_irq, IRQF_DISABLED, "DSL ", dev))
++  if (request_irq (priv->dsl_irq, tn7atm_dsl_irq, 0, "DSL ", dev))
+     printk ("Could not register tn7atm_dsl_irq\n");
+ /***** VRB Tasklet Mode ****/