kernel: bump to 4.4.36
authorÁlvaro Fernández Rojas <noltari@gmail.com>
Fri, 2 Dec 2016 10:43:17 +0000 (11:43 +0100)
committerÁlvaro Fernández Rojas <noltari@gmail.com>
Sun, 4 Dec 2016 11:31:30 +0000 (12:31 +0100)
Refresh patches on all 4.4 supported platforms.
Compile & run tested: brcm2708/bcm2710 - Raspberry Pi 3

Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
include/kernel-version.mk
target/linux/brcm47xx/patches-4.4/159-cpu_fixes.patch
target/linux/generic/patches-4.4/738-net-phy-at803x-only-the-AT8030-needs-a-hardware-rese.patch
target/linux/lantiq/patches-4.4/0121-MIPS-lantiq-make-it-possible-to-build-in-no-device-t.patch

index 2dab214f5bbf8d6d0798ee04cde6cbca61b6dd5f..0cde46732dd96ef6c728e1798609a0053b6a9c69 100644 (file)
@@ -4,11 +4,11 @@ LINUX_RELEASE?=1
 
 LINUX_VERSION-3.18 = .43
 LINUX_VERSION-4.1 = .34
-LINUX_VERSION-4.4 = .35
+LINUX_VERSION-4.4 = .36
 
 LINUX_KERNEL_MD5SUM-3.18.43 = b1faeb4a2e1e70ffe061bdbb3452840a
 LINUX_KERNEL_MD5SUM-4.1.34 = fba99f0f4765ebf01033e69518740a3c
-LINUX_KERNEL_MD5SUM-4.4.35 = 03d1eb75928ff741217f78dc3b55515d
+LINUX_KERNEL_MD5SUM-4.4.36 = c23de77131c05a27e638026972ada85b
 
 ifdef KERNEL_PATCHVER
   LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
index ea904a0837c9662cb27324caa2bc0027275b4572..cf72d66114c2ea661e5d3335284cf8c5bdf1def5 100644 (file)
 -__BUILD_BLAST_CACHE(d, dcache, Index_Writeback_Inv_D, Hit_Writeback_Inv_D, 128, )
 -__BUILD_BLAST_CACHE(i, icache, Index_Invalidate_I, Hit_Invalidate_I, 128, )
 -__BUILD_BLAST_CACHE(s, scache, Index_Writeback_Inv_SD, Hit_Writeback_Inv_SD, 128, )
+-
+-__BUILD_BLAST_CACHE(inv_d, dcache, Index_Writeback_Inv_D, Hit_Invalidate_D, 16, )
+-__BUILD_BLAST_CACHE(inv_d, dcache, Index_Writeback_Inv_D, Hit_Invalidate_D, 32, )
+-__BUILD_BLAST_CACHE(inv_s, scache, Index_Writeback_Inv_SD, Hit_Invalidate_SD, 16, )
+-__BUILD_BLAST_CACHE(inv_s, scache, Index_Writeback_Inv_SD, Hit_Invalidate_SD, 32, )
+-__BUILD_BLAST_CACHE(inv_s, scache, Index_Writeback_Inv_SD, Hit_Invalidate_SD, 64, )
+-__BUILD_BLAST_CACHE(inv_s, scache, Index_Writeback_Inv_SD, Hit_Invalidate_SD, 128, )
 +__BUILD_BLAST_CACHE(d, dcache, Index_Writeback_Inv_D, Hit_Writeback_Inv_D, 16, , )
 +__BUILD_BLAST_CACHE(i, icache, Index_Invalidate_I, Hit_Invalidate_I, 16, , BCM4710_FILL_TLB(start);)
 +__BUILD_BLAST_CACHE(s, scache, Index_Writeback_Inv_SD, Hit_Writeback_Inv_SD, 16, , )
 +__BUILD_BLAST_CACHE(d, dcache, Index_Writeback_Inv_D, Hit_Writeback_Inv_D, 128, , )
 +__BUILD_BLAST_CACHE(i, icache, Index_Invalidate_I, Hit_Invalidate_I, 128, , )
 +__BUILD_BLAST_CACHE(s, scache, Index_Writeback_Inv_SD, Hit_Writeback_Inv_SD, 128, , )
--__BUILD_BLAST_CACHE(inv_d, dcache, Index_Writeback_Inv_D, Hit_Invalidate_D, 16, )
--__BUILD_BLAST_CACHE(inv_d, dcache, Index_Writeback_Inv_D, Hit_Invalidate_D, 32, )
--__BUILD_BLAST_CACHE(inv_s, scache, Index_Writeback_Inv_SD, Hit_Invalidate_SD, 16, )
--__BUILD_BLAST_CACHE(inv_s, scache, Index_Writeback_Inv_SD, Hit_Invalidate_SD, 32, )
--__BUILD_BLAST_CACHE(inv_s, scache, Index_Writeback_Inv_SD, Hit_Invalidate_SD, 64, )
--__BUILD_BLAST_CACHE(inv_s, scache, Index_Writeback_Inv_SD, Hit_Invalidate_SD, 128, )
++
 +__BUILD_BLAST_CACHE(inv_d, dcache, Index_Writeback_Inv_D, Hit_Invalidate_D, 16, , )
 +__BUILD_BLAST_CACHE(inv_d, dcache, Index_Writeback_Inv_D, Hit_Invalidate_D, 32, , )
 +__BUILD_BLAST_CACHE(inv_s, scache, Index_Writeback_Inv_SD, Hit_Invalidate_SD, 16, , )
index c49d53ee1c48c3d144716a8f4b5d42a32d349dc6..4e6baac0c3644d279a8d62b25e65162411f15a56 100644 (file)
@@ -25,31 +25,35 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
 -              if (phydev->state == PHY_NOLINK) {
 -                      if (priv->gpiod_reset && !priv->phy_reset) {
 -                              struct at803x_context context;
-+      if (phydev->state == PHY_NOLINK) {
-+              if (priv->gpiod_reset && !priv->phy_reset) {
-+                      struct at803x_context context;
+-
 -                              at803x_context_save(phydev, &context);
-+                      at803x_context_save(phydev, &context);
+-
 -                              gpiod_set_value(priv->gpiod_reset, 1);
 -                              msleep(1);
 -                              gpiod_set_value(priv->gpiod_reset, 0);
 -                              msleep(1);
-+                      gpiod_set_value(priv->gpiod_reset, 1);
-+                      msleep(1);
-+                      gpiod_set_value(priv->gpiod_reset, 0);
-+                      msleep(1);
+-
 -                              at803x_context_restore(phydev, &context);
-+                      at803x_context_restore(phydev, &context);
+-
 -                              dev_dbg(&phydev->dev, "%s(): phy was reset\n",
 -                                      __func__);
 -                              priv->phy_reset = true;
 -                      }
 -              } else {
 -                      priv->phy_reset = false;
++      if (phydev->state == PHY_NOLINK) {
++              if (priv->gpiod_reset && !priv->phy_reset) {
++                      struct at803x_context context;
++
++                      at803x_context_save(phydev, &context);
++
++                      gpiod_set_value(priv->gpiod_reset, 1);
++                      msleep(1);
++                      gpiod_set_value(priv->gpiod_reset, 0);
++                      msleep(1);
++
++                      at803x_context_restore(phydev, &context);
++
 +                      dev_dbg(&phydev->dev, "%s(): phy was reset\n",
 +                              __func__);
 +                      priv->phy_reset = true;
index 2b7b6f1ba0e1308d86f3afbc34c2ae9d18186659..7a7dd970f1c35a80bb40eafc58f4b7f68507268c 100644 (file)
@@ -16,7 +16,7 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
 
 --- a/arch/mips/lantiq/Kconfig
 +++ b/arch/mips/lantiq/Kconfig
-@@ -27,7 +27,17 @@ config SOC_FALCON
+@@ -26,7 +26,17 @@ config SOC_FALCON
  endchoice
  
  choice