m4: update to 1.4.17
authorLuka Perkov <luka@openwrt.org>
Tue, 24 Sep 2013 20:01:00 +0000 (20:01 +0000)
committerLuka Perkov <luka@openwrt.org>
Tue, 24 Sep 2013 20:01:00 +0000 (20:01 +0000)
Signed-off-by: Luka Perkov <luka@openwrt.org>
SVN-Revision: 38168

tools/m4/Makefile
tools/m4/patches/100-fix-gets-removal.patch

index 080eb5d99c1a4b5a3e13230cf874b238acb40fec..71498b490a15d129897c4f2e0a548ca5daf72e4b 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2008-2012 OpenWrt.org
+# Copyright (C) 2008-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,12 +7,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=m4
-PKG_VERSION:=1.4.16
+PKG_VERSION:=1.4.17
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
-PKG_MD5SUM:=a5dfb4f2b7370e9d34293d23fd09b280
-PKG_CAT:=zcat
+PKG_MD5SUM:=12a3c829301a4fd6586a57d3fcf196dc
+PKG_CAT:=xzcat
 
 HOST_BUILD_PARALLEL:=1
 
index be0ea851cef138c90ab851e43f8968541c221bb5..ecd110d934ea04a1f630a31ee67ab5bc8189ab20 100644 (file)
@@ -1,15 +1,17 @@
 --- a/lib/stdio.in.h
 +++ b/lib/stdio.in.h
-@@ -158,12 +158,6 @@ _GL_WARN_ON_USE (fflush, "fflush is not 
-                  "use gnulib module fflush for portable POSIX compliance");
+@@ -714,14 +714,6 @@ _GL_WARN_ON_USE (getline, "getline is un
+ # endif
  #endif
  
 -/* It is very rare that the developer ever has full control of stdin,
--   so any use of gets warrants an unconditional warning.  Assume it is
--   always declared, since it is required by C89.  */
+-   so any use of gets warrants an unconditional warning; besides, C11
+-   removed it.  */
 -#undef gets
+-#if HAVE_RAW_DECL_GETS
 -_GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
+-#endif
 -
- #if @GNULIB_FOPEN@
- # if @REPLACE_FOPEN@
- #  if !(defined __cplusplus && defined GNULIB_NAMESPACE)
+ #if @GNULIB_OBSTACK_PRINTF@ || @GNULIB_OBSTACK_PRINTF_POSIX@
+ struct obstack;