linux: add missing dependencies to kmod-fs-msdos and kmod-fs-xfs
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 18 Jul 2013 13:57:36 +0000 (13:57 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 18 Jul 2013 13:57:36 +0000 (13:57 +0000)
SVN-Revision: 37398

package/kernel/linux/modules/fs.mk

index 536e28b4c61dac5cadb9ae61a73c0278b863afd0..70387fd99d197573cd95d93e601cccc74dd61ca0 100644 (file)
@@ -203,6 +203,7 @@ $(eval $(call KernelPackage,fs-minix))
 define KernelPackage/fs-msdos
   SUBMENU:=$(FS_MENU)
   TITLE:=MSDOS filesystem support
+  DEPENDS:=+kmod-fs-vfat
   KCONFIG:=CONFIG_MSDOS_FS
   FILES:=$(LINUX_DIR)/fs/fat/msdos.ko
   AUTOLOAD:=$(call AutoLoad,40,msdos)
@@ -360,7 +361,7 @@ define KernelPackage/fs-xfs
   SUBMENU:=$(FS_MENU)
   TITLE:=XFS filesystem support
   KCONFIG:=CONFIG_XFS_FS
-  DEPENDS:= +kmod-fs-exportfs @!avr32
+  DEPENDS:= +kmod-fs-exportfs +kmod-lib-crc32c @!avr32
   FILES:=$(LINUX_DIR)/fs/xfs/xfs.ko
   AUTOLOAD:=$(call AutoLoad,30,xfs,1)
 endef