build: add @APACHE download facility
authorFelix Fietkau <nbd@openwrt.org>
Sun, 17 Jan 2016 10:47:32 +0000 (10:47 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 17 Jan 2016 10:47:32 +0000 (10:47 +0000)
The Apache Software Foundation offers diverse download mirros.

For packaging Apache software a new alias @APACHE is defined.

Signed-off-by: Heinrich Schuchardt <xypron.glpk@gmx.de>
SVN-Revision: 48270

include/download.mk
scripts/download.pl

index 8a1205df00ff5eb5b2b88ef9d0ed07122d9a0af8..ca5eee4e028984e7de9c939bae7f92178a57a888 100644 (file)
@@ -13,7 +13,7 @@ DOWNLOAD_RDEP=$(STAMP_PREPARED) $(HOST_STAMP_PREPARED)
 define dl_method
 $(strip \
   $(if $(2),$(2), \
-    $(if $(filter @GNOME/% @GNU/% @KERNEL/% @SF/% @SAVANNAH/% ftp://% http://% https://% file://%,$(1)),default, \
+    $(if $(filter @APACHE/% @GNOME/% @GNU/% @KERNEL/% @SF/% @SAVANNAH/% ftp://% http://% https://% file://%,$(1)),default, \
       $(if $(filter git://%,$(1)),git, \
         $(if $(filter svn://%,$(1)),svn, \
           $(if $(filter cvs://%,$(1)),cvs, \
index 9d1fe4755aecf3edc4b8b03ba81a27bc753f7720..25c73fbeb522ebaecbdee77c913a968e0af8d429 100755 (executable)
@@ -176,6 +176,12 @@ foreach my $mirror (@ARGV) {
                for (1 .. 5) {
                        push @mirrors, "http://downloads.sourceforge.net/$1";
                }
+       } elsif ($mirror =~ /^\@APACHE\/(.+)$/) {
+               push @mirrors, "http://ftp.tudelft.nl/apache/$1";
+               push @mirrors, "http://apache.openmirror.de/$1";
+               push @mirrors, "http://mirrors.ocf.berkeley.edu/apache/$1";
+               push @mirrors, "http://mirror.cc.columbia.edu/pub/software/apache/$1";
+               push @mirrors, "http://ftp.jaist.ac.jp/pub/apache/$1";
        } elsif ($mirror =~ /^\@GNU\/(.+)$/) {
                push @mirrors, "http://ftpmirror.gnu.org/$1";
                push @mirrors, "http://ftp.gnu.org/pub/gnu/$1";