iproute2: always use -DHAVE_SETNS, since the old uclibc is gone now
authorFelix Fietkau <nbd@openwrt.org>
Mon, 2 Nov 2015 18:12:23 +0000 (18:12 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 2 Nov 2015 18:12:23 +0000 (18:12 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 47358

package/network/utils/iproute2/Makefile

index f5b5f4e536b13f989159dad92a6c6e439facd496..e5015dbdfc25856bcc8766342ea6eb7521beada2 100644 (file)
@@ -78,16 +78,7 @@ define Build/Configure
                > $(PKG_BUILD_DIR)/include/SNAPSHOT.h
 endef
 
                > $(PKG_BUILD_DIR)/include/SNAPSHOT.h
 endef
 
-ifdef CONFIG_USE_GLIBC
-  TARGET_CFLAGS += -DHAVE_SETNS
-endif
-ifdef CONFIG_USE_MUSL
-  TARGET_CFLAGS += -DHAVE_SETNS
-endif
-ifdef CONFIG_UCLIBC_USE_VERSION_NG
-  TARGET_CFLAGS += -DHAVE_SETNS
-endif
-
+TARGET_CFLAGS += -DHAVE_SETNS
 TARGET_CFLAGS += -ffunction-sections -fdata-sections
 
 MAKE_FLAGS += \
 TARGET_CFLAGS += -ffunction-sections -fdata-sections
 
 MAKE_FLAGS += \