pkg-config: update to latest version, fix build on Mac OS X 10.9
authorFelix Fietkau <nbd@openwrt.org>
Mon, 28 Oct 2013 15:15:12 +0000 (15:15 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 28 Oct 2013 15:15:12 +0000 (15:15 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 38561

tools/pkg-config/Makefile
tools/pkg-config/patches/100-disable_compat_cmd.patch [deleted file]

index b72f3ce457ef9bf6131950c86c702a76c904629a..6bd53f8610749791b0f2c7881aa01cf78aea8b3d 100644 (file)
@@ -7,17 +7,20 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pkg-config
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pkg-config
-PKG_VERSION:=0.25
+PKG_VERSION:=0.28
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://pkgconfig.freedesktop.org/releases/
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://pkgconfig.freedesktop.org/releases/
-PKG_MD5SUM:=a3270bab3f4b69b7dc6dbdacbcae9745
+PKG_MD5SUM:=aa3c86e67551adc3ac865160e34a2a0d
 
 HOST_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/host-build.mk
 
 HOST_LDFLAGS += $(HOST_STATIC_LINKING)
 
 HOST_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/host-build.mk
 
 HOST_LDFLAGS += $(HOST_STATIC_LINKING)
+unexport PKG_CONFIG
+
+HOST_CONFIGURE_ARGS += --with-internal-glib
 
 define Host/Install
        $(MAKE) -C $(HOST_BUILD_DIR) install \
 
 define Host/Install
        $(MAKE) -C $(HOST_BUILD_DIR) install \
diff --git a/tools/pkg-config/patches/100-disable_compat_cmd.patch b/tools/pkg-config/patches/100-disable_compat_cmd.patch
deleted file mode 100644 (file)
index 9907840..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
---- a/parse.c
-+++ b/parse.c
-@@ -1187,15 +1187,12 @@ try_command (const char *command)
- Package *
- get_compat_package (const char *name)
- {
--#ifdef G_OS_WIN32
--  /* There has never been any of these legacy *-config scripts on
--   * Windows as far as I know. No use trying to execute them, will
--   * only confuse users to see the "blabla is not recognized as an
--   * internal or external command, operable program or batch file"
--   * messages.
-+  /*
-+   * We don't need this compatibility stuff on a system
-+   * that is free of legacy stuff 
-    */
-   return NULL;
--#else
-+#if 0
-   Package *pkg;