ramips: cleanup some rt305x profiles
authorJohn Crispin <john@openwrt.org>
Thu, 19 Jun 2014 14:13:07 +0000 (14:13 +0000)
committerJohn Crispin <john@openwrt.org>
Thu, 19 Jun 2014 14:13:07 +0000 (14:13 +0000)
move both asus boards to asus.mk
rename HW5503G profile to HW550-3G to match name in image/Makefile
(fixes #16599)

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
SVN-Revision: 41271

target/linux/ramips/rt305x/profiles/asus.mk [new file with mode: 0644]
target/linux/ramips/rt305x/profiles/aztech.mk
target/linux/ramips/rt305x/profiles/n10-plus.mk (revision 0) [deleted file]
target/linux/ramips/rt305x/profiles/n13u.mk [deleted file]

diff --git a/target/linux/ramips/rt305x/profiles/asus.mk b/target/linux/ramips/rt305x/profiles/asus.mk
new file mode 100644 (file)
index 0000000..fcf4aa4
--- /dev/null
@@ -0,0 +1,27 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/RT-N10-PLUS
+       NAME:=Asus RT-N10+
+       PACKAGES:=kmod-leds-gpio wpa
+endef
+
+define Profile/RT-N10-PLUS/Description
+       Package set for Asus RT-N10+.
+endef
+
+define Profile/RT-N13U
+       NAME:=Asus RT-N13U
+       PACKAGES:=kmod-leds-gpio kmod-rt2800-pci wpad-mini kmod-usb-rt305x-dwc_otg
+endef
+
+define Profile/RT-N13U/Description
+       Package set for Asus RT-N13U.
+endef
+
+$(eval $(call Profile,RT-N10-PLUS))
+$(eval $(call Profile,RT-N13U))
index ab2d8cba2f367d65fd224e3c50a92df8edab10c6..63e5d5e294ed83abbd9c1f7f318eb24856d9fc6b 100644 (file)
@@ -5,15 +5,15 @@
 # See /LICENSE for more information.
 #
 
-define Profile/HW5503G
+define Profile/HW550-3G
        NAME:=Aztech HW550-3G
        PACKAGES:=\
                kmod-usb-core kmod-usb-rt305x-dwc_otg \
                kmod-ledtrig-usbdev
 endef
 
-define Profile/HW5503G/Description
+define Profile/HW550-3G/Description
        Package set for Aztech HW550-3G
 endef
 
-$(eval $(call Profile,HW5503G))
+$(eval $(call Profile,HW550-3G))
diff --git a/target/linux/ramips/rt305x/profiles/n10-plus.mk (revision 0) b/target/linux/ramips/rt305x/profiles/n10-plus.mk (revision 0)
deleted file mode 100644 (file)
index 8c122f7..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-#
-# Copyright (C) 2014 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/RT-N10-PLUS
-    NAME:=Asus RT-N10+
-    PACKAGES:=kmod-leds-gpio wpa
-endef
-
-define Profile/RT-N10-PLUS/Description
-    Package set for Asus RT-N10+.
-endef
-
-$(eval $(call Profile,RT-N10-PLUS))
diff --git a/target/linux/ramips/rt305x/profiles/n13u.mk b/target/linux/ramips/rt305x/profiles/n13u.mk
deleted file mode 100644 (file)
index 6c81722..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-#
-# Copyright (C) 2010 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/RT-N13U
-       NAME:=Asus RT-N13U
-       PACKAGES:=kmod-leds-gpio kmod-rt2800-pci wpad-mini kmod-usb-rt305x-dwc_otg
-endef
-
-define Profile/RT-N13U/Description
-       Package set for Asus RT-N13U.
-endef
-
-$(eval $(call Profile,RT-N13U))