generate ubifs images
authorImre Kaloz <kaloz@openwrt.org>
Wed, 12 Feb 2014 10:48:33 +0000 (10:48 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Wed, 12 Feb 2014 10:48:33 +0000 (10:48 +0000)
Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
SVN-Revision: 39576

target/linux/omap/Makefile
target/linux/omap/image/Makefile
target/linux/omap/image/ubinize.cfg [new file with mode: 0644]

index bc811a154fa65f01122a193b05b8ef40731b7b52..b27ca2fcca92aec035730dd4862053e2c1be299d 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=omap
 BOARDNAME:=TI OMAP3/4/AM33xx
-FEATURES:=usb usbgadget ext4 targz fpu audio display
+FEATURES:=usb usbgadget ext4 targz fpu audio display ubifs
 CPU_TYPE:=cortex-a9
 CPU_SUBTYPE:=vfpv3
 
index 42ca517c589c3958d61795511adc1b30bdf571be..91b9df3b57b3e669fa2d6b400ff372042e79c3bc 100644 (file)
@@ -7,6 +7,9 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
+UBIFS_OPTS = -F -m 2048 -e 124KiB -c 4096 -U
+UBI_OPTS = -m 2048 -p 128KiB -s 512 -O 2048
+
 define Image/BuildKernel
        cp $(KDIR)/zImage $(BIN_DIR)/openwrt-$(BOARD)-zImage
        -mkdir $(BIN_DIR)/dtbs
diff --git a/target/linux/omap/image/ubinize.cfg b/target/linux/omap/image/ubinize.cfg
new file mode 100644 (file)
index 0000000..49d55b9
--- /dev/null
@@ -0,0 +1,14 @@
+[rootfs]
+# Volume mode (other option is static)
+mode=ubi
+# Source image
+image=root.ubifs
+# Volume ID in UBI image
+vol_id=0
+# Allow for dynamic resize
+vol_type=dynamic
+# Volume name
+vol_name=rootfs
+# Autoresize volume at first mount
+vol_flags=autoresize
+