ramips: add support for RT-N14U (mt7620n based) board
authorJohn Crispin <john@openwrt.org>
Wed, 25 Dec 2013 17:04:50 +0000 (17:04 +0000)
committerJohn Crispin <john@openwrt.org>
Wed, 25 Dec 2013 17:04:50 +0000 (17:04 +0000)
added dts file and userspace scripts modified to support Asus RT-N14U board

current support status:
usb        works
ethernet   works
buttons    reset, wps
leds       asus:blue:[usb|lan|wan|air|power]
i2c        not tested
uart       not tested
wifi       not yet

Signed-off-by: Pavel Löbl <lobl.pavel@gmail.com>
SVN-Revision: 39163

target/linux/ramips/base-files/etc/uci-defaults/01_leds
target/linux/ramips/base-files/etc/uci-defaults/02_network
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/dts/RT-N14U.dts [new file with mode: 0644]
target/linux/ramips/image/Makefile

index 44951d8e230593049c43a30d5a21bdc43d391365..fe22875596d471bee62d7aa14726a86d60caf54e 100755 (executable)
@@ -141,6 +141,13 @@ case $board in
        wnce2001)
                set_wifi_led "netgear:green:wlan"
                ;;
+       rt-n14u)
+               ucidef_set_led_default "power" "power" "asus:blue:power" "1"
+               ucidef_set_led_netdev "lan" "lan" "asus:blue:lan" "eth0.1"
+               ucidef_set_led_netdev "wan" "wan" "asus:blue:wan" "eth0.2"
+               set_wifi_led "asus:blue:air"
+               set_usb_led "asus:blue:usb"
+               ;;
        rp-n53)
                ucidef_set_led_netdev "eth" "Network" "asus:white:back" "eth0"
                set_wifi_led "asus:blue:wifi"
index 63458eda0a501ba663d95f81deb99070ed4c911f..a9914fdb872d77c8e691e3d73fbf07cb7d132ff4 100755 (executable)
@@ -87,6 +87,7 @@ ramips_setup_interfaces()
        f5d8235-v1 | \
        f5d8235-v2 | \
        hg255d | \
+       rt-n14u | \
        ur-326n4g)
                ucidef_set_interfaces_lan_wan "eth0.1" "eth0.2"
                ucidef_add_switch "switch0" "1" "1"
index 972f41534f6f6b5f5d7fd3b8372237cf4c47c600..d62002ea7cf235dc7c0e4669f7f7fad83148c0a7 100755 (executable)
@@ -127,6 +127,9 @@ ramips_board_detect() {
        *"La Fonera 2.0N")
                name="fonera20n"
                ;;
+       *"Asus RT-N14U")
+               name="rt-n14u"
+               ;;
        *"Asus RT-N13U")
                name="rt-n13u"
                ;;
index 6836e16d9631e4502eccaeafed1c0a7aa6cf54ee..babeaf21800bbad28e5db6b7e665447918cd3ae2 100755 (executable)
@@ -63,6 +63,7 @@ platform_check_image() {
        rp-n53 | \
        rt-g32-b1 | \
        rt-n10-plus | \
+       rt-n14u | \
        rt-n15 | \
        rt-n56u | \
        sl-r7205 | \
diff --git a/target/linux/ramips/dts/RT-N14U.dts b/target/linux/ramips/dts/RT-N14U.dts
new file mode 100644 (file)
index 0000000..d95365b
--- /dev/null
@@ -0,0 +1,118 @@
+/dts-v1/;
+
+/include/ "mt7620n.dtsi"
+
+/ {
+       compatible = "asus,rt-n14u", "ralink,mt7620n-soc";
+       model = "Asus RT-N14U";
+
+       palmbus@10000000 {
+               gpio2: gpio@660 {
+                       status = "okay";
+               };
+
+               gpio3: gpio@688 {
+                       status = "okay";
+               };
+
+               spi@b00 {
+                       status = "okay";
+
+                       m25p80@0 {
+                               #address-cells = <1>;
+                               #size-cells = <1>;
+                               #compatible = "mx25l6405d";
+                               compatible = "w25q128";
+                               reg = <0 0>;
+                               linux,modalias = "m25p80", "w25q128";
+                               spi-max-frequency = <10000000>;
+
+                               partition@0 {
+                                       label = "u-boot";
+                                       reg = <0x0 0x30000>;
+                                       read-only;
+                               };
+
+                               partition@30000 {
+                                       label = "u-boot-env";
+                                       reg = <0x30000 0x10000>;
+                                       read-only;
+                               };
+
+                               factory: partition@40000 {
+                                       label = "factory";
+                                       reg = <0x40000 0x10000>;
+                                       read-only;
+                               };
+
+                               partition@50000 {
+                                       label = "firmware";
+                                       reg = <0x50000 0xfb0000>;
+                               };
+                       };
+               };
+       };
+
+       ehci@101c0000 {
+               status = "okay";
+       };
+
+       ohci@101c1000 {
+               status = "okay";
+       };
+
+       ethernet@10100000 {
+               mtd-mac-address = <&factory 0x4>;
+               ralink,port-map = "wllll";
+       };
+
+       pinctrl {
+               state_default: pinctrl0 {
+                       default {
+                               ralink,group = "ephy", "wled";
+                               ralink,function = "gpio";
+                       };
+               };
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+               wan {
+                       label = "asus:blue:wan";
+                       gpios = <&gpio2 0 1>;
+               };
+               lan {
+                       label = "asus:blue:lan";
+                       gpios = <&gpio2 1 1>;
+               };
+               usb {
+                       label = "asus:blue:usb";
+                       gpios = <&gpio2 2 1>;
+               };
+               power {
+                       label = "asus:blue:power";
+                       gpios = <&gpio2 3 1>;
+               };
+               air {
+                       label = "asus:blue:air";
+                       gpios = <&gpio3 0 1>;
+               };
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+               reset {
+                       label = "reset";
+                       gpios = <&gpio0 1 1>;
+                       linux,code = <0x198>;
+               };
+               wps {
+                       label = "wps";
+                       gpios = <&gpio0 2 1>;
+                       linux,code = <0x211>;
+               };
+       };
+};
index 82addb27f8b3559af610877ddf82a6cb4dc5c729..2d4395dca41fcdaea390898ee6731c31f442abee 100644 (file)
@@ -646,10 +646,12 @@ endif
 #
 
 Image/Build/Profile/WMR300=$(call BuildFirmware/Default8M/$(1),$(1),wmr-300,WMR300)
+Image/Build/Profile/RT-N14U=$(call BuildFirmware/Default8M/$(1),$(1),rt-n14u,RT-N14U)
 
 ifeq ($(SUBTARGET),mt7620n)
 define Image/Build/Profile/Default
        $(call Image/Build/Profile/WMR300,$(1))
+       $(call Image/Build/Profile/RT-N14U,$(1))
 endef
 endif