uboot-pxa: remove package
authorFelix Fietkau <nbd@nbd.name>
Mon, 23 Jan 2017 11:42:35 +0000 (12:42 +0100)
committerFelix Fietkau <nbd@nbd.name>
Tue, 24 Jan 2017 15:21:25 +0000 (16:21 +0100)
support for pxa has been gone for a long time now

Signed-off-by: Felix Fietkau <nbd@nbd.name>
package/boot/uboot-pxa/Makefile [deleted file]
package/boot/uboot-pxa/patches/001-squashfs_rootfstype_cmdline.patch [deleted file]

diff --git a/package/boot/uboot-pxa/Makefile b/package/boot/uboot-pxa/Makefile
deleted file mode 100644 (file)
index 9c12ad7..0000000
+++ /dev/null
@@ -1,91 +0,0 @@
-#
-# Copyright (C) 2012 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/kernel.mk
-
-PKG_NAME:=u-boot
-PKG_RELEASE:=1
-
-PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL:=https://github.com/ashcharles/verdex-uboot.git
-PKG_SOURCE_DATE:=2011-08-25
-PKG_SOURCE_VERSION:=ca6bf3ef6ac5f5132a359b43dfa31e07076b74b7
-PKG_MIRROR_HASH:=7c92525b6c7bc0b6f065a9bfdf64d58a61583709cb44acb62a157ad3efc7c491
-
-PKG_LICENSE:=GPL-2.0 GPL-2.0+
-PKG_LICENSE_FILES:=Licenses/README
-
-include $(INCLUDE_DIR)/package.mk
-
-define uboot/Default
-  TITLE:=
-  CONFIG:=
-  IMAGE:=
-endef
-
-define uboot/gumstix
-  TITLE:=U-Boot for the Gumstix Verdex
-endef
-
-UBOOTS:=gumstix
-
-define Package/uboot/template
-define Package/uboot-pxa-$(1)
-  SECTION:=boot
-  CATEGORY:=Boot Loaders
-  DEPENDS:=@TARGET_pxa
-  TITLE:=$(2)
-  URL:=http://www.denx.de/wiki/U-Boot
-  VARIANT:=$(1)
-  MAINTAINER:=Florian Fainelli <florian@openwrt.org>
-endef
-endef
-
-define BuildUBootPackage
-       $(eval $(uboot/Default))
-       $(eval $(uboot/$(1)))
-       $(call Package/uboot/template,$(1),$(TITLE))
-endef
-
-ifdef BUILD_VARIANT
-$(eval $(call uboot/$(BUILD_VARIANT)))
-UBOOT_CONFIG:=$(if $(CONFIG),$(CONFIG),$(BUILD_VARIANT))
-UBOOT_IMAGE:=$(if $(IMAGE),$(IMAGE),openwrt-$(BOARD)-$(BUILD_VARIANT)-u-boot.bin)
-endif
-
-define Build/Configure
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               $(UBOOT_CONFIG)_config
-endef
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               u-boot.bin \
-               CROSS_COMPILE=$(TARGET_CROSS)
-endef
-
-define Package/uboot/install/default
-       $(INSTALL_DIR) $(BIN_DIR)
-       $(CP) $(PKG_BUILD_DIR)/u-boot.bin \
-               $(BIN_DIR)/openwrt-$(BOARD)-$(1)-u-boot.bin
-endef
-
-define Package/uboot/install/template
-define Package/uboot-pxa-$(1)/install
-       $(call Package/uboot/install/default,$(2))
-endef
-endef
-
-$(foreach u,$(UBOOTS), \
-       $(eval $(call Package/uboot/install/template,$(u),$(u))) \
-)
-
-$(foreach u,$(UBOOTS), \
-       $(eval $(call BuildUBootPackage,$(u))) \
-       $(eval $(call BuildPackage,uboot-pxa-$(u))) \
-)
diff --git a/package/boot/uboot-pxa/patches/001-squashfs_rootfstype_cmdline.patch b/package/boot/uboot-pxa/patches/001-squashfs_rootfstype_cmdline.patch
deleted file mode 100644 (file)
index cfef66b..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/include/configs/gumstix.h b/include/configs/gumstix.h
-index 319da63..5483993 100644
---- a/include/configs/gumstix.h
-+++ b/include/configs/gumstix.h
-@@ -136,7 +136,7 @@
- #define CONFIG_MISC_INIT_R    /* misc_init_r function in gumstix sets board serial number */
- #define CONFIG_BOOTFILE               boot/uImage
--#define CONFIG_BOOTARGS               "console=ttyS0,115200n8 root=1f01 rootfstype=jffs2 reboot=cold,hard"
-+#define CONFIG_BOOTARGS               "console=ttyS0,115200n8 root=1f01 rootfstype=squashfs,jffs2 reboot=cold,hard"
- #define CONFIG_BOOTCOMMAND    "icache on; setenv stderr nulldev; setenv stdout nulldev; if pinit on && fatload ide 0 a2000000 gumstix-factory.script; then setenv stdout serial; setenv stderr serial; echo Found gumstix-factory.script on CF...; autoscr; else if mmcinit && fatload mmc 0 a2000000 gumstix-factory.script; then setenv stdout serial; setenv stderr serial; echo Found gumstix-factory.script on MMC...; autoscr; else setenv stdout serial; setenv stderr serial; katload 100000 && bootm; fi; fi"
- #define CONFIG_BOOTDELAY      2               /* in seconds */
- #define CONFIG_EXTRA_ENV_SETTINGS     "verify=no"