remove support for old kernels
authorFlorian Fainelli <florian@openwrt.org>
Sat, 17 Mar 2012 11:55:59 +0000 (11:55 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 17 Mar 2012 11:55:59 +0000 (11:55 +0000)
SVN-Revision: 30963

22 files changed:
target/linux/uml/patches-2.6.32/001-gcc4_unit_at_a_time_i386_fix.patch [deleted file]
target/linux/uml/patches-2.6.32/002-gcc4_unfortify_source.patch [deleted file]
target/linux/uml/patches-2.6.32/003-fix_memcpy_export_on_x86_64.patch [deleted file]
target/linux/uml/patches-2.6.32/006-uml_libc_link_errors.patch [deleted file]
target/linux/uml/patches-2.6.32/007-uml_missing_stat_h.patch [deleted file]
target/linux/uml/patches-2.6.32/901-lib_zlib_deflate_visible.patch [deleted file]
target/linux/uml/patches-2.6.37/001-gcc4_unit_at_a_time_i386_fix.patch [deleted file]
target/linux/uml/patches-2.6.37/002-gcc4_unfortify_source.patch [deleted file]
target/linux/uml/patches-2.6.37/006-uml_libc_link_errors.patch [deleted file]
target/linux/uml/patches-2.6.37/901-lib_zlib_deflate_visible.patch [deleted file]
target/linux/uml/patches-2.6.38/001-gcc4_unit_at_a_time_i386_fix.patch [deleted file]
target/linux/uml/patches-2.6.38/002-gcc4_unfortify_source.patch [deleted file]
target/linux/uml/patches-2.6.38/006-uml_libc_link_errors.patch [deleted file]
target/linux/uml/patches-2.6.38/901-lib_zlib_deflate_visible.patch [deleted file]
target/linux/uml/patches-2.6.39/001-gcc4_unit_at_a_time_i386_fix.patch [deleted file]
target/linux/uml/patches-2.6.39/002-export___sprintf_chk.patch [deleted file]
target/linux/uml/patches-2.6.39/006-uml_libc_link_errors.patch [deleted file]
target/linux/uml/patches-2.6.39/901-lib_zlib_deflate_visible.patch [deleted file]
target/linux/uml/patches-3.0/001-gcc4_unit_at_a_time_i386_fix.patch [deleted file]
target/linux/uml/patches-3.0/002-export___sprintf_chk.patch [deleted file]
target/linux/uml/patches-3.0/004-fix_atomic64_32.patch [deleted file]
target/linux/uml/patches-3.0/901-lib_zlib_deflate_visible.patch [deleted file]

diff --git a/target/linux/uml/patches-2.6.32/001-gcc4_unit_at_a_time_i386_fix.patch b/target/linux/uml/patches-2.6.32/001-gcc4_unit_at_a_time_i386_fix.patch
deleted file mode 100644 (file)
index 442c0ec..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/arch/um/Makefile-i386
-+++ b/arch/um/Makefile-i386
-@@ -35,7 +35,7 @@ cflags-y += -ffreestanding
- # Disable unit-at-a-time mode on pre-gcc-4.0 compilers, it makes gcc use
- # a lot more stack due to the lack of sharing of stacklots.  Also, gcc
- # 4.3.0 needs -funit-at-a-time for extern inline functions.
--KBUILD_CFLAGS += $(shell if [ $(call cc-version) -lt 0400 ] ; then \
-+KBUILD_CFLAGS += $(shell if [ $(call cc-version) -lt 0403 ] ; then \
-                       echo $(call cc-option,-fno-unit-at-a-time); \
-                       else echo $(call cc-option,-funit-at-a-time); fi ;)
diff --git a/target/linux/uml/patches-2.6.32/002-gcc4_unfortify_source.patch b/target/linux/uml/patches-2.6.32/002-gcc4_unfortify_source.patch
deleted file mode 100644 (file)
index 2be33d0..0000000
+++ /dev/null
@@ -1,21 +0,0 @@
---- a/arch/um/Makefile-i386
-+++ b/arch/um/Makefile-i386
-@@ -39,4 +39,8 @@ KBUILD_CFLAGS += $(shell if [ $(call cc-
-                       echo $(call cc-option,-fno-unit-at-a-time); \
-                       else echo $(call cc-option,-funit-at-a-time); fi ;)
-+# disable compile-time buffer checks, enabled by default on Ubuntu 8.10 
-+# and later
-+KBUILD_CFLAGS += $(call cc-option,-U_FORTIFY_SOURCE)
-+
- KBUILD_CFLAGS += $(cflags-y)
---- a/arch/um/Makefile-x86_64
-+++ b/arch/um/Makefile-x86_64
-@@ -24,3 +24,7 @@ LINK-y += -m64
- # Do unit-at-a-time unconditionally on x86_64, following the host
- KBUILD_CFLAGS += $(call cc-option,-funit-at-a-time)
-+
-+# disable compile-time buffer checks, enabled by default on Ubuntu 8.10 
-+# and later
-+KBUILD_CFLAGS += $(call cc-option,-U_FORTIFY_SOURCE)
diff --git a/target/linux/uml/patches-2.6.32/003-fix_memcpy_export_on_x86_64.patch b/target/linux/uml/patches-2.6.32/003-fix_memcpy_export_on_x86_64.patch
deleted file mode 100644 (file)
index 7d2efe4..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/arch/um/os-Linux/user_syms.c
-+++ b/arch/um/os-Linux/user_syms.c
-@@ -23,7 +23,7 @@ extern int printf(const char *, ...);
- EXPORT_SYMBOL(strstr);
- #endif
--#ifndef __x86_64__
-+#if !defined(__x86_64) || (__GNUC__ == 4 && __GNUC_MINOR__ < 3) || (__GNUC__ < 4)
- extern void *memcpy(void *, const void *, size_t);
- EXPORT_SYMBOL(memcpy);
- #endif
diff --git a/target/linux/uml/patches-2.6.32/006-uml_libc_link_errors.patch b/target/linux/uml/patches-2.6.32/006-uml_libc_link_errors.patch
deleted file mode 100644 (file)
index 2adfe03..0000000
+++ /dev/null
@@ -1,50 +0,0 @@
---- a/arch/um/kernel/dyn.lds.S
-+++ b/arch/um/kernel/dyn.lds.S
-@@ -50,8 +50,21 @@ SECTIONS
-   .rela.got       : { *(.rela.got) }
-   .rel.bss        : { *(.rel.bss .rel.bss.* .rel.gnu.linkonce.b.*) }
-   .rela.bss       : { *(.rela.bss .rela.bss.* .rela.gnu.linkonce.b.*) }
--  .rel.plt        : { *(.rel.plt) }
--  .rela.plt       : { *(.rela.plt) }
-+  /* Deal with multilib libc */
-+  .rel.plt        :
-+  {
-+    *(.rel.plt)
-+    PROVIDE_HIDDEN (__rel_iplt_start = .);
-+    *(.rel.iplt)
-+    PROVIDE_HIDDEN (__rel_iplt_end = .);
-+  }
-+  .rela.plt       :
-+  {
-+    *(.rela.plt)
-+    PROVIDE_HIDDEN (__rela_iplt_start = .);
-+    *(.rela.iplt)
-+    PROVIDE_HIDDEN (__rela_iplt_end = .);
-+  }
-   .init           : {
-     KEEP (*(.init))
-   } =0x90909090
---- a/arch/um/kernel/uml.lds.S
-+++ b/arch/um/kernel/uml.lds.S
-@@ -35,6 +35,21 @@ SECTIONS
-     *(.gnu.warning)
-     *(.gnu.linkonce.t*)
-   }
-+  /* Deal with multilib libc */
-+  .rel.plt        :
-+  {
-+    *(.rel.plt)
-+    PROVIDE_HIDDEN (__rel_iplt_start = .);
-+    *(.rel.iplt)
-+    PROVIDE_HIDDEN (__rel_iplt_end = .);
-+  }
-+  .rela.plt       :
-+  {
-+    *(.rela.plt)
-+    PROVIDE_HIDDEN (__rela_iplt_start = .);
-+    *(.rela.iplt)
-+    PROVIDE_HIDDEN (__rela_iplt_end = .);
-+  }
-   . = ALIGN(PAGE_SIZE);
-   .syscall_stub : {
diff --git a/target/linux/uml/patches-2.6.32/007-uml_missing_stat_h.patch b/target/linux/uml/patches-2.6.32/007-uml_missing_stat_h.patch
deleted file mode 100644 (file)
index bddd23c..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/arch/um/os-Linux/mem.c
-+++ b/arch/um/os-Linux/mem.c
-@@ -10,6 +10,7 @@
- #include <errno.h>
- #include <fcntl.h>
- #include <string.h>
-+#include <sys/stat.h>
- #include <sys/mman.h>
- #include <sys/param.h>
- #include "init.h"
diff --git a/target/linux/uml/patches-2.6.32/901-lib_zlib_deflate_visible.patch b/target/linux/uml/patches-2.6.32/901-lib_zlib_deflate_visible.patch
deleted file mode 100644 (file)
index 116d76f..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-make ZLIB_DEFLATE visible, so that we can choose whether we want it built-in
-or as a module
-
---- a/lib/Kconfig
-+++ b/lib/Kconfig
-@@ -95,7 +95,7 @@ config ZLIB_INFLATE
-       tristate
- config ZLIB_DEFLATE
--      tristate
-+      tristate "Zlib compression"
- config LZO_COMPRESS
-       tristate
diff --git a/target/linux/uml/patches-2.6.37/001-gcc4_unit_at_a_time_i386_fix.patch b/target/linux/uml/patches-2.6.37/001-gcc4_unit_at_a_time_i386_fix.patch
deleted file mode 100644 (file)
index 442c0ec..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/arch/um/Makefile-i386
-+++ b/arch/um/Makefile-i386
-@@ -35,7 +35,7 @@ cflags-y += -ffreestanding
- # Disable unit-at-a-time mode on pre-gcc-4.0 compilers, it makes gcc use
- # a lot more stack due to the lack of sharing of stacklots.  Also, gcc
- # 4.3.0 needs -funit-at-a-time for extern inline functions.
--KBUILD_CFLAGS += $(shell if [ $(call cc-version) -lt 0400 ] ; then \
-+KBUILD_CFLAGS += $(shell if [ $(call cc-version) -lt 0403 ] ; then \
-                       echo $(call cc-option,-fno-unit-at-a-time); \
-                       else echo $(call cc-option,-funit-at-a-time); fi ;)
diff --git a/target/linux/uml/patches-2.6.37/002-gcc4_unfortify_source.patch b/target/linux/uml/patches-2.6.37/002-gcc4_unfortify_source.patch
deleted file mode 100644 (file)
index 2be33d0..0000000
+++ /dev/null
@@ -1,21 +0,0 @@
---- a/arch/um/Makefile-i386
-+++ b/arch/um/Makefile-i386
-@@ -39,4 +39,8 @@ KBUILD_CFLAGS += $(shell if [ $(call cc-
-                       echo $(call cc-option,-fno-unit-at-a-time); \
-                       else echo $(call cc-option,-funit-at-a-time); fi ;)
-+# disable compile-time buffer checks, enabled by default on Ubuntu 8.10 
-+# and later
-+KBUILD_CFLAGS += $(call cc-option,-U_FORTIFY_SOURCE)
-+
- KBUILD_CFLAGS += $(cflags-y)
---- a/arch/um/Makefile-x86_64
-+++ b/arch/um/Makefile-x86_64
-@@ -24,3 +24,7 @@ LINK-y += -m64
- # Do unit-at-a-time unconditionally on x86_64, following the host
- KBUILD_CFLAGS += $(call cc-option,-funit-at-a-time)
-+
-+# disable compile-time buffer checks, enabled by default on Ubuntu 8.10 
-+# and later
-+KBUILD_CFLAGS += $(call cc-option,-U_FORTIFY_SOURCE)
diff --git a/target/linux/uml/patches-2.6.37/006-uml_libc_link_errors.patch b/target/linux/uml/patches-2.6.37/006-uml_libc_link_errors.patch
deleted file mode 100644 (file)
index 0bab54c..0000000
+++ /dev/null
@@ -1,24 +0,0 @@
---- a/arch/um/kernel/uml.lds.S
-+++ b/arch/um/kernel/uml.lds.S
-@@ -35,6 +35,21 @@ SECTIONS
-     *(.gnu.warning)
-     *(.gnu.linkonce.t*)
-   }
-+  /* Deal with multilib libc */
-+  .rel.plt        :
-+  {
-+    *(.rel.plt)
-+    PROVIDE_HIDDEN (__rel_iplt_start = .);
-+    *(.rel.iplt)
-+    PROVIDE_HIDDEN (__rel_iplt_end = .);
-+  }
-+  .rela.plt       :
-+  {
-+    *(.rela.plt)
-+    PROVIDE_HIDDEN (__rela_iplt_start = .);
-+    *(.rela.iplt)
-+    PROVIDE_HIDDEN (__rela_iplt_end = .);
-+  }
-   . = ALIGN(PAGE_SIZE);
-   .syscall_stub : {
diff --git a/target/linux/uml/patches-2.6.37/901-lib_zlib_deflate_visible.patch b/target/linux/uml/patches-2.6.37/901-lib_zlib_deflate_visible.patch
deleted file mode 100644 (file)
index f4aba9b..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-make ZLIB_DEFLATE visible, so that we can choose whether we want it built-in
-or as a module
-
---- a/lib/Kconfig
-+++ b/lib/Kconfig
-@@ -98,7 +98,7 @@ config ZLIB_INFLATE
-       tristate
- config ZLIB_DEFLATE
--      tristate
-+      tristate "Zlib compression"
- config LZO_COMPRESS
-       tristate
diff --git a/target/linux/uml/patches-2.6.38/001-gcc4_unit_at_a_time_i386_fix.patch b/target/linux/uml/patches-2.6.38/001-gcc4_unit_at_a_time_i386_fix.patch
deleted file mode 100644 (file)
index 442c0ec..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/arch/um/Makefile-i386
-+++ b/arch/um/Makefile-i386
-@@ -35,7 +35,7 @@ cflags-y += -ffreestanding
- # Disable unit-at-a-time mode on pre-gcc-4.0 compilers, it makes gcc use
- # a lot more stack due to the lack of sharing of stacklots.  Also, gcc
- # 4.3.0 needs -funit-at-a-time for extern inline functions.
--KBUILD_CFLAGS += $(shell if [ $(call cc-version) -lt 0400 ] ; then \
-+KBUILD_CFLAGS += $(shell if [ $(call cc-version) -lt 0403 ] ; then \
-                       echo $(call cc-option,-fno-unit-at-a-time); \
-                       else echo $(call cc-option,-funit-at-a-time); fi ;)
diff --git a/target/linux/uml/patches-2.6.38/002-gcc4_unfortify_source.patch b/target/linux/uml/patches-2.6.38/002-gcc4_unfortify_source.patch
deleted file mode 100644 (file)
index 2be33d0..0000000
+++ /dev/null
@@ -1,21 +0,0 @@
---- a/arch/um/Makefile-i386
-+++ b/arch/um/Makefile-i386
-@@ -39,4 +39,8 @@ KBUILD_CFLAGS += $(shell if [ $(call cc-
-                       echo $(call cc-option,-fno-unit-at-a-time); \
-                       else echo $(call cc-option,-funit-at-a-time); fi ;)
-+# disable compile-time buffer checks, enabled by default on Ubuntu 8.10 
-+# and later
-+KBUILD_CFLAGS += $(call cc-option,-U_FORTIFY_SOURCE)
-+
- KBUILD_CFLAGS += $(cflags-y)
---- a/arch/um/Makefile-x86_64
-+++ b/arch/um/Makefile-x86_64
-@@ -24,3 +24,7 @@ LINK-y += -m64
- # Do unit-at-a-time unconditionally on x86_64, following the host
- KBUILD_CFLAGS += $(call cc-option,-funit-at-a-time)
-+
-+# disable compile-time buffer checks, enabled by default on Ubuntu 8.10 
-+# and later
-+KBUILD_CFLAGS += $(call cc-option,-U_FORTIFY_SOURCE)
diff --git a/target/linux/uml/patches-2.6.38/006-uml_libc_link_errors.patch b/target/linux/uml/patches-2.6.38/006-uml_libc_link_errors.patch
deleted file mode 100644 (file)
index 0bab54c..0000000
+++ /dev/null
@@ -1,24 +0,0 @@
---- a/arch/um/kernel/uml.lds.S
-+++ b/arch/um/kernel/uml.lds.S
-@@ -35,6 +35,21 @@ SECTIONS
-     *(.gnu.warning)
-     *(.gnu.linkonce.t*)
-   }
-+  /* Deal with multilib libc */
-+  .rel.plt        :
-+  {
-+    *(.rel.plt)
-+    PROVIDE_HIDDEN (__rel_iplt_start = .);
-+    *(.rel.iplt)
-+    PROVIDE_HIDDEN (__rel_iplt_end = .);
-+  }
-+  .rela.plt       :
-+  {
-+    *(.rela.plt)
-+    PROVIDE_HIDDEN (__rela_iplt_start = .);
-+    *(.rela.iplt)
-+    PROVIDE_HIDDEN (__rela_iplt_end = .);
-+  }
-   . = ALIGN(PAGE_SIZE);
-   .syscall_stub : {
diff --git a/target/linux/uml/patches-2.6.38/901-lib_zlib_deflate_visible.patch b/target/linux/uml/patches-2.6.38/901-lib_zlib_deflate_visible.patch
deleted file mode 100644 (file)
index f4aba9b..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-make ZLIB_DEFLATE visible, so that we can choose whether we want it built-in
-or as a module
-
---- a/lib/Kconfig
-+++ b/lib/Kconfig
-@@ -98,7 +98,7 @@ config ZLIB_INFLATE
-       tristate
- config ZLIB_DEFLATE
--      tristate
-+      tristate "Zlib compression"
- config LZO_COMPRESS
-       tristate
diff --git a/target/linux/uml/patches-2.6.39/001-gcc4_unit_at_a_time_i386_fix.patch b/target/linux/uml/patches-2.6.39/001-gcc4_unit_at_a_time_i386_fix.patch
deleted file mode 100644 (file)
index 442c0ec..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/arch/um/Makefile-i386
-+++ b/arch/um/Makefile-i386
-@@ -35,7 +35,7 @@ cflags-y += -ffreestanding
- # Disable unit-at-a-time mode on pre-gcc-4.0 compilers, it makes gcc use
- # a lot more stack due to the lack of sharing of stacklots.  Also, gcc
- # 4.3.0 needs -funit-at-a-time for extern inline functions.
--KBUILD_CFLAGS += $(shell if [ $(call cc-version) -lt 0400 ] ; then \
-+KBUILD_CFLAGS += $(shell if [ $(call cc-version) -lt 0403 ] ; then \
-                       echo $(call cc-option,-fno-unit-at-a-time); \
-                       else echo $(call cc-option,-funit-at-a-time); fi ;)
diff --git a/target/linux/uml/patches-2.6.39/002-export___sprintf_chk.patch b/target/linux/uml/patches-2.6.39/002-export___sprintf_chk.patch
deleted file mode 100644 (file)
index 1d3cf49..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-diff --git a/arch/um/os-Linux/user_syms.c b/arch/um/os-Linux/user_syms.c
-index 05f5ea8..9e71e7e 100644
---- a/arch/um/os-Linux/user_syms.c
-+++ b/arch/um/os-Linux/user_syms.c
-@@ -18,6 +18,9 @@ extern void *memmove(void *, const void *, size_t);
- extern void *memset(void *, int, size_t);
- extern int printf(const char *, ...);
-+extern int __sprintf_chk(char *str, int flag, size_t strlen, const char *format);
-+EXPORT_SYMBOL(__sprintf_chk);
-+
- /* If it's not defined, the export is included in lib/string.c.*/
- #ifdef __HAVE_ARCH_STRSTR
- EXPORT_SYMBOL(strstr);
diff --git a/target/linux/uml/patches-2.6.39/006-uml_libc_link_errors.patch b/target/linux/uml/patches-2.6.39/006-uml_libc_link_errors.patch
deleted file mode 100644 (file)
index 0bab54c..0000000
+++ /dev/null
@@ -1,24 +0,0 @@
---- a/arch/um/kernel/uml.lds.S
-+++ b/arch/um/kernel/uml.lds.S
-@@ -35,6 +35,21 @@ SECTIONS
-     *(.gnu.warning)
-     *(.gnu.linkonce.t*)
-   }
-+  /* Deal with multilib libc */
-+  .rel.plt        :
-+  {
-+    *(.rel.plt)
-+    PROVIDE_HIDDEN (__rel_iplt_start = .);
-+    *(.rel.iplt)
-+    PROVIDE_HIDDEN (__rel_iplt_end = .);
-+  }
-+  .rela.plt       :
-+  {
-+    *(.rela.plt)
-+    PROVIDE_HIDDEN (__rela_iplt_start = .);
-+    *(.rela.iplt)
-+    PROVIDE_HIDDEN (__rela_iplt_end = .);
-+  }
-   . = ALIGN(PAGE_SIZE);
-   .syscall_stub : {
diff --git a/target/linux/uml/patches-2.6.39/901-lib_zlib_deflate_visible.patch b/target/linux/uml/patches-2.6.39/901-lib_zlib_deflate_visible.patch
deleted file mode 100644 (file)
index f4aba9b..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-make ZLIB_DEFLATE visible, so that we can choose whether we want it built-in
-or as a module
-
---- a/lib/Kconfig
-+++ b/lib/Kconfig
-@@ -98,7 +98,7 @@ config ZLIB_INFLATE
-       tristate
- config ZLIB_DEFLATE
--      tristate
-+      tristate "Zlib compression"
- config LZO_COMPRESS
-       tristate
diff --git a/target/linux/uml/patches-3.0/001-gcc4_unit_at_a_time_i386_fix.patch b/target/linux/uml/patches-3.0/001-gcc4_unit_at_a_time_i386_fix.patch
deleted file mode 100644 (file)
index 442c0ec..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/arch/um/Makefile-i386
-+++ b/arch/um/Makefile-i386
-@@ -35,7 +35,7 @@ cflags-y += -ffreestanding
- # Disable unit-at-a-time mode on pre-gcc-4.0 compilers, it makes gcc use
- # a lot more stack due to the lack of sharing of stacklots.  Also, gcc
- # 4.3.0 needs -funit-at-a-time for extern inline functions.
--KBUILD_CFLAGS += $(shell if [ $(call cc-version) -lt 0400 ] ; then \
-+KBUILD_CFLAGS += $(shell if [ $(call cc-version) -lt 0403 ] ; then \
-                       echo $(call cc-option,-fno-unit-at-a-time); \
-                       else echo $(call cc-option,-funit-at-a-time); fi ;)
diff --git a/target/linux/uml/patches-3.0/002-export___sprintf_chk.patch b/target/linux/uml/patches-3.0/002-export___sprintf_chk.patch
deleted file mode 100644 (file)
index cda1ffe..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/arch/um/os-Linux/user_syms.c
-+++ b/arch/um/os-Linux/user_syms.c
-@@ -18,6 +18,9 @@ extern void *memmove(void *, const void
- extern void *memset(void *, int, size_t);
- extern int printf(const char *, ...);
-+extern int __sprintf_chk(char *str, int flag, size_t strlen, const char *format);
-+EXPORT_SYMBOL(__sprintf_chk);
-+
- /* If it's not defined, the export is included in lib/string.c.*/
- #ifdef __HAVE_ARCH_STRSTR
- EXPORT_SYMBOL(strstr);
diff --git a/target/linux/uml/patches-3.0/004-fix_atomic64_32.patch b/target/linux/uml/patches-3.0/004-fix_atomic64_32.patch
deleted file mode 100644 (file)
index fe1e48f..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
-[patch] um: export atomic64_* functions on i386
-
---- a/arch/um/sys-i386/Makefile
-+++ b/arch/um/sys-i386/Makefile
-@@ -8,7 +8,7 @@ obj-y = bug.o bugs.o checksum.o delay.o
- obj-$(CONFIG_BINFMT_ELF) += elfcore.o
--subarch-obj-y = lib/semaphore_32.o lib/string_32.o
-+subarch-obj-y = lib/atomic64_32.o lib/semaphore_32.o lib/string_32.o
- subarch-obj-$(CONFIG_HIGHMEM) += mm/highmem_32.o
- subarch-obj-$(CONFIG_MODULES) += kernel/module.o
diff --git a/target/linux/uml/patches-3.0/901-lib_zlib_deflate_visible.patch b/target/linux/uml/patches-3.0/901-lib_zlib_deflate_visible.patch
deleted file mode 100644 (file)
index e9ec0cb..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-make ZLIB_DEFLATE visible, so that we can choose whether we want it built-in
-or as a module
-
---- a/lib/Kconfig
-+++ b/lib/Kconfig
-@@ -91,7 +91,7 @@ config ZLIB_INFLATE
-       tristate
- config ZLIB_DEFLATE
--      tristate
-+      tristate "Zlib compression"
- config LZO_COMPRESS
-       tristate