uhttp: make sure that the ubus module is loaded when when installed
authorJohn Crispin <john@openwrt.org>
Mon, 11 Nov 2013 12:18:58 +0000 (12:18 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 11 Nov 2013 12:18:58 +0000 (12:18 +0000)
Signed-off-by: John Crispin <blogic@openwrt.org>
SVN-Revision: 38723

package/network/services/uhttpd/Makefile

index 2ff2ff798c834a015268edbabc481fb6a6075735..be1a1e27f133b13fd89d7003a079de98ea0f6ca9 100644 (file)
@@ -129,8 +129,9 @@ define Package/uhttpd-mod-lua/install
 endef
 
 define Package/uhttpd-mod-ubus/install
-       $(INSTALL_DIR) $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib $(1)/etc/uci-defaults
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/uhttpd_ubus.so $(1)/usr/lib/
+       $(INSTALL_DATA) ./files/ubus.default $(1)/etc/uci-defaults/00_uhttpd_ubus
 endef