ipq806x/nbg6817: add support for ZyXEL NBG6817
authorAndré Valentin <avalentin@marcant.net>
Tue, 25 Oct 2016 06:40:34 +0000 (08:40 +0200)
committerJohn Crispin <john@phrozen.org>
Wed, 26 Oct 2016 10:37:46 +0000 (12:37 +0200)
CPU: 2x1.8GHz ARM, RAM: 512MiB
Storage: 4MiB serial Flash, 3.9GiB MMC
NIC: 2x1GBit/s, Switch with 5 external and 2 internal ports
WiFi: Dualband, ath10k 2.4GHz, 5GHz MU-MIMO

For installation copy xx-mmcblk0p4-kernel.bin and xx-mmcblk0p5-rootfs-full.bin
to device. Then run:
cat xx-mmcblk0p4-kernel.bin > /dev/mmc0blk0p4
cat xx-mmcblk0p5-rootfs-full.bin > /dev/mmc0blk0p5
reboot -f

For debugging serial console is easily visible on board, no soldering needed.

Signed-off-by: André Valentin <avalentin@marcant.net>
target/linux/ipq806x/base-files/etc/board.d/01_leds
target/linux/ipq806x/base-files/etc/board.d/02_network
target/linux/ipq806x/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
target/linux/ipq806x/base-files/lib/ipq806x.sh
target/linux/ipq806x/config-4.4
target/linux/ipq806x/files/arch/arm/boot/dts/qcom-ipq8065-nbg6817.dts [new file with mode: 0644]
target/linux/ipq806x/image/Makefile
target/linux/ipq806x/patches-4.4/800-devicetree.patch

index a7ace1f92e5a22602e4eedfa3d2c4f18fd68efef..53c2a809930c972741b08afa0e2f97a801ced0e3 100755 (executable)
@@ -33,6 +33,11 @@ ea8500)
        ucidef_set_led_wlan "wifi" "WIFI" "ea8500:green:wifi" "phy0radio"
        ucidef_set_led_default "wps" "WPS" "ea8500:green:wps" "0"
        ;;
+nbg6817)
+       ucidef_set_led_wlan "wlan2g" "WLAN2g" "$board:amber:wifi" "phy1radio"
+       ucidef_set_led_wlan "wlan5g" "WLAN5G" "$board:amber:wifi5" "phy0radio"
+       ucidef_set_led_netdev "wan" "WAN" "$board:white:internet" "eth1"
+       ;;
 *)
        ;;
 esac
index b72045538a60f0699a748b3ec2c92ebac5051b13..a461033dfe6961e7dae69b2e40b3666247c3c805 100755 (executable)
@@ -35,6 +35,13 @@ ea8500)
        ucidef_set_interface_macaddr "lan" "$hw_mac_addr"
        ucidef_set_interface_macaddr "wan" "$hw_mac_addr"
        ;;
+nbg6817)
+       hw_mac_addr=$(mtd_get_mac_ascii 0:APPSBLENV ethaddr)
+       ucidef_add_switch "switch0" \
+               "1:lan" "2:lan" "3:lan" "4:lan" "6@eth1" "5:wan" "0@eth0"
+       ucidef_set_interface_macaddr "lan" "$hw_mac_addr"
+       ucidef_set_interface_macaddr "wan" "$(macaddr_add $hw_mac_addr 1)"
+       ;;
 *)
        echo "Unsupported hardware. Network interfaces not intialized"
        ;;
index c7977e6375f50af1622c56e4a27aa976b6f97b59..f95692a88904b791aee7fe9e5a564beeb1bb29ea 100644 (file)
@@ -56,6 +56,9 @@ case "$FIRMWARE" in
                hw_mac_addr=$(mtd_get_mac_ascii devinfo hw_mac_addr)
                ath10kcal_extract "art" 4096 12064
                ;;
+       nbg6817)
+               ath10kcal_extract "0:ART" 4096 12064
+               ;;
          r7500v2 |\
          r7800)
                ath10kcal_extract "art" 4096 12064
@@ -72,6 +75,9 @@ case "$FIRMWARE" in
                hw_mac_addr=$(mtd_get_mac_ascii devinfo hw_mac_addr)
                ath10kcal_extract "art" 20480 12064
                ;;
+       nbg6817)
+               ath10kcal_extract "0:ART" 20480 12064
+               ;;
         r7500v2 |\
         r7800)
                ath10kcal_extract "art" 20480 12064
index ea45381d91c2fbedab833b76e4597ade7200dbea..1bd0e2bd94231f0ef9acbedc190e58942383d1e6 100644 (file)
@@ -26,6 +26,9 @@ ipq806x_board_detect() {
        *"DB149")
                name="db149"
                ;;
+       *"NBG6817")
+               name="nbg6817"
+               ;;
        *"R7500")
                name="r7500"
                ;;
index bc040497cb626665ed124f5f84dbae249a3c8ccc..1972e3675e656c60a2d27e31573b835c3c7976f8 100644 (file)
@@ -61,6 +61,7 @@ CONFIG_ARM_THUMB=y
 CONFIG_ARM_UNWIND=y
 CONFIG_ARM_VIRT_EXT=y
 CONFIG_AT803X_PHY=y
+CONFIG_BLK_DEV_LOOP=y
 # CONFIG_BOOTPARAM_SOFTLOCKUP_PANIC is not set
 CONFIG_BOOTPARAM_SOFTLOCKUP_PANIC_VALUE=0
 CONFIG_BOUNCE=y
@@ -197,11 +198,6 @@ CONFIG_HAVE_GENERIC_DMA_COHERENT=y
 CONFIG_HAVE_HW_BREAKPOINT=y
 CONFIG_HAVE_IDE=y
 CONFIG_HAVE_IRQ_TIME_ACCOUNTING=y
-CONFIG_HAVE_KERNEL_GZIP=y
-CONFIG_HAVE_KERNEL_LZ4=y
-CONFIG_HAVE_KERNEL_LZMA=y
-CONFIG_HAVE_KERNEL_LZO=y
-CONFIG_HAVE_KERNEL_XZ=y
 CONFIG_HAVE_MEMBLOCK=y
 CONFIG_HAVE_MOD_ARCH_SPECIFIC=y
 CONFIG_HAVE_NET_DSA=y
@@ -262,6 +258,16 @@ CONFIG_MFD_SYSCON=y
 CONFIG_MIGHT_HAVE_CACHE_L2X0=y
 CONFIG_MIGHT_HAVE_PCI=y
 CONFIG_MIGRATION=y
+CONFIG_MMC=y
+CONFIG_MMC_ARMMMCI=y
+CONFIG_MMC_BLOCK=y
+CONFIG_MMC_BLOCK_MINORS=16
+CONFIG_MMC_QCOM_DML=y
+CONFIG_MMC_SDHCI=y
+CONFIG_MMC_SDHCI_MSM=y
+# CONFIG_MMC_SDHCI_PCI is not set
+CONFIG_MMC_SDHCI_PLTFM=y
+# CONFIG_MMC_TIFM_SD is not set
 CONFIG_MODULES_TREE_LOOKUP=y
 CONFIG_MODULES_USE_ELF_REL=y
 CONFIG_MSM_GCC_8660=y
@@ -378,7 +384,6 @@ CONFIG_QCOM_SCM=y
 CONFIG_QCOM_SCM_32=y
 # CONFIG_QCOM_SMD is not set
 CONFIG_QCOM_SMEM=y
-# CONFIG_QCOM_SPMI_TEMP_ALARM is not set
 CONFIG_QCOM_WDT=y
 CONFIG_RAS=y
 CONFIG_RATIONAL=y
@@ -389,6 +394,7 @@ CONFIG_RD_GZIP=y
 CONFIG_REGMAP=y
 CONFIG_REGMAP_MMIO=y
 CONFIG_REGULATOR=y
+CONFIG_REGULATOR_FIXED_VOLTAGE=y
 CONFIG_REGULATOR_QCOM_RPM=y
 # CONFIG_REGULATOR_QCOM_SPMI is not set
 CONFIG_RESET_CONTROLLER=y
diff --git a/target/linux/ipq806x/files/arch/arm/boot/dts/qcom-ipq8065-nbg6817.dts b/target/linux/ipq806x/files/arch/arm/boot/dts/qcom-ipq8065-nbg6817.dts
new file mode 100644 (file)
index 0000000..cc56213
--- /dev/null
@@ -0,0 +1,341 @@
+#include "qcom-ipq8065-v1.0.dtsi"
+
+#include <dt-bindings/input/input.h>
+
+/ {
+       model = "ZyXEL NBG6817";
+       compatible = "zyxel,nbg6817", "qcom,ipq8065";
+
+       memory@0 {
+               reg = <0x42000000 0x1e000000>;
+               device_type = "memory";
+       };
+
+       reserved-memory {
+               #address-cells = <1>;
+               #size-cells = <1>;
+               ranges;
+               rsvd@41200000 {
+                       reg = <0x41200000 0x300000>;
+                       no-map;
+               };
+       };
+
+       aliases {
+               serial0 = &uart4;
+               mdio-gpio0 = &mdio0;
+               sdcc1 = &sdcc1;
+       };
+
+       chosen {
+               bootargs = "root=/dev/mmcblk0p5 rootfstype=squashfs,ext4 rootwait noinitrd";
+               linux,stdout-path = "serial0:115200n8";
+       };
+
+       soc {
+               pinmux@800000 {
+                       pinctrl-0 = <&mdio0_pins &rgmii2_pins>;
+                       pinctrl-names = "default";
+
+                       i2c4_pins: i2c4_pinmux {
+                               mux {
+                                       pins = "gpio12", "gpio13";
+                                       function = "gsbi4";
+                                       drive-strength = <12>;
+                                       bias-disable;
+                               };
+                       };
+
+                       mdio0_pins: mdio0_pins {
+                               mux {
+                                       pins = "gpio0", "gpio1";
+                                       function = "gpio";
+                                       drive-strength = <8>;
+                                       bias-disable;
+                               };
+
+                               clk {
+                                       pins = "gpio1";
+                                       input-disable;
+                               };
+                       };
+
+                       rgmii2_pins: rgmii2_pins {
+                               mux {
+                                       pins = "gpio27", "gpio28", "gpio29", "gpio30", "gpio31", "gpio32",
+                                              "gpio51", "gpio52", "gpio59", "gpio60", "gpio61", "gpio62" ;
+                                       function = "rgmii2";
+                                       drive-strength = <8>;
+                                       bias-disable;
+                               };
+
+                               tx {
+                                       pins = "gpio27", "gpio28", "gpio29", "gpio30", "gpio31", "gpio32" ;
+                                       input-disable;
+                               };
+                       };
+
+                       spi_pins: spi_pins {
+                               mux {
+                                       pins = "gpio18", "gpio19", "gpio21";
+                                       function = "gsbi5";
+                                       drive-strength = <10>;
+                                       bias-none;
+                               };
+
+                               cs {
+                                       pins = "gpio20";
+                                       drive-strength = <12>;
+                               };
+                       };
+               };
+
+               gsbi@16300000 {
+                       qcom,mode = <GSBI_PROT_I2C_UART>;
+                       status = "ok";
+                       serial@16340000 {
+                               status = "ok";
+                       };
+                       /*
+                        * The i2c device on gsbi4 should not be enabled.
+                        * On ipq806x designs gsbi4 i2c is meant for exclusive
+                        * RPM usage. Turning this on in kernel manifests as
+                        * i2c failure for the RPM.
+                        */
+               };
+
+               gsbi5: gsbi@1a200000 {
+                       qcom,mode = <GSBI_PROT_SPI>;
+                       status = "ok";
+
+                       spi4: spi@1a280000 {
+                               status = "ok";
+                               spi-max-frequency = <50000000>;
+                               pinctrl-0 = <&spi_pins>;
+                               pinctrl-names = "default";
+
+                               cs-gpios = <&qcom_pinmux 20 GPIO_ACTIVE_HIGH>;
+
+                               flash: m25p80@0 {
+                                       compatible = "s25fl512s";
+                                       #address-cells = <1>;
+                                       #size-cells = <1>;
+                                       spi-max-frequency = <51200000>;
+                                       reg = <0>;
+
+                                       linux,part-probe = "qcom-smem";
+                               };
+                       };
+               };
+
+               phy@100f8800 {          /* USB3 port 1 HS phy */
+                       status = "ok";
+               };
+
+               phy@100f8830 {          /* USB3 port 1 SS phy */
+                       status = "ok";
+               };
+
+               phy@110f8800 {          /* USB3 port 0 HS phy */
+                       status = "ok";
+               };
+
+               phy@110f8830 {          /* USB3 port 0 SS phy */
+                       status = "ok";
+               };
+
+               usb30@0 {
+                       status = "ok";
+               };
+
+               usb30@1 {
+                       status = "ok";
+               };
+
+               pcie0: pci@1b500000 {
+                       status = "ok";
+                       reset-gpio = <&qcom_pinmux 3 GPIO_ACTIVE_LOW>;
+                       pinctrl-0 = <&pcie0_pins>;
+                       pinctrl-names = "default";
+               };
+
+               pcie1: pci@1b700000 {
+                       status = "ok";
+                       reset-gpio = <&qcom_pinmux 48 GPIO_ACTIVE_LOW>;
+                       pinctrl-0 = <&pcie1_pins>;
+                       pinctrl-names = "default";
+               };
+
+               mdio0: mdio {
+                       compatible = "virtual,mdio-gpio";
+                       #address-cells = <1>;
+                       #size-cells = <0>;
+                       gpios = <&qcom_pinmux 1 0 &qcom_pinmux 0 0>;
+
+                       phy0: ethernet-phy@0 {
+                               device_type = "ethernet-phy";
+                               reg = <0>;
+                               qca,ar8327-initvals = <
+                                       0x00004 0x7600000   /* PAD0_MODE */
+                                       0x00008 0x1000000   /* PAD5_MODE */
+                                       0x0000c 0x80        /* PAD6_MODE */
+                                       0x000e4 0xaa545     /* MAC_POWER_SEL */
+                                       0x000e0 0xc74164de  /* SGMII_CTRL */
+                                       0x0007c 0x4e        /* PORT0_STATUS */
+                                       0x00094 0x4e        /* PORT6_STATUS */
+                                       0x00970 0x1e864443  /* QM_PORT0_CTRL0 */
+                                       0x00974 0x000001c6  /* QM_PORT0_CTRL1 */
+                                       0x00978 0x19008643  /* QM_PORT1_CTRL0 */
+                                       0x0097c 0x000001c6  /* QM_PORT1_CTRL1 */
+                                       0x00980 0x19008643  /* QM_PORT2_CTRL0 */
+                                       0x00984 0x000001c6  /* QM_PORT2_CTRL1 */
+                                       0x00988 0x19008643  /* QM_PORT3_CTRL0 */
+                                       0x0098c 0x000001c6  /* QM_PORT3_CTRL1 */
+                                       0x00990 0x19008643  /* QM_PORT4_CTRL0 */
+                                       0x00994 0x000001c6  /* QM_PORT4_CTRL1 */
+                                       0x00998 0x1e864443  /* QM_PORT5_CTRL0 */
+                                       0x0099c 0x000001c6  /* QM_PORT5_CTRL1 */
+                                       0x009a0 0x1e864443  /* QM_PORT6_CTRL0 */
+                                       0x009a4 0x000001c6  /* QM_PORT6_CTRL1 */
+                                       >;
+                       };
+
+                       phy4: ethernet-phy@4 {
+                               device_type = "ethernet-phy";
+                               reg = <4>;
+                               qca,ar8327-initvals = <
+                                       0x000e4 0x6a545     /* MAC_POWER_SEL */
+                                       0x0000c 0x80        /* PAD6_MODE */
+                                       >;
+                       };
+               };
+
+               gmac1: ethernet@37200000 {
+                       status = "ok";
+                       phy-mode = "rgmii";
+                       qcom,id = <1>;
+                       qcom,phy_mdio_addr = <4>;
+                       qcom,poll_required = <0>;
+                       qcom,rgmii_delay = <1>;
+                       qcom,phy_mii_type = <0>;
+                       qcom,emulation = <0>;
+                       qcom,irq = <255>;
+                       mdiobus = <&mdio0>;
+
+                       fixed-link {
+                               speed = <1000>;
+                               full-duplex;
+                       };
+               };
+
+               gmac2: ethernet@37400000 {
+                       status = "ok";
+                       phy-mode = "sgmii";
+                       qcom,id = <2>;
+                       qcom,phy_mdio_addr = <0>;       /* none */
+                       qcom,poll_required = <0>;       /* no polling */
+                       qcom,rgmii_delay = <0>;
+                       qcom,phy_mii_type = <1>;
+                       qcom,emulation = <0>;
+                       qcom,irq = <258>;
+                       mdiobus = <&mdio0>;
+
+                       fixed-link {
+                               speed = <1000>;
+                               full-duplex;
+                       };
+               };
+
+               rpm@108000 {
+                       pinctrl-0 = <&i2c4_pins>;
+                       pinctrl-names = "default";
+               };
+
+               amba {
+                       sdcc1: sdcc@12400000 {
+                               status          = "okay";
+                                dmas = <&sdcc1bam 2>, <&sdcc1bam 1>;
+                                dma-names = "tx", "rx";
+                       };
+               };
+
+
+
+       };
+
+       gpio-keys {
+               compatible = "gpio-keys";
+               wifi {
+                       label = "wifi";
+                       gpios = <&qcom_pinmux 6 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RFKILL>;
+               };
+
+               reset {
+                       label = "reset";
+                       gpios = <&qcom_pinmux 54 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RESTART>;
+               };
+
+               wps {
+                       label = "wps";
+                       gpios = <&qcom_pinmux 65 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_WPS_BUTTON>;
+               };
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+               internet {
+                       label = "nbg6817:white:internet";
+                       gpios = <&qcom_pinmux 64 GPIO_ACTIVE_HIGH>;
+               };
+
+               power {
+                       label = "nbg6817:white:power";
+                       gpios = <&qcom_pinmux 9 GPIO_ACTIVE_HIGH>;
+                       default-state = "on";
+               };
+
+               wifi {
+                       label = "nbg6817:amber:wifi";
+                       gpios = <&qcom_pinmux 33 GPIO_ACTIVE_HIGH>;
+               };
+
+               wifi5g {
+                       label = "nbg6817:amber:wifi5g";
+                       gpios = <&qcom_pinmux 26 GPIO_ACTIVE_HIGH>;
+               };
+       };
+
+       gpio_export {
+               compatible = "gpio-export";
+               #size-cells = <0>;
+
+               usb0_status {
+                       gpio-export,name = "usb0";
+                       gpio-export,output = <1>;
+                       gpios = <&qcom_pinmux 15 GPIO_ACTIVE_HIGH>;
+               };
+
+               usb1_status {
+                       gpio-export,name = "usb1";
+                       gpio-export,output = <1>;
+                       gpios = <&qcom_pinmux 16 GPIO_ACTIVE_HIGH>;
+               };
+               usb1_power {
+                       gpio-export,name = "usb1_power";
+                       gpio-export,output = <1>;
+                       gpios = <&qcom_pinmux 14 GPIO_ACTIVE_HIGH>;
+               };
+               usb2_power {
+                       gpio-export,name = "usb2_power";
+                       gpio-export,output = <1>;
+                       gpios = <&qcom_pinmux 17 GPIO_ACTIVE_HIGH>;
+               };
+       };
+};
+
+&adm_dma {
+       status = "ok";
+};
index b74f1a77c252e37d6e4c35d6fed468e6e0486dd7..3bee923f9390519044bb36d8cc6e0363e38379a8 100644 (file)
@@ -90,6 +90,19 @@ define Device/TpSafeImage
 endef
 DEVICE_VARS += TPLINK_BOARD_NAME
 
+define Device/ZyXELImage
+       PROFILES += $$(DEVICE_NAME)
+       FILESYSTEMS := squashfs
+       KERNEL_SUFFIX := -uImage
+       KERNEL = kernel-bin | append-dtb | uImage none | pad-to $$$${KERNEL_SIZE}
+       KERNEL_NAME := zImage
+       IMAGES := sysupgrade.tar mmcblk0p5-rootfs.bin mmcblk0p4-kernel.bin
+       IMAGE/sysupgrade.tar/squashfs := append-rootfs | pad-to $$$${BLOCKSIZE} | sysupgrade-tar rootfs=$$$$@
+       IMAGE/sysupgrade.tar := sysupgrade-tar
+       IMAGE/mmcblk0p5-rootfs.bin := append-rootfs | pad-rootfs | pad-to $$$${BLOCKSIZE}
+       IMAGE/mmcblk0p4-kernel.bin := append-kernel
+endef
+
 define Device/AP148
        $(call Device/FitImage)
        $(call Device/UbiFit)
@@ -202,6 +215,16 @@ define Device/R7800
        DEVICE_PACKAGES := ath10k-firmware-qca9984
 endef
 
-TARGET_DEVICES += AP148 AP148-legacy C2600 D7800 DB149 EA8500 R7500 R7500v2 R7800
+define Device/NBG6817
+       DEVICE_DTS := qcom-ipq8065-nbg6817
+       KERNEL_SIZE := 4096k
+       BLOCKSIZE := 64k
+       BOARD_NAME := nbg6817
+       DEVICE_TITLE := ZyXEL NBG6817
+       DEVICE_PACKAGES := ath10k-firmware-qca9984 e2fsprogs losetup
+       $(call Device/ZyXELImage)
+endef
+
+TARGET_DEVICES += AP148 AP148-legacy C2600 D7800 DB149 EA8500 R7500 R7500v2 R7800 NBG6817
 
 $(eval $(call BuildImage))
index 85f253429b0a480c61e5c7745408964e37b48e7c..916e2efd728f4b6f9634a516b54b640e81483c5b 100644 (file)
@@ -12,7 +12,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
 
 --- a/arch/arm/boot/dts/Makefile
 +++ b/arch/arm/boot/dts/Makefile
-@@ -506,7 +506,13 @@ dtb-$(CONFIG_ARCH_QCOM) += \
+@@ -506,7 +506,14 @@ dtb-$(CONFIG_ARCH_QCOM) += \
        qcom-apq8084-ifc6540.dtb \
        qcom-apq8084-mtp.dtb \
        qcom-ipq8064-ap148.dtb \
@@ -22,6 +22,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
 +      qcom-ipq8064-ea8500.dtb \
 +      qcom-ipq8064-r7500.dtb \
 +      qcom-ipq8064-r7500v2.dtb \
++      qcom-ipq8065-nbg6817.dtb \
 +      qcom-ipq8065-r7800.dtb \
        qcom-msm8660-surf.dtb \
        qcom-msm8960-cdp.dtb \