kernel: update kernel 4.3 to version 4.3.4
authorHauke Mehrtens <hauke@hauke-m.de>
Mon, 25 Jan 2016 21:44:48 +0000 (21:44 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Mon, 25 Jan 2016 21:44:48 +0000 (21:44 +0000)
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
SVN-Revision: 48498

include/kernel-version.mk
target/linux/generic/patches-4.3/010-KEYS-Fix-keyring-ref-leak-in-join_session_keyring.patch [deleted file]
target/linux/generic/patches-4.3/650-pppoe_header_pad.patch
target/linux/generic/patches-4.3/700-swconfig.patch
target/linux/generic/patches-4.3/901-debloat_sock_diag.patch
target/linux/generic/patches-4.3/902-debloat_proc.patch
target/linux/ramips/patches-4.3/0033-USB-add-xhci-hooks.patch

index 4d5bb02f994c5a5fac3dde6dc99051ad347bc36a..af1af70cd91f17052bbd7800dcc9349ba30108b7 100644 (file)
@@ -4,12 +4,12 @@ LINUX_RELEASE?=1
 
 LINUX_VERSION-3.18 = .26
 LINUX_VERSION-4.1 = .16
-LINUX_VERSION-4.3 = .3
+LINUX_VERSION-4.3 = .4
 LINUX_VERSION-4.4 =
 
 LINUX_KERNEL_MD5SUM-3.18.26 = fb3ef8da32a25607807887b9567a6927
 LINUX_KERNEL_MD5SUM-4.1.16 = e4bf22fed49b476b47acffc00c03267a
-LINUX_KERNEL_MD5SUM-4.3.3 = f3068333fa524ff98914cf751d0b5710
+LINUX_KERNEL_MD5SUM-4.3.4 = 5275d02132107c28b85f986bad576d91
 LINUX_KERNEL_MD5SUM-4.4 = 9a78fa2eb6c68ca5a40ed5af08142599
 
 ifdef KERNEL_PATCHVER
diff --git a/target/linux/generic/patches-4.3/010-KEYS-Fix-keyring-ref-leak-in-join_session_keyring.patch b/target/linux/generic/patches-4.3/010-KEYS-Fix-keyring-ref-leak-in-join_session_keyring.patch
deleted file mode 100644 (file)
index 9c6a969..0000000
+++ /dev/null
@@ -1,75 +0,0 @@
-From 7ca88764d45c209791e8813131c1457c2e9e51e7 Mon Sep 17 00:00:00 2001
-From: Yevgeny Pats <yevgeny@perception-point.io>
-Date: Mon, 11 Jan 2016 12:05:28 +0000
-Subject: KEYS: Fix keyring ref leak in join_session_keyring()
-
-If a thread is asked to join as a session keyring the keyring that's already
-set as its session, we leak a keyring reference.
-
-This can be tested with the following program:
-
-       #include <stddef.h>
-       #include <stdio.h>
-       #include <sys/types.h>
-       #include <keyutils.h>
-
-       int main(int argc, const char *argv[])
-       {
-               int i = 0;
-               key_serial_t serial;
-
-               serial = keyctl(KEYCTL_JOIN_SESSION_KEYRING,
-                               "leaked-keyring");
-               if (serial < 0) {
-                       perror("keyctl");
-                       return -1;
-               }
-
-               if (keyctl(KEYCTL_SETPERM, serial,
-                          KEY_POS_ALL | KEY_USR_ALL) < 0) {
-                       perror("keyctl");
-                       return -1;
-               }
-
-               for (i = 0; i < 100; i++) {
-                       serial = keyctl(KEYCTL_JOIN_SESSION_KEYRING,
-                                       "leaked-keyring");
-                       if (serial < 0) {
-                               perror("keyctl");
-                               return -1;
-                       }
-               }
-
-               return 0;
-       }
-
-If, after the program has run, there something like the following line in
-/proc/keys:
-
-3f3d898f I--Q---   100 perm 3f3f0000     0     0 keyring   leaked-keyring: empty
-
-with a usage count of 100 * the number of times the program has been run,
-then the kernel is malfunctioning.  If leaked-keyring has zero usages or
-has been garbage collected, then the problem is fixed.
-
-Reported-by: Yevgeny Pats <yevgeny@perception-point.io>
-Signed-off-by: David Howells <dhowells@redhat.com>
----
- security/keys/process_keys.c | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/security/keys/process_keys.c b/security/keys/process_keys.c
-index a3f85d2..e6d50172 100644
---- a/security/keys/process_keys.c
-+++ b/security/keys/process_keys.c
-@@ -794,6 +794,7 @@ long join_session_keyring(const char *name)
-               ret = PTR_ERR(keyring);
-               goto error2;
-       } else if (keyring == new->session_keyring) {
-+              key_put(keyring);
-               ret = 0;
-               goto error2;
-       }
--- 
-2.7.0.rc3
-
index 28044699524d2b584c581fd2410bc7e35a1121a6..adba206c089f1d40c1797232e8b8e25be3c21f48 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/ppp/pppoe.c
 +++ b/drivers/net/ppp/pppoe.c
-@@ -871,7 +871,7 @@ static int pppoe_sendmsg(struct socket *
+@@ -877,7 +877,7 @@ static int pppoe_sendmsg(struct socket *
                goto end;
  
  
@@ -9,7 +9,7 @@
                           0, GFP_KERNEL);
        if (!skb) {
                error = -ENOMEM;
-@@ -879,7 +879,7 @@ static int pppoe_sendmsg(struct socket *
+@@ -885,7 +885,7 @@ static int pppoe_sendmsg(struct socket *
        }
  
        /* Reserve space for headers. */
index 2b4c20e5ec83d36ef027ad1368ee82ed53331d89..d5eba0b3297d09162409b0a28a323c6b63265a94 100644 (file)
@@ -29,7 +29,7 @@
  obj-$(CONFIG_DAVICOM_PHY)     += davicom.o
 --- a/include/uapi/linux/Kbuild
 +++ b/include/uapi/linux/Kbuild
-@@ -385,6 +385,7 @@ header-y += stddef.h
+@@ -386,6 +386,7 @@ header-y += stddef.h
  header-y += string.h
  header-y += suspend_ioctls.h
  header-y += swab.h
index bf03c395a7b945dd1feac45c649c729e7f60ed0d..0a2c9a69b6deeba2acddb8d631f9ac749efce5ee 100644 (file)
@@ -25,7 +25,7 @@
  obj-$(CONFIG_PROC_FS) += net-procfs.o
 --- a/net/core/sock.c
 +++ b/net/core/sock.c
-@@ -1454,9 +1454,11 @@ void sk_destruct(struct sock *sk)
+@@ -1453,9 +1453,11 @@ void sk_destruct(struct sock *sk)
  
  static void __sk_free(struct sock *sk)
  {
index 5d74f43d24f95956a4568442c4020c495f98582c..cf59d71c0b9227901cb8a043157f5374d494c406 100644 (file)
                goto err;
 --- a/net/core/sock.c
 +++ b/net/core/sock.c
-@@ -2969,6 +2969,8 @@ static __net_initdata struct pernet_oper
+@@ -2968,6 +2968,8 @@ static __net_initdata struct pernet_oper
  
  static int __init proto_init(void)
  {
index db2929358414e0726bef6a0602404646d5bb8883..d0acad3ef656d89292f2e63ea73484a88ab09a91 100644 (file)
@@ -59,7 +59,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
                /* EHCI, OHCI */
 --- a/drivers/usb/core/hub.c
 +++ b/drivers/usb/core/hub.c
-@@ -1287,7 +1287,7 @@ static void hub_quiesce(struct usb_hub *
+@@ -1291,7 +1291,7 @@ static void hub_quiesce(struct usb_hub *
        if (type != HUB_SUSPEND) {
                /* Disconnect all the children */
                for (i = 0; i < hdev->maxchild; ++i) {