Add HOST_FPIC. It currently always is -fPIC, because that should work on all platform...
authorMichael Büsch <mb@bu3sch.de>
Sat, 23 Oct 2010 20:30:43 +0000 (20:30 +0000)
committerMichael Büsch <mb@bu3sch.de>
Sat, 23 Oct 2010 20:30:43 +0000 (20:30 +0000)
SVN-Revision: 23598

rules.mk

index 7d3516bc4272e1186dde2ceb89145cde7c5ad19d..23445bfaeed6d7a2642a1cd55becec9895fa5d0e 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -47,6 +47,8 @@ else
   FPIC:=-fpic
 endif
 
   FPIC:=-fpic
 endif
 
+HOST_FPIC:=-fPIC
+
 ARCH_SUFFIX:=
 ifneq ($(findstring -mips32r2,$(TARGET_OPTIMIZATION)),)
   ARCH_SUFFIX:=_r2
 ARCH_SUFFIX:=
 ifneq ($(findstring -mips32r2,$(TARGET_OPTIMIZATION)),)
   ARCH_SUFFIX:=_r2