ar71xx: use uimage split for WZR-HP-G450H
authorFelix Fietkau <nbd@openwrt.org>
Sun, 14 Jul 2013 14:05:19 +0000 (14:05 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 14 Jul 2013 14:05:19 +0000 (14:05 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 37292

target/linux/ar71xx/files/arch/mips/ath79/mach-wzr-hp-g450h.c
target/linux/ar71xx/image/Makefile

index 2c28a55f557c3bdd86f73c0b6dde0df61f8cd944..03b63c9eece041539d00ed60ea6557c2f451575d 100644 (file)
@@ -43,21 +43,13 @@ static struct mtd_partition wzrhpg450h_partitions[] = {
                .size           = 0x0010000,
                .mask_flags     = MTD_WRITEABLE,
        }, {
-               .name           = "uImage",
+               .name           = "firmware",
                .offset         = 0x0060000,
-               .size           = 0x0100000,
-       }, {
-               .name           = "rootfs",
-               .offset         = 0x0160000,
-               .size           = 0x1e80000,
+               .size           = 0x1f80000,
        }, {
                .name           = "user_property",
                .offset         = 0x1fe0000,
                .size           = 0x0020000,
-       }, {
-               .name           = "firmware",
-               .offset         = 0x0060000,
-               .size           = 0x1f80000,
        }
 };
 
index 7b83b6424a556cf97feeb5cd6006b9e936265b95..b50f333d4c88b0eedc92e228f546629759fadc4d 100644 (file)
@@ -270,6 +270,28 @@ define Image/Build/DLRTDEV
        fi
 endef
 
+define Image/Build/WZRHP64K
+       $(call MkuImageLzma,$(2),$(3))
+       $(call Sysupgrade/KRuImage,$(1),$(2),65536,31850496)
+       if [ -e "$(call sysupname,$(1),$(2))" ]; then \
+               ( \
+                       echo -n -e "# Airstation Public Fmt1\x00\x00\x00\x00\x00\x00\x00\x00"; \
+                       dd if=$(call sysupname,$(1),$(2)); \
+               ) > $(call imgname,$(1),$(2))-tftp.bin; \
+               buffalo-enc -p $(4) -v 1.99 \
+                       -i $(call sysupname,$(1),$(2)) \
+                       -o $(KDIR_TMP)/$(2).enc; \
+               buffalo-tag -b $(4) -p $(4) -a ath -v 1.99 -m 1.01 -l mlang8 \
+                       -w 3 -c 0x80041000 -d 0x801e8000 -f 1 -r M_ \
+                       -i $(KDIR_TMP)/$(2).enc \
+                       -o $(call factoryname,$(1),$(2)); \
+       fi
+endef
+
+define Image/Build/WZRHP64K/initramfs
+       $(call MkuImageLzma/initramfs,$(2),$(3) $(4))
+endef
+
 define Image/Build/WZRHPG30XNH
        $(call MkuImageLzma,$(2),$(3))
        $(call Sysupgrade/KRuImage,$(1),$(2),1048576,31850496)
@@ -994,7 +1016,7 @@ $(eval $(call SingleProfile,WRT400N,$(fs_64k),WRT400N,wrt400n,WRT400N,ttyS0,1152
 $(eval $(call SingleProfile,WZRHPG30XNH,$(fs_128k),WZRHPG300NH,wzr-hp-g300nh,WZR-HP-G300NH,ttyS0,115200,WZR-HP-G300NH))
 $(eval $(call SingleProfile,WZRHPG30XNH,$(fs_64k),WZRHPG300NH2,wzr-hp-g300nh2,WZR-HP-G300NH2,ttyS0,115200,WZR-HP-G300NH2))
 $(eval $(call SingleProfile,WZRHPG30XNH,$(fs_64k),WZRHPAG300H,wzr-hp-ag300h,WZR-HP-AG300H,ttyS0,115200,WZR-HP-AG300H))
-$(eval $(call SingleProfile,WZRHPG30XNH,$(fs_64k),WZRHPG450H,wzr-hp-g450h,WZR-HP-G450H,ttyS0,115200,WZR-HP-AG450H))
+$(eval $(call SingleProfile,WZRHP64K,$(fs_64k),WZRHPG450H,wzr-hp-g450h,WZR-HP-G450H,ttyS0,115200,WZR-HP-AG450H))
 $(eval $(call SingleProfile,WZRHPG30XNH,$(fs_64k),WZR600DHP,wzr-600dhp,WZR-HP-AG300H,ttyS0,115200,WZR-600DHP))
 
 $(eval $(call SingleProfile,Zcomax,$(fs_64k),ZCN1523H28,zcn-1523h-2-8,ZCN-1523H-2,ttyS0,115200,$$(zcn1523h_mtdlayout)))