build: fix subtarget descriptions
authorFelix Fietkau <nbd@nbd.name>
Sun, 4 Sep 2016 11:34:18 +0000 (13:34 +0200)
committerFelix Fietkau <nbd@nbd.name>
Sun, 4 Sep 2016 11:35:11 +0000 (13:35 +0200)
Move Target/Description above the target.mk include

Signed-off-by: Felix Fietkau <nbd@nbd.name>
21 files changed:
target/linux/adm8668/Makefile
target/linux/apm821xx/Makefile
target/linux/ar7/Makefile
target/linux/arc770/Makefile
target/linux/archs38/Makefile
target/linux/arm64/Makefile
target/linux/ath25/Makefile
target/linux/au1000/Makefile
target/linux/bcm53xx/Makefile
target/linux/brcm2708/Makefile
target/linux/brcm47xx/Makefile
target/linux/brcm63xx/Makefile
target/linux/cns3xxx/Makefile
target/linux/mpc85xx/Makefile
target/linux/octeon/Makefile
target/linux/omap/Makefile
target/linux/ppc40x/Makefile
target/linux/ppc44x/Makefile
target/linux/ramips/Makefile
target/linux/realview/Makefile
target/linux/xburst/Makefile

index 96958389992a7ecfb8fcd7f1d674295a36b16f0d..ddca8d4a275d94e0fd7ac92ed307e0ca2e6a8cb6 100644 (file)
@@ -14,11 +14,11 @@ MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 KERNEL_PATCHVER:=3.18
 
-include $(INCLUDE_DIR)/target.mk
-
 define Target/Description
        Build firmware images for Infineon WildPass (ADM8668) based routers
        (e.g. T-Mobile branded Linksys WRTU54G-TM)
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
 $(eval $(call BuildTarget))
index bd89c6b332432598efde27721f9d1e13688d70ab..026466d86de55ba1be20acf012b5a2a0b92119ba 100644 (file)
@@ -15,6 +15,10 @@ SUBTARGETS:=nand sata
 
 KERNEL_PATCHVER:=4.4
 
+define Target/Description
+       Build images for AppliedMicro APM821xx based boards.
+endef
+
 include $(INCLUDE_DIR)/target.mk
 
 KERNELNAME:=uImage
@@ -22,8 +26,4 @@ KERNELNAME:=uImage
 DEFAULT_PACKAGES += \
        kmod-leds-gpio kmod-i2c-core kmod-gpio-button-hotplug
 
-define Target/Description
-       Build images for AppliedMicro APM821xx based boards.
-endef
-
 $(eval $(call BuildTarget))
index 1832e7b5e077d7dfb6eb598b56f9fa985d219af7..c5a6035b53fc5e7c8b09a2e856e87c0579c71a28 100644 (file)
@@ -15,12 +15,12 @@ SUBTARGETS:=generic ac49x
 
 KERNEL_PATCHVER:=3.18
 
-include $(INCLUDE_DIR)/target.mk
-
-DEFAULT_PACKAGES+= swconfig
-
 define Target/Description
        Build firmware images for TI AR7 based routers.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES+= swconfig
+
 $(eval $(call BuildTarget))
index f917338aa489ec05eda33e5a169c1e4e2e9ca63a..6492529503046967cec08e45c10fe1b197b976b3 100644 (file)
@@ -16,10 +16,10 @@ KERNEL_PATCHVER:=4.4
 
 DEVICE_TYPE:=developerboard
 
-include $(INCLUDE_DIR)/target.mk
-
 define Target/Description
        Synopsys DesignWare boards
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
 $(eval $(call BuildTarget))
index 166d3d554073c54ef2ae63fa603134c3c1f919aa..be0d7228931088332e2265073d030a85d2297bf3 100644 (file)
@@ -17,10 +17,10 @@ KERNEL_PATCHVER:=4.4
 
 DEVICE_TYPE:=developerboard
 
-include $(INCLUDE_DIR)/target.mk
-
 define Target/Description
        Synopsys DesignWare boards
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
 $(eval $(call BuildTarget))
index f0d23d0ebea2e0dc98ababc60b8480fb3b7b9264..6bf89a7194d174e48373ceeddd6074bdf3284978 100644 (file)
@@ -17,12 +17,12 @@ KERNEL_PATCHVER:=4.4
 
 DEVICE_TYPE:=developerboard
 
-include $(INCLUDE_DIR)/target.mk
-
 define Target/Description
        Build multi-platform images for the ARMv8 instruction set architecture
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
 KERNELNAME:=Image dtbs
 
 $(eval $(call BuildTarget))
index c09220db6441e85538e2554676b3dcecf68b47cc..86db43fd66f7a1b42b6906ee276e83cd72ac9b80 100644 (file)
@@ -14,12 +14,12 @@ MAINTAINER:=Sergey Ryazanov <ryazanov.s.a@gmail.com>
 
 KERNEL_PATCHVER:=4.4
 
-include $(INCLUDE_DIR)/target.mk
-
-DEFAULT_PACKAGES += wpad-mini kmod-ath5k swconfig kmod-gpio-button-hotplug
-
 define Target/Description
        Build firmware images for Atheros SoC boards
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += wpad-mini kmod-ath5k swconfig kmod-gpio-button-hotplug
+
 $(eval $(call BuildTarget))
index 7438e9b6df1c671482f9ea48f294617c1aa42430..0e019a9d67c09bed5f2e4a5134927eb54215b591 100644 (file)
@@ -15,14 +15,14 @@ MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 KERNEL_PATCHVER:=3.18
 
-include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += wpad-mini yamonenv
-
 define Target/Description
        Build firmware for RMI/AMD Alchemy 1500,1550 boards
        (e.g. 4G-Systems Mesh/Access Cube, DBAu1550 ...)
 endef
 
+include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += wpad-mini yamonenv
+
 define Kernel/BuildImage
        $(call Kernel/BuildImage/Default)
        $(CP) $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.flash.srec $(LINUX_DIR)/zImage.flash.srec
index 717a44203ad5d494d62cd9ebbe3d30b166bc7567..917e55b5e33c0478e4bc0e981770e2435c96cec3 100644 (file)
@@ -15,12 +15,12 @@ CPU_TYPE:=cortex-a9
 
 KERNEL_PATCHVER:=4.4
 
-include $(INCLUDE_DIR)/target.mk
-
 define Target/Description
        Build firmware images for Broadcom based BCM47xx/53xx routers with ARM CPU, *not* MIPS.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
 KERNELNAME:=zImage dtbs
 
 DEFAULT_PACKAGES += swconfig wpad-mini nvram oseama otrx \
index 9d0d921738c81475a5785842ff081f82bf3f305e..9240f664210d183b1e21abe4044e7250dbf31259 100644 (file)
@@ -16,14 +16,14 @@ SUBTARGETS:=bcm2708 bcm2709 bcm2710
 
 KERNEL_PATCHVER:=4.4
 
-include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += brcm2708-gpu-fw kmod-usb-hid kmod-sound-core kmod-sound-arm-bcm2835 kmod-fs-vfat kmod-nls-cp437 kmod-nls-iso8859-1
-
 define Target/Description
        Build firmware image for Broadcom BCM27xx SoC devices.
        Currently produces SD Card image for Raspberry Pi.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += brcm2708-gpu-fw kmod-usb-hid kmod-sound-core kmod-sound-arm-bcm2835 kmod-fs-vfat kmod-nls-cp437 kmod-nls-iso8859-1
+
 KERNELNAME:=Image dtbs
 
 $(eval $(call BuildTarget))
index e0c44c8596fc0e41f73d0ce3ac40028e5278f7f7..cb6d39fa2237a7e10ad355f2a91249b4813dd3c3 100644 (file)
@@ -15,13 +15,12 @@ MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
 
 KERNEL_PATCHVER:=4.1
 
-include $(INCLUDE_DIR)/target.mk
-
-
 define Target/Description
        Build firmware images for Broadcom based BCM47xx/53xx routers with MIPS CPU, *not* ARM.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
 DEFAULT_PACKAGES += swconfig wpad-mini nvram otrx \
        kmod-leds-gpio kmod-gpio-button-hotplug \
        kmod-ledtrig-default-on kmod-ledtrig-timer kmod-ledtrig-netdev
index 0dba065d0d4c3b0f1faf1344c67e3521283db25e..84e9a8d44e35ef19d6f283e864e8b8031d081c3d 100644 (file)
@@ -15,14 +15,14 @@ FEATURES:=squashfs usb atm pci pcmcia usbgadget
 KERNEL_PATCHVER:=4.4
 MAINTAINER:=Jonas Gorski <jogo@openwrt.org>
 
-include $(INCLUDE_DIR)/target.mk
-
-DEFAULT_PACKAGES += swconfig kmod-gpio-button-hotplug
-
 define Target/Description
        Build firmware images for Broadcom based xDSL/routers
        currently supports BCM6338, BCM6348 and BCM6358 based devices.
        (e.g. Inventel Livebox, Siemens SE515, Neufbox 4)
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += swconfig kmod-gpio-button-hotplug
+
 $(eval $(call BuildTarget))
index 52425821eccde4dae59c2506d0792ed42363d519..c8d62519ce6b097e92ef73c6dcc16832bb87b2b1 100644 (file)
@@ -16,13 +16,13 @@ MAINTAINER:=Felix Fietkau <nbd@nbd.name>
 
 KERNEL_PATCHVER:=4.4
 
-include $(INCLUDE_DIR)/target.mk
-
 define Target/Description
        Build images for Cavium Networks Econa CNS3xxx based boards,
        eg. the Gateworks Laguna family
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
 KERNELNAME:=zImage
 
 DEFAULT_PACKAGES += kmod-ath9k kmod-usb2 wpad-mini
index efd48d7d41cc3d93fd60dde2cf6c7bd0e2996d46..7f986452c557c26873dfe4e9a3249c87875517ca 100644 (file)
@@ -16,6 +16,10 @@ SUBTARGETS=generic p1020
 
 KERNEL_PATCHVER:=4.4
 
+define Target/Description
+       Build images for the Freescale MPC85xx based boards.
+endef
+
 include $(INCLUDE_DIR)/target.mk
 
 KERNEL_IMAGES := zImage
@@ -27,8 +31,4 @@ DEFAULT_PACKAGES += \
        kmod-input-core kmod-input-gpio-keys kmod-button-hotplug \
        kmod-leds-gpio swconfig kmod-ath9k wpad-mini
 
-define Target/Description
-       Build images for the Freescale MPC85xx based boards.
-endef
-
 $(eval $(call BuildTarget))
index 5cddd2de854469c1d52c18e944abe54869097ad4..afef2ba67e7714d98167a2533808ca4af61fd2f2 100644 (file)
@@ -15,11 +15,10 @@ MAINTAINER:=John Crispin <john@phrozen.org>
 
 KERNEL_PATCHVER:=4.4
 
-include $(INCLUDE_DIR)/target.mk
-
-
 define Target/Description
        Build firmware images for Cavium Networks Octeon-based boards.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
 $(eval $(call BuildTarget))
index bc861f1117009bc8372634f805e89cf98474ba28..91b9d9b20a2c4c1018465e83bbb47eb3ed69185b 100644 (file)
@@ -19,12 +19,12 @@ MAINTAINER:=Alexander Couzens <lynxis@fe80.eu>
 
 KERNELNAME:=zImage dtbs
 
-include $(INCLUDE_DIR)/target.mk
-
-DEFAULT_PACKAGES += uboot-omap-am335x_evm uboot-omap-omap3_beagle uboot-omap-omap3_overo uboot-omap-omap4_panda
-
 define Target/Description
        TI OMAP boards
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += uboot-omap-am335x_evm uboot-omap-omap3_beagle uboot-omap-omap3_overo uboot-omap-omap4_panda
+
 $(eval $(call BuildTarget))
index fc85b03c2940bdf5e81ae6c859da1e3c33073ef5..3529bb3db501e4eed0db5a4b4a40647324e389e9 100644 (file)
@@ -15,12 +15,12 @@ MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
 KERNEL_PATCHVER:=3.18
 
-include $(INCLUDE_DIR)/target.mk
-
 define Target/Description
        Build firmware images for AMCC/IBM PPC40x based boards.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
 KERNELNAME:=uImage cuImage.magicbox cuImage.openrb
 
 $(eval $(call BuildTarget))
index 17a3f5893ae145467206ea636ffff46b6de761ea..5187cb3e23acd78c128952babb41b8d4c36ad2a3 100644 (file)
@@ -15,12 +15,12 @@ MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
 KERNEL_PATCHVER:=3.18
 
-include $(INCLUDE_DIR)/target.mk
-
 define Target/Description
        Build firmware images for AMCC/IBM PPC44x based boards.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
 KERNELNAME:=uImage cuImage.taishan
 
 $(eval $(call BuildTarget))
index b4ccaf64e1d27355907ac697e4b77e6a68ba922a..51cd8f3e06c706a2772af9fe9c75cb0d22c4f21b 100644 (file)
@@ -15,12 +15,12 @@ MAINTAINER:=John Crispin <john@phrozen.org>
 
 KERNEL_PATCHVER:=4.4
 
-include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += \
-       kmod-leds-gpio kmod-gpio-button-hotplug wpad-mini swconfig
-
 define Target/Description
        Build firmware images for Ralink RT288x/RT3xxx based boards.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += \
+       kmod-leds-gpio kmod-gpio-button-hotplug wpad-mini swconfig
+
 $(eval $(call BuildTarget))
index c4f7a72e390f5c78d85c887d7adc9b8c6ed8f229..5bff0969d53ec21fe1a42c04f3de1d6e06064b1c 100644 (file)
@@ -18,12 +18,12 @@ KERNEL_PATCHVER:=4.4
 
 DEVICE_TYPE:=developerboard
 
-include $(INCLUDE_DIR)/target.mk
-
 define Target/Description
        Build images for ARM Ltd. Realview boards to be run with qemu
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
 KERNELNAME:=zImage
 
 $(eval $(call BuildTarget))
index 258a743643b8e15a458fd84ec59b2ceb2471cc69..df499b6d533355116903021e032e360a194cd3d4 100644 (file)
@@ -16,10 +16,10 @@ KERNEL_PATCHVER:=3.18
 
 DEVICE_TYPE=other
 
-include $(INCLUDE_DIR)/target.mk
-
 define Target/Description
        Build firmware images for XBurst JZ47x0 based boards.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
 $(eval $(call BuildTarget))