ramips: fix Netgear R6220 package selection
authorMathias Kresin <dev@kresin.me>
Sun, 9 Apr 2017 07:58:51 +0000 (09:58 +0200)
committerMathias Kresin <dev@kresin.me>
Thu, 13 Apr 2017 06:18:57 +0000 (08:18 +0200)
The Netgear R6220 requires the kmod-usb3 package and misses
kmod-usb-ledtrig-usbport package to setup the configured usb led
trigger.

Drop the already target selected kmod-mt76.

Fixes: FS#686

Fixes: 38bee61dab02 ("ramips: add support for Netgear R6220")
Signed-off-by: Mathias Kresin <dev@kresin.me>
target/linux/ramips/image/mt7621.mk

index a90cf17..8e4ac40 100644 (file)
@@ -131,7 +131,7 @@ define Device/r6220
   IMAGE/kernel.bin := append-kernel
   IMAGE/rootfs.bin := append-ubi | check-size $$$$(IMAGE_SIZE)
   DEVICE_TITLE := Netgear R6220
-  DEVICE_PACKAGES := kmod-usb2 kmod-mt76
+  DEVICE_PACKAGES := kmod-usb3 kmod-usb-ledtrig-usbport
 endef
 TARGET_DEVICES += r6220