add a menuconfig option for enabling KALLSYMS for the kernel
authorFelix Fietkau <nbd@openwrt.org>
Tue, 20 Jan 2009 21:09:04 +0000 (21:09 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 20 Jan 2009 21:09:04 +0000 (21:09 +0000)
SVN-Revision: 14122

Config.in
include/kernel-defaults.mk

index a5b3364612c5bb85f220e7fa9bec0f4b19d0dbca..0f131f062395f9f1c6355940987530cd614fd2b4 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -117,6 +117,14 @@ config NO_STRIP
        bool "Install unstripped binary on the target (useful for native compiling/debugging)"
        default n
 
+comment "Kernel build options"
+
+config KERNEL_KALLSYMS
+       bool "Compile the kernel with symbol table information"
+       default n
+       help
+               This will give you more information in stack traces from kernel oopses
+
 endmenu
 
 menuconfig DEVEL
index 36f9174c9158a877b2af87f7733cdf5496e46782..4aa5c0ef18232305df8c7412e37dccbf08e9cea2 100644 (file)
@@ -86,6 +86,9 @@ define Kernel/Configure/2.6
 endef
 define Kernel/Configure/Default
        $(LINUX_CONFCMD) > $(LINUX_DIR)/.config.target
+       echo "$(if $(CONFIG_KERNEL_KALLSYMS),CONFIG_KALLSYMS=y,# CONFIG_KALLSYMS is not set)" >> $(LINUX_DIR)/.config.target
+       echo "# CONFIG_KALLSYMS_EXTRA_PASS is not set" >> $(LINUX_DIR)/.config.target
+       echo "# CONFIG_KPROBES is not set" >> $(LINUX_DIR)/.config.target
        $(SCRIPT_DIR)/metadata.pl kconfig $(TMP_DIR)/.packageinfo $(TOPDIR)/.config > $(LINUX_DIR)/.config.override
        $(SCRIPT_DIR)/kconfig.pl 'm+' $(LINUX_DIR)/.config.target $(LINUX_DIR)/.config.override > $(LINUX_DIR)/.config
        $(call Kernel/SetInitramfs)