ramips: rt305x: pass MTD partition map to the ALL0256N via cmdline
authorGabor Juhos <juhosg@openwrt.org>
Sun, 12 Feb 2012 18:04:46 +0000 (18:04 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Sun, 12 Feb 2012 18:04:46 +0000 (18:04 +0000)
SVN-Revision: 30482

target/linux/ramips/image/Makefile

index 76f14ca41ba02295f743ea5dcc05665b90d6402d..0a1436ddfda8b0209d8be98418728a7d1da0be9e 100644 (file)
@@ -223,8 +223,9 @@ define Image/Build/Profile/BC2
        $(call Image/Build/Template/GENERIC_8M,$(1),bc2,BC2)
 endef
 
+mtdlayout_all0256n=mtdparts=spi0.0:192k(u-boot)ro,64k(u-boot-env)ro,64k(factory)ro,832k(kernel),2944k(rootfs),3776k@0x50000(firmware)
 define Image/Build/Profile/ALL0256N
-       $(call Image/Build/Template/GENERIC_4M,$(1),all0256n,ALL0256N)
+       $(call BuildFirmware/Generic,$(1),all0256n,board=ALL0256N,mtdlayout_all0256n,851968,3014656)
 endef
 
 define Image/Build/Profile/NBG419N