gcc: remove the bogus CONFIG_TLS_SUPPORT symbol - TLS support is required by libc.
authorFelix Fietkau <nbd@openwrt.org>
Sun, 7 Apr 2013 10:11:41 +0000 (10:11 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 7 Apr 2013 10:11:41 +0000 (10:11 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 36240

toolchain/gcc/Config.in
toolchain/gcc/final/Makefile

index 585017586acae4a6f01bb85a1b65a161417bff05..811c6d47c24f629fe38b6487dfcd4c96f52d1259 100644 (file)
@@ -52,13 +52,6 @@ config SSP_SUPPORT
        help
            Enable Stack-Smashing Protection support
 
-config TLS_SUPPORT
-       bool
-       prompt "Enable Thread-local storage (TLS) support" if TOOLCHAINOPTS
-       default n
-       help
-           Enable Thread-local storage support
-
 config SJLJ_EXCEPTIONS
        bool
        prompt "Use setjump()/longjump() exceptions" if TOOLCHAINOPTS
index e8c32f629dc77af1eeaae99df135cd54ca407905..2c25263db17b9ad419d16baf1441d0d27823fe87 100644 (file)
@@ -15,14 +15,6 @@ ifneq ($(CONFIG_GCC_VERSION_4_5)$(CONFIG_GCC_VERSION_4_6),)
        --with-libelf=$(TOPDIR)/staging_dir/host
 endif
 
-ifneq ($(CONFIG_TLS_SUPPORT),)
-  GCC_CONFIGURE += \
-       --enable-tls
-else
-  GCC_CONFIGURE += \
-       --disable-tls
-endif
-
 ifneq ($(CONFIG_SJLJ_EXCEPTIONS),)
   GCC_CONFIGURE += \
        --enable-sjlj-exceptions