kirkwood: put uboot-envtools in DEFAULT_PACKAGES
authorLuka Perkov <luka@openwrt.org>
Fri, 17 Apr 2015 13:47:09 +0000 (13:47 +0000)
committerLuka Perkov <luka@openwrt.org>
Fri, 17 Apr 2015 13:47:09 +0000 (13:47 +0000)
Signed-off-by: Luka Perkov <luka@openwrt.org>
SVN-Revision: 45477

target/linux/kirkwood/Makefile
target/linux/kirkwood/profiles/110-nas.mk
target/linux/kirkwood/profiles/115-router.mk
target/linux/kirkwood/profiles/120-plug.mk

index 3f40d912ef08b24000d259ece11cc576df0340cf..2fe1c845d9cac3f3009673a859194558c2b990e7 100644 (file)
@@ -19,4 +19,6 @@ include $(INCLUDE_DIR)/target.mk
 
 KERNELNAME:=zImage dtbs
 
+DEFAULT_PACKAGES += uboot-envtools
+
 $(eval $(call BuildTarget))
index 66a4f6c9c4c9c87dcf28102a41f8f3c3ae289333..d87c45c2bfd044f9158383c7db3bc21ac7f868df 100644 (file)
@@ -8,8 +8,7 @@
 define Profile/DOCKSTAR
   NAME:=Seagate FreeAgent Dockstar
   PACKAGES:= \
-       kmod-rtc-marvell kmod-usb2 kmod-usb-storage \
-       uboot-envtools
+       kmod-rtc-marvell kmod-usb2 kmod-usb-storage
 endef
 
 define Profile/DOCKSTAR/Description
@@ -25,8 +24,7 @@ define Profile/GOFLEXNET
   NAME:=Seagate GoFlexNet
   PACKAGES:= \
        kmod-ata-core kmod-ata-marvell-sata \
-       kmod-usb2 kmod-usb-storage \
-       uboot-envtools
+       kmod-usb2 kmod-usb-storage
 endef
 
 define Profile/GOFLEXNET/Description
@@ -42,8 +40,7 @@ define Profile/IB62X0
   NAME:=RaidSonic ICY BOX IB-NAS62x0
   PACKAGES:= \
        kmod-ata-core kmod-ata-marvell-sata \
-       kmod-rtc-marvell kmod-usb2 kmod-usb-storage \
-       uboot-envtools
+       kmod-rtc-marvell kmod-usb2 kmod-usb-storage
 endef
 
 define Profile/IB62X0/Description
@@ -74,8 +71,7 @@ define Profile/IOMEGA_IX2_200
   NAME:=Iomega StorCenter ix2-200
   PACKAGES:= \
        kmod-ata-core kmod-ata-marvell-sata \
-       kmod-usb2 kmod-usb-storage \
-       uboot-envtools
+       kmod-usb2 kmod-usb-storage
 endef
 
 define Profile/IOMEGA_IX2_200/Description
@@ -90,7 +86,7 @@ $(eval $(call Profile,IOMEGA_IX2_200))
 define Profile/POGOE02
   NAME:=Cloud Engines Pogoplug E02
   PACKAGES:= \
-       kmod-usb2 kmod-usb-storage uboot-envtools
+       kmod-usb2 kmod-usb-storage
 endef
 
 define Profile/POGOE02/Description
index 769284f7ea35a41ae6c7e9bfee293a57185842e0..526934d97b3ac9d7cfe573b9ddefbec21195716c 100644 (file)
@@ -9,7 +9,7 @@ define Profile/EA3500
   NAME:=Linksys EA3500
   PACKAGES:= \
        kmod-mwl8k kmod-usb2 kmod-usb-storage \
-       swconfig uboot-envtools
+       swconfig
 endef
 
 define Profile/EA3500/Description
@@ -25,7 +25,7 @@ define Profile/EA4500
   NAME:=Linksys EA4500
   PACKAGES:= \
        kmod-mwl8k kmod-usb2 kmod-usb-storage \
-       swconfig uboot-envtools
+       swconfig
 endef
 
 define Profile/EA4500/Description
index 96ce7fc5d5e6eaed9d64a7782c6abdc65131d39c..3f92f89b23ff01073fbd9525797afe68e4961788 100644 (file)
@@ -10,7 +10,7 @@ define Profile/SHEEVAPLUG
   PACKAGES:= \
        kmod-mmc kmod-mvsdio kmod-usb2 kmod-usb-storage \
        kmod-i2c-core kmod-i2c-mv64xxx \
-       kmod-ata-core uboot-envtools
+       kmod-ata-core
 endef
 
 define Profile/SHEEVAPLUG/Description
@@ -27,8 +27,7 @@ define Profile/SHEEVAPLUGSATA
   PACKAGES:= \
        kmod-mmc kmod-mvsdio kmod-usb2 kmod-usb-storage \
        kmod-i2c-core kmod-i2c-mv64xxx \
-       kmod-ata-core kmod-ata-marvell-sata \
-       uboot-envtools
+       kmod-ata-core kmod-ata-marvell-sata
 endef
 
 define Profile/SHEEVAPLUGSATA/Description
@@ -47,7 +46,7 @@ define Profile/GuruplugServerPlus
        kmod-i2c-core kmod-i2c-mv64xxx \
        kmod-ata-core kmod-ata-marvell-sata \
        kmod-btmrvl kmod-btmrvl-sdio kmod-libertas kmod-libertas-sdio \
-       uboot-envtools wpad-mini
+       wpad-mini
 endef
 
 define Profile/GuruplugServerPlus/Description
@@ -64,8 +63,7 @@ define Profile/Topkick1281P2
   PACKAGES:= \
        kmod-mmc kmod-mvsdio kmod-usb2 kmod-usb-storage \
        kmod-i2c-core kmod-i2c-mv64xxx \
-       kmod-ata-core kmod-ata-marvell-sata \
-       uboot-envtools
+       kmod-ata-core kmod-ata-marvell-sata
 endef
 
 define Profile/Topkick1281P2/Description