ipq806x: make the dwc3 driver and required phy drivers built-in
authorJohn Crispin <john@phrozen.org>
Wed, 22 Mar 2017 08:36:00 +0000 (09:36 +0100)
committerJohn Crispin <john@phrozen.org>
Wed, 22 Mar 2017 08:45:18 +0000 (09:45 +0100)
Signed-off-by: John Crispin <john@phrozen.org>
target/linux/ipq806x/config-4.9
target/linux/ipq806x/modules.mk [deleted file]

index 072ab6a897781156e7344fef573629dd9c4ae024..cf16ff43839b57be2d4ff0865dd8a17660c1ae99 100644 (file)
@@ -371,6 +371,7 @@ CONFIG_PERF_USE_VMALLOC=y
 CONFIG_PGTABLE_LEVELS=2
 CONFIG_PHYLIB=y
 # CONFIG_PHY_QCOM_APQ8064_SATA is not set
+CONFIG_PHY_QCOM_DWC3=y
 CONFIG_PHY_QCOM_IPQ806X_SATA=y
 # CONFIG_PHY_QCOM_UFS is not set
 CONFIG_PINCTRL=y
@@ -482,8 +483,12 @@ CONFIG_UEVENT_HELPER_PATH=""
 CONFIG_UNCOMPRESS_INCLUDE="debug/uncompress.h"
 CONFIG_USB=y
 CONFIG_USB_COMMON=y
+CONFIG_USB_DWC3=y
+CONFIG_USB_DWC3_HOST=y
+CONFIG_USB_DWC3_OF_SIMPLE=y
 # CONFIG_USB_EHCI_HCD is not set
-# CONFIG_USB_IPQ4019_PHY is not set
+CONFIG_USB_IPQ4019_PHY=y
+CONFIG_USB_PHY=y
 CONFIG_USB_SUPPORT=y
 # CONFIG_USB_UHCI_HCD is not set
 CONFIG_USE_OF=y
diff --git a/target/linux/ipq806x/modules.mk b/target/linux/ipq806x/modules.mk
deleted file mode 100644 (file)
index 6f1ca2d..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
-define KernelPackage/usb-dwc3-of-simple
-  TITLE:=DWC3 USB simple OF driver
-  DEPENDS:=+kmod-usb-dwc3
-  KCONFIG:= CONFIG_USB_DWC3_OF_SIMPLE
-  FILES:= $(LINUX_DIR)/drivers/usb/dwc3/dwc3-of-simple.ko
-  AUTOLOAD:=$(call AutoLoad,53,dwc3-of-simple,1)
-  $(call AddDepends/usb)
-endef
-
-define KernelPackage/usb-dwc3-of-simple/description
- This driver provides generic platform glue for the integrated DesignWare
- USB3 IP Core.
-endef
-
-$(eval $(call KernelPackage,usb-dwc3-of-simple))
-
-define KernelPackage/usb-phy-qcom-dwc3
-  TITLE:=DWC3 USB QCOM PHY driver
-  DEPENDS:=@TARGET_ipq806x +kmod-usb-dwc3-of-simple
-  KCONFIG:= CONFIG_PHY_QCOM_DWC3
-  FILES:= $(LINUX_DIR)/drivers/phy/phy-qcom-dwc3.ko
-  AUTOLOAD:=$(call AutoLoad,45,phy-qcom-dwc3,1)
-  $(call AddDepends/usb)
-endef
-
-define KernelPackage/usb-phy-qcom-dwc3/description
- This driver provides support for the integrated DesignWare
- USB3 IP Core within the QCOM SoCs.
-endef
-
-$(eval $(call KernelPackage,usb-phy-qcom-dwc3))