ar71xx: fix board name ordering
authorJohn Crispin <john@openwrt.org>
Wed, 8 Jul 2015 14:26:18 +0000 (14:26 +0000)
committerJohn Crispin <john@openwrt.org>
Wed, 8 Jul 2015 14:26:18 +0000 (14:26 +0000)
r46248 added case statements in the same places

Signed-off-by: John Crispin <blogic@openwrt.org>
SVN-Revision: 46274

target/linux/ar71xx/base-files/etc/uci-defaults/02_network
target/linux/ar71xx/base-files/lib/preinit/05_set_iface_mac_ar71xx
target/linux/ar71xx/image/Makefile

index 51095a9a5e16ee61cf1894977d4fdeb366a7344f..ec709a002c2a1dcdd2aec1a56e657fed43b28c89 100755 (executable)
@@ -213,9 +213,9 @@ tl-wr941nd)
        ucidef_set_interfaces_lan_wan "lan1 lan2 lan3 lan4" "wan"
        ;;
 
+dir-615-i1 |\
 r6100 |\
 smart-300 |\
-dir-615-i1 |\
 tl-mr3420-v2 |\
 tl-wr841n-v8 |\
 tl-wr842n-v2 |\
index c39169aa5d26d2ab2f1fed14e62438f9b023aabf..92b3765bb206f77fac6c482b4da9a26f3e37bb20 100644 (file)
@@ -22,9 +22,6 @@ fetch_mac_from_mtd() {
 
 preinit_set_mac_address() {
        case $(ar71xx_board_name) in
-               tew-632brp)
-                       fetch_mac_from_mtd config lan_mac wan_mac
-                       ;;
                dir-615-c1)
                        fetch_mac_from_mtd config lan_mac wan_mac
                        echo 1 > /sys/class/leds/dir-615-c1:green:wancpu/brightness
@@ -38,6 +35,9 @@ preinit_set_mac_address() {
                        mac_wan=$(mtd_get_mac_binary caldata 6)
                        [ -n "$mac_wan" ] && ifconfig eth0 hw ether "$mac_wan"
                        ;;
+               tew-632brp)
+                       fetch_mac_from_mtd config lan_mac wan_mac
+                       ;;
                wrt160nl)
                        fetch_mac_from_mtd nvram lan_hwaddr wan_hwaddr
                        ;;
index e43d95dd4a17c9dbbeceb83fd2c6480769916e8c..03513109ca6ab4f6300bf251cf6e30f264b9a44d 100644 (file)
@@ -2158,9 +2158,9 @@ $(eval $(call SingleProfile,Zcomax,64k,ZCN1523H516,zcn-1523h-5-16,ZCN-1523H-5,tt
 $(eval $(call SingleProfile,ZyXEL,64k,NBG_460N_550N_550NH,nbg460n_550n_550nh,NBG460N,ttyS0,115200,NBG-460N))
 
 $(eval $(call MultiProfile,AP121,AP121_2M AP121_4M))
-$(eval $(call MultiProfile,DIR615IX,DIR615I1 DIR615I3))
 $(eval $(call MultiProfile,AP136,AP136_010 AP136_020))
 $(eval $(call MultiProfile,AP143,AP143_8M AP143_16M))
+$(eval $(call MultiProfile,DIR615IX,DIR615I1 DIR615I3))
 $(eval $(call MultiProfile,EWDORIN, EWDORINAP EWDORINRT EWDORIN16M))
 $(eval $(call MultiProfile,OPENMESH,OM2P OM5P MR600 MR900))
 $(eval $(call MultiProfile,TEW652BRP,TEW652BRP_FW TEW652BRP_RECOVERY))