ar71xx: fix DEFAULT_PACKAGES for mikrotik devices
authorFelix Fietkau <nbd@nbd.name>
Tue, 14 Feb 2017 12:14:38 +0000 (13:14 +0100)
committerFelix Fietkau <nbd@nbd.name>
Tue, 14 Feb 2017 12:15:44 +0000 (13:15 +0100)
Include packages from the default profile for NAND devices

Signed-off-by: Felix Fietkau <nbd@nbd.name>
target/linux/ar71xx/image/mikrotik.mk

index a2b682f5f6411684e43aedc3d726fc10b13c11b0..939544d764003d2a657225f58f8636f81d95257a 100644 (file)
@@ -1,5 +1,6 @@
 define Device/mikrotik
   PROFILES := Default
+  DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport nand-utils
   BOARD_NAME := routerboard
   KERNEL_INITRAMFS :=
   KERNEL_NAME := loader-generic.elf
@@ -25,6 +26,7 @@ TARGET_DEVICES += nand-64m nand-large
 
 define Device/rb-nor-flash-16M
   DEVICE_TITLE := MikroTik RouterBoard with 16 MB NOR flash
+  DEVICE_PACKAGES := rbcfg
   BLOCKSIZE := 64k
   IMAGE_SIZE := 16000k
   LOADER_TYPE := elf
@@ -38,7 +40,6 @@ endef
 define Device/rb-941-2nd
 $(Device/rb-nor-flash-16M)
   DEVICE_TITLE := hAP lite
-  DEVICE_PACKAGES:= rbcfg
   BOARDNAME:= rb-941-2nd
 endef