kernel: update linux 3.8 to 3.8.10
authorGabor Juhos <juhosg@openwrt.org>
Tue, 30 Apr 2013 10:43:59 +0000 (10:43 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Tue, 30 Apr 2013 10:43:59 +0000 (10:43 +0000)
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 36493

28 files changed:
include/kernel-version.mk
target/linux/adm5120/Makefile
target/linux/ar71xx/Makefile
target/linux/ar71xx/patches-3.8/617-MIPS-ath79-add-Netgear-WNR2000v3-support.patch
target/linux/at91/Makefile
target/linux/atheros/Makefile
target/linux/avr32/Makefile
target/linux/brcm63xx/Makefile
target/linux/cns21xx/Makefile
target/linux/cns3xxx/Makefile
target/linux/ep93xx/Makefile
target/linux/lantiq/Makefile
target/linux/lantiq/patches-3.8/0041-owrt-mtd-split.patch
target/linux/malta/Makefile
target/linux/mpc52xx/Makefile
target/linux/mpc83xx/Makefile
target/linux/mpc85xx/Makefile
target/linux/mvebu/Makefile
target/linux/ppc40x/Makefile
target/linux/ppc44x/Makefile
target/linux/ramips/Makefile
target/linux/ramips/patches-3.8/0208-owrt-mtd-split.patch
target/linux/rb532/Makefile
target/linux/realview/Makefile
target/linux/uml/Makefile
target/linux/x86/alix2/target.mk
target/linux/x86/generic/target.mk
target/linux/xburst/Makefile

index 9bcbd0b5545fc94e61a124a82551cf56f93d16b3..b9a6776ae7d196fe0d2973ab4ff78b56515243a9 100644 (file)
@@ -11,8 +11,8 @@ endif
 ifeq ($(LINUX_VERSION),3.7.10)
   LINUX_KERNEL_MD5SUM:=09624c3702107076efcac5e1cd8a18ec
 endif
-ifeq ($(LINUX_VERSION),3.8.9)
-  LINUX_KERNEL_MD5SUM:=b5286ad3d8a729e9ae48b26211e05aec
+ifeq ($(LINUX_VERSION),3.8.10)
+  LINUX_KERNEL_MD5SUM:=3d5fb6d9add9cce7725bbe9b139c8d6e
 endif
 
 # disable the md5sum check for unknown kernel versions
index ac337195e2fd3a5bc1be6ad4855308d58646112f..3b50ba037539a1d349ca45aa97afe302a51ef7b1 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 BOARD:=adm5120
 BOARDNAME:=Infineon/ADMtek ADM5120
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
 SUBTARGETS:=router_le router_be rb1xx
 INITRAMFS_EXTRA_FILES:=
 
index 7e2471537124b1feb7ff27dfa6ac95d93968f0e1..baaccdaa821b822b05139d089c04ffa7a49305ec 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 targz
 CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
 SUBTARGETS:=generic nand
 
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
 
 include $(INCLUDE_DIR)/target.mk
 
index 0b9c1efa9d45f20bbb54dc16418cc65fb3ef2667..aa3edf0bd47fef4b7a29f16a1a59c75b04967d8e 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ath79/machtypes.h
 +++ b/arch/mips/ath79/machtypes.h
-@@ -119,6 +119,7 @@ enum ath79_mach_type {
+@@ -120,6 +120,7 @@ enum ath79_mach_type {
        ATH79_MACH_WNDR3700,            /* NETGEAR WNDR3700/WNDR3800/WNDRMAC */
        ATH79_MACH_WNDR4300,            /* NETGEAR WNDR4300 */
        ATH79_MACH_WNR2000,             /* NETGEAR WNR2000 */
@@ -28,7 +28,7 @@
        select SOC_AR724X
 --- a/arch/mips/ath79/Makefile
 +++ b/arch/mips/ath79/Makefile
-@@ -100,6 +100,7 @@ obj-$(CONFIG_ATH79_MACH_WLAE_AG300N)       += 
+@@ -101,6 +101,7 @@ obj-$(CONFIG_ATH79_MACH_WLAE_AG300N)       +=
  obj-$(CONFIG_ATH79_MACH_WNDR3700)     += mach-wndr3700.o
  obj-$(CONFIG_ATH79_MACH_WNDR4300)     += mach-wndr4300.o
  obj-$(CONFIG_ATH79_MACH_WNR2000)      += mach-wnr2000.o
index ea72b67e1bccd0cc9eeef2e5755c43ad9f903b2b..38e2b0324371d32c1272dec07d348517f82a59a2 100644 (file)
@@ -13,7 +13,7 @@ BOARDNAME:=Atmel AT91
 FEATURES:=squashfs jffs2 targz ext2 usb
 CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -fno-caller-saves
 
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
 
 include $(INCLUDE_DIR)/target.mk
 
index 4caff66d83ce0b9f3d68c8be445e997eabe40599..f0c1345dcab054351c6af532de76b19e25e2261a 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=atheros
 BOARDNAME:=Atheros AR231x/AR5312
 FEATURES:=squashfs jffs2
 
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
 
 include $(INCLUDE_DIR)/target.mk
 
index b4d2b04ed073525fd737e6f8f875296385e80fdd..38948ce6aad4e846f92561b185fa4723f61e1c04 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Atmel AVR32
 FEATURES:=squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
 
 include $(INCLUDE_DIR)/target.mk
 
index 52e4524f92a63941bfbef968c2a4d39b4f7cd4f5..09410b5cef7b0ef27955a72f2d7f0f888af1d301 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=mips
 BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM63xx
 FEATURES:=squashfs jffs2 usb atm pci pcmcia
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 include $(INCLUDE_DIR)/target.mk
index a5a90ff222383abbfbcfa206288440ed2cbb749a..a33c61da85f22d3c0c0640116e841ebfbcaee488 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Cavium Networks Econa CNS21xx
 FEATURES:=squashfs
 CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526 -fno-caller-saves
 
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
 
 include $(INCLUDE_DIR)/target.mk
 
index 87f6c440d1a03c17d5f9a15b84d5ed33fa5162ee..15422237f0d7d5c511581bf3b318e7c5ffe3913c 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs fpu gpio pcie usb usbgadget
 CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -fno-caller-saves
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
 
 include $(INCLUDE_DIR)/target.mk
 
index 72577204e768fdcbfbf7723bbe95c7953090e024..0b36548a965c2668ce9cd3fefe78a17977b481ba 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 ext4 targz usb display sound
 CFLAGS:=-Os -pipe -march=armv4t -fno-caller-saves
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
 
 DEVICE_TYPE:=developerboard
 
index 88f12b12c22cdb219a191825d13113b81f33b348..bcd0ff79fa6a34bf298a3d7c5220aa413c103ae5 100644 (file)
@@ -11,7 +11,7 @@ BOARDNAME:=Lantiq GPON/XWAY/SVIP
 FEATURES:=squashfs jffs2
 SUBTARGETS=xway ase falcon
 
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
 
 CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
 
index ee5fa734672e2be30ccb4a27163ee7ff8d3c9ef0..16da43818374f88fb9d31622676324ad398d833e 100644 (file)
@@ -25,7 +25,7 @@ Subject: [PATCH 19/25] owrt mtd split
        ---help---
 --- a/drivers/mtd/mtdpart.c
 +++ b/drivers/mtd/mtdpart.c
-@@ -844,6 +844,168 @@ static int refresh_rootfs_split(struct m
+@@ -833,6 +833,168 @@ static int refresh_rootfs_split(struct m
  }
  #endif /* CONFIG_MTD_ROOTFS_SPLIT */
  
@@ -194,7 +194,7 @@ Subject: [PATCH 19/25] owrt mtd split
  /*
   * This function, given a master MTD object and a partition table, creates
   * and registers slave MTD objects which are bound to the master according to
-@@ -860,7 +1022,7 @@ int add_mtd_partitions(struct mtd_info *
+@@ -849,7 +1011,7 @@ int add_mtd_partitions(struct mtd_info *
        struct mtd_part *slave;
        uint64_t cur_offset = 0;
        int i;
@@ -203,7 +203,7 @@ Subject: [PATCH 19/25] owrt mtd split
        int ret;
  #endif
  
-@@ -877,6 +1039,15 @@ int add_mtd_partitions(struct mtd_info *
+@@ -866,6 +1028,15 @@ int add_mtd_partitions(struct mtd_info *
  
                add_mtd_device(&slave->mtd);
  
index 8db4e90306afcf5fc5f6dcd3ee96510b9a35181e..5e4d2c132d3447fa51d4d2d4621ea1f7fe84f39f 100644 (file)
@@ -12,7 +12,7 @@ SUBTARGETS:=le be le64 be64
 INITRAMFS_EXTRA_FILES:=
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
 
 DEVICE_TYPE:=developerboard
 
index 7493441c5609088c98444c9db9427b3405b5ef87..94fe5f79252d108c1227cefc9831fc1b177e4c4f 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Freescale MPC52xx
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=603e
 FEATURES:=targz ext4
 
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
 
 include $(INCLUDE_DIR)/target.mk
 
index bb6f6986ee417a19fb480dfa58f260e3dac64e88..7b5a7ac5d4b89d4a85906c4c8a0bee915ffc1555 100644 (file)
@@ -13,7 +13,7 @@ CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=603e
 FEATURES:=squashfs targz
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
 
 include $(INCLUDE_DIR)/target.mk
 
index 88d9b9543e4d0d33ad0541972944972c73af3f8a..3129d188f0c3dc4b82ba444a24121ad26b082e66 100644 (file)
@@ -14,7 +14,7 @@ FEATURES:=spe_fpu squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 SUBTARGETS=generic p1020
 
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
 
 include $(INCLUDE_DIR)/target.mk
 
index fcb604af95fa00d52504038b4d93a8e70e070a28..b6f917f40197f3cea7fa17d1dec0c1461db3c2a0 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=targz usb jffs2 pci pcie gpio
 CFLAGS:=-Os -pipe -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=softfp
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
 
 include $(INCLUDE_DIR)/target.mk
 
index ab79d7ce232608ae216d34e8ccd0d91844015db7..adc01938b7c4c2ec1e54c59c32a472cef2e3b3d8 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=405
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
 
 include $(INCLUDE_DIR)/target.mk
 
index 0a5533c6013fcbc89f7aaddaa93f8fcb4a530036..fceccdf093cf04230faf440977a8334697119229 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs broken
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
 
 include $(INCLUDE_DIR)/target.mk
 
index 1b359ad06b043b32a91175876d24f730f09db07c..f4a42127656c1c84e9cc98cb8777de8a73d1acf4 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS:=rt288x rt305x rt3883
 CFLAGS:=-Os -pipe -fno-caller-saves -mno-branch-likely
 FEATURES:=squashfs gpio
 
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES+=\
index 8f6899c4cc335b3d62d6671753b62f1f8139928f..f15d16f6da5ffe6e57cb88c018a081bb021380da 100644 (file)
@@ -25,7 +25,7 @@ Subject: [PATCH 19/25] owrt mtd split
        ---help---
 --- a/drivers/mtd/mtdpart.c
 +++ b/drivers/mtd/mtdpart.c
-@@ -844,6 +844,99 @@ static int refresh_rootfs_split(struct m
+@@ -833,6 +833,99 @@ static int refresh_rootfs_split(struct m
  }
  #endif /* CONFIG_MTD_ROOTFS_SPLIT */
  
@@ -125,7 +125,7 @@ Subject: [PATCH 19/25] owrt mtd split
  /*
   * This function, given a master MTD object and a partition table, creates
   * and registers slave MTD objects which are bound to the master according to
-@@ -860,7 +953,7 @@ int add_mtd_partitions(struct mtd_info *
+@@ -849,7 +942,7 @@ int add_mtd_partitions(struct mtd_info *
        struct mtd_part *slave;
        uint64_t cur_offset = 0;
        int i;
@@ -134,7 +134,7 @@ Subject: [PATCH 19/25] owrt mtd split
        int ret;
  #endif
  
-@@ -877,6 +970,14 @@ int add_mtd_partitions(struct mtd_info *
+@@ -866,6 +959,14 @@ int add_mtd_partitions(struct mtd_info *
  
                add_mtd_device(&slave->mtd);
  
index 56b2d20e5324fcc6218d07bcd7a6f89864393b82..52441810e5232587a490fcb26dc2c10afb20a64d 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=rb532
 BOARDNAME:=Mikrotik RouterBoard 532
 FEATURES:=jffs2 pci targz broken
 
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini kmod-madwifi kmod-input-rb532
index cc6d9776770d62aedff1b7c5501d00402d1d6c23..ce5571f07ecf6c1adf3181dc074a9aabb986e7f0 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=fpu ramdisk
 CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -fno-caller-saves
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
 
 DEVICE_TYPE:=developerboard
 
index 3be431a62ff6152737724e98a6dd0e5137b4869d..c9066544244d34d6a8ab465aa86a8415dfccfb86 100644 (file)
@@ -23,7 +23,7 @@ BOARDNAME:=User Mode Linux
 FEATURES:=ext4 audio
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
 
 include $(INCLUDE_DIR)/target.mk
 
index 534ffa3463135266e2e7536ffae414ea6d305163..ff4c29d6ef6b285da0a0b7780f2feca37e4ba869 100644 (file)
@@ -19,7 +19,7 @@ DEFAULT_PACKAGES += \
                        kmod-ledtrig-heartbeat kmod-ledtrig-gpio \
                        kmod-ledtrig-netdev \
                        kmod-cpu-msr hwclock wpad
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
 CS5535_MASK:=0x0b000042
 
 CFLAGS += -march=geode -Os -mmmx -m3dnow -fno-align-jumps -fno-align-functions \
index 4e5f373b1ce8116dedda5e406255e7016d19d6d3..765d7085090c418d7d95c3e9fc6d59a403931738 100644 (file)
@@ -1,6 +1,6 @@
 BOARDNAME:=Generic
 
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
 
 define Target/Description
        Build firmware images for x86 based boards
index 074f0545edc583e1103ed0ba80654aa8790cd787..f90c8ecf60eb35182481d93070bfe75646f7c8c6 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Ingenic XBurst
 FEATURES:=jffs2 targz ubifs audio broken
 SUBTARGETS:=qi_lb60 n516 n526 id800wt
 
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
 
 DEVICE_TYPE=other