kernel: sctp depends on ipv6 if ipv6 is enabled
authorFelix Fietkau <nbd@openwrt.org>
Thu, 18 Jul 2013 16:46:11 +0000 (16:46 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 18 Jul 2013 16:46:11 +0000 (16:46 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 37406

package/kernel/linux/modules/netsupport.mk

index 0edfe5f0e0ca9fdefdec6a0d1695cdd3e09e48a9..07ce47992cbd50eca9bcd9ed8a14e50ee4196c1d 100644 (file)
@@ -865,6 +865,7 @@ $(eval $(call KernelPackage,l2tp-ip))
 define KernelPackage/sctp
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   TITLE:=SCTP protocol kernel support
+  DEPENDS:=+IPV6:kmod-ipv6
   KCONFIG:=\
      CONFIG_IP_SCTP \
      CONFIG_SCTP_DBG_MSG=n \