automatically generate network config
authorImre Kaloz <kaloz@openwrt.org>
Sun, 29 Jun 2014 12:50:12 +0000 (12:50 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Sun, 29 Jun 2014 12:50:12 +0000 (12:50 +0000)
Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
SVN-Revision: 41381

target/linux/mvebu/base-files.mk [new file with mode: 0644]
target/linux/mvebu/base-files/etc/uci-defaults/02_network [new file with mode: 0644]

diff --git a/target/linux/mvebu/base-files.mk b/target/linux/mvebu/base-files.mk
new file mode 100644 (file)
index 0000000..fdd2c71
--- /dev/null
@@ -0,0 +1,3 @@
+define Package/base-files/install-target
+       rm -f $(1)/etc/config/network
+endef
diff --git a/target/linux/mvebu/base-files/etc/uci-defaults/02_network b/target/linux/mvebu/base-files/etc/uci-defaults/02_network
new file mode 100644 (file)
index 0000000..8b1ed6a
--- /dev/null
@@ -0,0 +1,29 @@
+#!/bin/sh
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+
+[ -e /etc/config/network ] && exit 0
+
+touch /etc/config/network
+
+. /lib/functions/uci-defaults.sh
+. /lib/mvebu.sh
+
+ucidef_set_interface_loopback
+
+board=$(mvebu_board_name)
+
+case "$board" in
+armada-xp-mamba)
+       ucidef_set_interfaces_lan_wan "eth0" "eth1"
+       ;;
+
+*)
+       ucidef_set_interface_lan "eth0"
+       ;;
+esac
+
+uci commit network
+
+exit 0