specify the adapter type for the vmdk conversion
authorImre Kaloz <kaloz@openwrt.org>
Thu, 10 Apr 2014 11:09:27 +0000 (11:09 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Thu, 10 Apr 2014 11:09:27 +0000 (11:09 +0000)
Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
SVN-Revision: 40442

target/linux/x86_64/image/Makefile

index fad6d2d383306d3b07146e9400df9a4e32c45f28..d77a5bc2c11c101a5da70b736ba1931b007f033a 100644 (file)
@@ -145,7 +145,7 @@ ifneq ($(CONFIG_VMDK_IMAGES),)
     # left here because the image builder doesnt need these
     ifeq ($(1),ext4)
                rm $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vmdk || true
-               qemu-img convert -f raw -O vmdk \
+               qemu-img convert -f raw -O vmdk -o adapter_type=lsilogic \
                        $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img \
                        $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).vmdk
     endif