ar71xx: create profile and build image for the OpenMesh MR1750 board
authorJohn Crispin <john@openwrt.org>
Mon, 14 Sep 2015 20:11:51 +0000 (20:11 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 14 Sep 2015 20:11:51 +0000 (20:11 +0000)
Signed-off-by: Sven Eckelmann <sven@open-mesh.com>
SVN-Revision: 46932

target/linux/ar71xx/generic/profiles/openmesh.mk
target/linux/ar71xx/image/Makefile

index 41b462e86b738669b85da663f7896f4565e15fce..1c51e93a92ec2ee09bd08bca4237218eb6665a60 100644 (file)
@@ -49,9 +49,20 @@ endef
 
 $(eval $(call Profile,MR900))
 
+define Profile/MR1750
+        NAME:=OpenMesh MR1750
+        PACKAGES:=kmod-ath9k kmod-ath10k
+endef
+
+define Profile/MR1750/Description
+        Package set optimized for the OpenMesh MR1750.
+endef
+
+$(eval $(call Profile,MR1750))
+
 define Profile/OPENMESH
        NAME:=OpenMesh products
-       PACKAGES:=kmod-ath9k om-watchdog
+       PACKAGES:=kmod-ath9k kmod-ath10k om-watchdog
 endef
 
 define Profile/OPENMESH/Description
index 7d39674212e47f59fdd9507ab7d12283dfb58252..60ede75929255df1b0d54f758781caad1978478b 100644 (file)
@@ -2159,6 +2159,7 @@ $(eval $(call SingleProfile,OpenMesh,squashfs-only,OM2P,om2p,,,,OM2P))
 $(eval $(call SingleProfile,OpenMesh,squashfs-only,OM5P,om5p,,,,OM5P))
 $(eval $(call SingleProfile,OpenMesh,squashfs-only,MR600,mr600,,,,MR600))
 $(eval $(call SingleProfile,OpenMesh,squashfs-only,MR900,mr900,,,,MR900))
+$(eval $(call SingleProfile,OpenMesh,squashfs-only,MR1750,mr1750,,,,MR1750))
 
 $(eval $(call SingleProfile,PB4X,128k,ALL0305,all0305,ALL0305,ttyS0,115200))
 $(eval $(call SingleProfile,PB4X,128k,EAP7660D,eap7660d,EAP7660D,ttyS0,115200))
@@ -2234,7 +2235,7 @@ $(eval $(call MultiProfile,AP143,AP143_8M AP143_16M))
 $(eval $(call MultiProfile,AP147,AP147_010))
 $(eval $(call MultiProfile,DIR615IX,DIR615I1 DIR615I3))
 $(eval $(call MultiProfile,EWDORIN, EWDORINAP EWDORINRT EWDORIN16M))
-$(eval $(call MultiProfile,OPENMESH,OM2P OM5P MR600 MR900))
+$(eval $(call MultiProfile,OPENMESH,OM2P OM5P MR600 MR900 MR1750))
 $(eval $(call MultiProfile,TEW652BRP,TEW652BRP_FW TEW652BRP_RECOVERY))
 $(eval $(call MultiProfile,TLMR3220,TLMR3220V1))
 $(eval $(call MultiProfile,TLMR3420,TLMR3420V1))