fix rootfs and init script handling
[openwrt/staging/mkresin.git] / Makefile
index 8a052674b4d5c9b14d64b688532dd341a78d7f93..e035faac2598135a8ce418c793e8ef349f81a600 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -48,7 +48,7 @@ distclean: dirclean
 # check prerequisites before starting to build
 prereq: $(package/stamp-prereq) $(target/stamp-prereq) ;
 
-world: .config $(tools/stamp-install) $(toolchain/stamp-install) $(target/stamp-compile) $(package/stamp-compile) $(package/stamp-install) $(target/stamp-install) FORCE
+world: .config $(tools/stamp-install) $(toolchain/stamp-install) $(target/stamp-compile) $(package/stamp-cleanup) $(package/stamp-compile) $(package/stamp-install) $(package/stamp-rootfs-prepare) $(target/stamp-install) FORCE
        $(MAKE) package/index
 
 package/symlinks: