build: remove duplicate mksercomfw image recipe
[openwrt/staging/mkresin.git] / include / image-commands.mk
index 395e31f9947cc9e81bd2e01361162ca0c7bb794c..169c1919e7b56c02ff1ea46c97715e84141b342c 100644 (file)
@@ -49,6 +49,31 @@ define Build/eva-image
        mv $@.new $@
 endef
 
+define Build/seama
+       $(STAGING_DIR_HOST)/bin/seama -i $@ \
+               -m "dev=/dev/mtdblock/$(SEAMA_MTDBLOCK)" -m "type=firmware"
+       mv $@.seama $@
+endef
+
+define Build/seama-seal
+       $(STAGING_DIR_HOST)/bin/seama -i $@ -s $@.seama \
+               -m "signature=$(SEAMA_SIGNATURE)"
+       mv $@.seama $@
+endef
+
+define Build/zyxel-ras-image
+       let \
+               newsize="$(subst k,* 1024,$(RAS_ROOTFS_SIZE))"; \
+               $(STAGING_DIR_HOST)/bin/mkrasimage \
+                       -b $(RAS_BOARD) \
+                       -v $(RAS_VERSION) \
+                       -r $@ \
+                       -s $$newsize \
+                       -o $@.new \
+                       $(if $(findstring separate-kernel,$(word 1,$(1))),-k $(IMAGE_KERNEL)) \
+               && mv $@.new $@
+endef
+
 define Build/netgear-chk
        $(STAGING_DIR_HOST)/bin/mkchkimg \
                -o $@.new \
@@ -60,7 +85,7 @@ endef
 
 define Build/netgear-dni
        $(STAGING_DIR_HOST)/bin/mkdniimg \
-               -B $(NETGEAR_BOARD_ID) -v $(VERSION_DIST).$(REVISION) \
+               -B $(NETGEAR_BOARD_ID) -v $(VERSION_DIST).$(firstword $(subst -, ,$(REVISION))) \
                $(if $(NETGEAR_HW_ID),-H $(NETGEAR_HW_ID)) \
                -r "$(1)" \
                -i $@ -o $@.new
@@ -77,6 +102,10 @@ define Build/append-squashfs-fakeroot-be
        cat $@.fakesquashfs >> $@
 endef
 
+define Build/append-string
+       echo -n $(1) >> $@
+endef
+
 # append a fake/empty uImage header, to fool bootloaders rootfs integrity check
 # for example
 define Build/append-uImage-fakehdr
@@ -215,6 +244,11 @@ define Build/pad-offset
        mv $@.new $@
 endef
 
+define Build/xor-image
+       $(STAGING_DIR_HOST)/bin/xorimage -i $@ -o $@.xor $(1)
+       mv $@.xor $@
+endef
+
 define Build/check-size
        @[ $$(($(subst k,* 1024,$(subst m, * 1024k,$(1))))) -ge "$$(stat -c%s $@)" ] || { \
                echo "WARNING: Image file $@ is too big" >&2; \
@@ -243,6 +277,11 @@ define Build/openmesh-image
                "$(call param_get_default,rootfs,$(1),$@)" "rootfs"
 endef
 
+define Build/senao-header
+       $(STAGING_DIR_HOST)/bin/mksenaofw $(1) -e $@ -o $@.new
+       mv $@.new $@
+endef
+
 define Build/sysupgrade-tar
        sh $(TOPDIR)/scripts/sysupgrade-tar.sh \
                --board $(if $(BOARD_NAME),$(BOARD_NAME),$(DEVICE_NAME)) \
@@ -296,6 +335,12 @@ metadata_json = \
 
 define Build/append-metadata
        $(if $(SUPPORTED_DEVICES),-echo $(call metadata_json,$(SUPPORTED_DEVICES)) | fwtool -I - $@)
+       [ ! -s "$(BUILD_KEY)" -o ! -s "$(BUILD_KEY).ucert" -o ! -s "$@" ] || { \
+               cp "$(BUILD_KEY).ucert" "$@.ucert" ;\
+               usign -S -m "$@" -s "$(BUILD_KEY)" -x "$@.sig" ;\
+               ucert -A -c "$@.ucert" -x "$@.sig" ;\
+               fwtool -S "$@.ucert" "$@" ;\
+       }
 endef
 
 define Build/kernel2minor