valgrind: update to the latest version, fix build issues on ARM
[openwrt/staging/mkresin.git] / package / devel / valgrind / patches / 200-musl_fix.patch
index e61e822b2583751a62f879a66b751529a9e91b26..23d74e0caf3bf1191d3cfbd7ad0300319796a5aa 100644 (file)
@@ -6,21 +6,21 @@
  {
 -#  if !defined(__UCLIBC__) \
 +#  if !defined(__UCLIBC__) && defined(__GLIBC__) \
-    && !defined(VGPV_arm_linux_android) && !defined(VGPV_x86_linux_android) \
-    && !defined(VGPV_mips32_linux_android)
-    extern void __libc_freeres(void);
+       && !defined(VGPV_arm_linux_android) \
+       && !defined(VGPV_x86_linux_android) \
+       && !defined(VGPV_mips32_linux_android) \
 --- a/include/pub_tool_redir.h
 +++ b/include/pub_tool_redir.h
-@@ -241,7 +241,7 @@
+@@ -242,7 +242,7 @@
  /* --- Soname of the standard C library. --- */
  
- #if defined(VGO_linux)
+ #if defined(VGO_linux) || defined(VGO_solaris)
 -#  define  VG_Z_LIBC_SONAME  libcZdsoZa              // libc.so*
 +#  define  VG_Z_LIBC_SONAME  libcZdZa                // libc.*
  
  #elif defined(VGO_darwin) && (DARWIN_VERS <= DARWIN_10_6)
  #  define  VG_Z_LIBC_SONAME  libSystemZdZaZddylib    // libSystem.*.dylib
-@@ -273,7 +273,11 @@
+@@ -274,7 +274,11 @@
  /* --- Soname of the pthreads library. --- */
  
  #if defined(VGO_linux)
 +# endif
  #elif defined(VGO_darwin)
  #  define  VG_Z_LIBPTHREAD_SONAME  libSystemZdZaZddylib  // libSystem.*.dylib
- #else
+ #elif defined(VGO_solaris)
 --- a/configure.ac
 +++ b/configure.ac
-@@ -1025,8 +1025,6 @@ case "${GLIBC_VERSION}" in
-      *)
+@@ -1066,8 +1066,6 @@ case "${GLIBC_VERSION}" in
+       ;;
+      2.0|2.1|*)
        AC_MSG_RESULT([unsupported version ${GLIBC_VERSION}])
--      AC_MSG_ERROR([Valgrind requires glibc version 2.2 - 2.19])
--      AC_MSG_ERROR([or Darwin or Bionic libc])
+-      AC_MSG_ERROR([Valgrind requires glibc version 2.2 or later,])
+-      AC_MSG_ERROR([Darwin libc, Bionic libc or Solaris libc])
        ;;
  esac