openssl: move make depend call to Build/Configure
[openwrt/staging/mkresin.git] / package / libs / openssl / Makefile
index 19863fbf58af54b1317db0ac6b6f852932984126..fe99a534b84d98bd1f8e582150879856c33c6675 100644 (file)
@@ -121,11 +121,6 @@ define Build/Configure
                        $(OPENSSL_NO_CIPHERS) \
                        $(OPENSSL_OPTIONS) \
        )
-endef
-
-TARGET_CFLAGS += $(FPIC)
-
-define Build/Compile
        # XXX: OpenSSL "make depend" will look for installed headers before its own,
        # so remove installed stuff first
        -$(SUBMAKE) -j1 clean-staging
@@ -134,6 +129,11 @@ define Build/Compile
                OPENWRT_OPTIMIZATION_FLAGS="$(TARGET_CFLAGS)" \
                $(OPENSSL_MAKEFLAGS) \
                depend
+endef
+
+TARGET_CFLAGS += $(FPIC)
+
+define Build/Compile
        +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
                CC="$(TARGET_CC)" \
                ASFLAGS="$(TARGET_ASFLAGS) -c" \