ppp: backport security fixes
[openwrt/staging/mkresin.git] / package / network / services / lldpd / Makefile
index cffae63dfdb88b940b578f47ccb1f83d5d7fdf29..eb1fe6539d205f439505e9121bcd4329c3ef34e5 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2013 OpenWrt.org
+# Copyright (C) 2008-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,21 +8,20 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=lldpd
-PKG_VERSION:=0.7.10
-PKG_RELEASE:=1
+PKG_VERSION:=1.0.3
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://media.luffy.cx/files/lldpd
-PKG_MD5SUM:=508f2e76703abf8420d9223aae3db548
+PKG_SOURCE_URL:=https://media.luffy.cx/files/lldpd
+PKG_HASH:=39fced395168015416bfe78b95414facf066f841f349024433aa20ab54e4c360
 
-PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
+PKG_MAINTAINER:=Stijn Tintel <stijn@linux-ipv6.be>
 PKG_LICENSE:=ISC
 
 PKG_FIXUP:=autoreconf
+PKG_BUILD_PARALLEL:=1
 PKG_INSTALL:=1
 
-TARGET_CFLAGS+=--std=c99
-
 include $(INCLUDE_DIR)/package.mk
 
 define Package/lldpd
@@ -30,8 +29,8 @@ define Package/lldpd
   CATEGORY:=Network
   SUBMENU:=Routing and Redirection
   TITLE:=Link Layer Discovery Protocol daemon
-  URL:=https://github.com/vincentbernat/lldpd/wiki
-  DEPENDS:=+libevent2 +USE_EGLIBC:libbsd +LLDPD_WITH_JSON:libjson-c
+  URL:=https://vincentbernat.github.io/lldpd/
+  DEPENDS:=+libevent2 +USE_GLIBC:libbsd +LLDPD_WITH_JSON:libjson-c +LLDPD_WITH_SNMP:libnetsnmp
   USERID:=lldp=121:lldp=129
   MENU:=1
 endef
@@ -49,6 +48,14 @@ define Package/lldpd/description
        Link-Layer notifications to adjacent network devices.
 endef
 
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/liblldpctl.so* $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/lldpctl.h $(1)/usr/include/lldpctl.h
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/lldp-const.h $(1)/usr/include/lldp-const.h
+endef
+
 define Package/lldpd/install
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_DIR) $(1)/etc/lldpd.d
@@ -57,7 +64,7 @@ define Package/lldpd/install
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/lldp{cli,ctl,d} $(1)/usr/sbin/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/liblldpctl.so* $(1)/usr/lib/
        $(INSTALL_BIN) ./files/lldpd.init $(1)/etc/init.d/lldpd
-       $(INSTALL_DATA) ./files/lldpd.config $(1)/etc/config/lldpd
+       $(INSTALL_CONF) ./files/lldpd.config $(1)/etc/config/lldpd
 ifneq ($(CONFIG_LLDPD_WITH_CDP),y)
        sed -i -e '/cdp/d' $(1)/etc/init.d/lldpd $(1)/etc/config/lldpd
 endif
@@ -70,6 +77,9 @@ endif
 ifneq ($(CONFIG_LLDPD_WITH_SONMP),y)
        sed -i -e '/sonmp/d' $(1)/etc/init.d/lldpd $(1)/etc/config/lldpd
 endif
+ifneq ($(CONFIG_LLDPD_WITH_SNMP),y)
+       sed -i -e '/agentxsocket/d' $(1)/etc/init.d/lldpd $(1)/etc/config/lldpd
+endif
 endef
 
 define Package/lldpd/conffiles
@@ -77,16 +87,27 @@ define Package/lldpd/conffiles
 endef
 
 CONFIGURE_ARGS += \
+       $(if $(CONFIG_LLDPD_WITH_PRIVSEP), \
        --with-privsep-user=lldp \
        --with-privsep-group=lldp \
        --with-privsep-chroot=/var/run/lldp \
+       ,--disable-privsep) \
        --with-readline=no \
        --with-embedded-libevent=no \
+       --disable-hardening \
+       --without-xml \
+       --disable-doxygen-doc \
+       --sysconfdir=/tmp \
        $(if $(CONFIG_LLDPD_WITH_CDP),,--disable-cdp) \
        $(if $(CONFIG_LLDPD_WITH_FDP),,--disable-fdp) \
        $(if $(CONFIG_LLDPD_WITH_EDP),,--disable-edp) \
+       $(if $(CONFIG_LLDPD_WITH_LLDPMED),,--disable-lldpmed) \
+       $(if $(CONFIG_LLDPD_WITH_DOT1),,--disable-dot1) \
+       $(if $(CONFIG_LLDPD_WITH_DOT3),,--disable-dot3) \
+       $(if $(CONFIG_LLDPD_WITH_CUSTOM),,--disable-custom) \
        $(if $(CONFIG_LLDPD_WITH_SONMP),,--disable-sonmp) \
-       $(if $(CONFIG_LLDPD_WITH_JSON),--with-json=json-c)
-
+       $(if $(CONFIG_LLDPD_WITH_JSON),--enable-json0,) \
+       $(if $(CONFIG_LLDPD_WITH_SNMP),--with-snmp,) \
+       $(if $(CONFIG_USE_GLIBC),,--without-libbsd)
 
 $(eval $(call BuildPackage,lldpd))