force pcmcia-cs reconfiguration when the kernel configuration changes
[openwrt/staging/mkresin.git] / package / pcmcia-cs / Makefile
index 2e312fbf12ac1426efe72369b95a87a710b97a8d..6aca50fd78ef90cca9eced2ee42d70c84618d8fe 100644 (file)
@@ -30,6 +30,8 @@ define Package/pcmcia-cs
   URL:=http://pcmcia-cs.sourceforge.net/
 endef
 
+$(PKG_BUILD_DIR)/.configured: $(LINUX_DIR)/.config
+
 define Build/Configure
        ( cd $(PKG_BUILD_DIR); \
                ./Configure \
@@ -51,6 +53,8 @@ define Build/Configure
 endef
 
 define Build/Compile
+       rm -rf $(PKG_INSTALL_DIR)
+       mkdir -p $(PKG_INSTALL_DIR)
        $(call Build/Compile/Default, \
                CFLAGS="$(TARGET_CFLAGS)" \
                all install \